NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old May 21st, 2003, 13:23
wardxj wardxj is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: brownsburg, IN
Posts: 2
High idle

Hi my 87 jeep cherokee is going into high idle again. it sometimes idles at 2000 rpms as opposed to 500. Is the tps the only thing that will correct this. I changed it last year and it helped a lot. it has just started up again this week, and i hope i don't have to replace it again. thanks
matt
Reply With Quote
  #2  
Old May 21st, 2003, 13:24
wardxj wardxj is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: brownsburg, IN
Posts: 2
oh yeah

its a 4 liter sorry
Reply With Quote
  #3  
Old May 21st, 2003, 14:10
XJTripp XJTripp is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: eastern North Carolina
Posts: 154
Possible candidates:
1. Idle Air Solenoid- Clean it before considering replacement
2. Throttle body gunked from oil inhaled caused by a stopped up CCV tube. Clean the throttle body if it is black inside the bore. If it is black, remove CCV tube and clean and clean CCV gromet in valve cover.
3. Vaccum leak-trace out those plastic vac. lines
Reply With Quote
  #4  
Old May 21st, 2003, 17:26
PaulJ PaulJ is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Lynnwood, WA
Posts: 803
Do a search. You're not the only one.
Reply With Quote
  #5  
Old May 22nd, 2003, 08:01
XJTripp XJTripp is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: eastern North Carolina
Posts: 154
Cleaning the throttle body and the IAS eliminated my problem with high idle.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle - After Driving; Weird TPS... LynchMob OEM Tech Discussion 5 November 10th, 2003 16:41
High idle and emission maint light on HELP!?!?!?! shag OEM Tech Discussion 3 October 25th, 2003 21:22
High Idle still... BenXJCA OEM Tech Discussion 20 May 28th, 2003 02:28
Idle is high on 4.0l 88justin OEM Tech Discussion 6 April 14th, 2003 14:15
high idle problem frsno jeeper Sierra Chapter 6 January 12th, 2003 11:33


All times are GMT -7. The time now is 13:15.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014