NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old April 3rd, 2004, 09:04
88woody's Avatar
88woody 88woody is offline
NAXJA Forum User
 
Join Date: Feb 2004
Location: Maine
Posts: 104
Very High Idle

This started happening last Sunday.
I was out hitting the powerlines (very muddy). I went thru a puddle that was up to my doors. (very fun)
after I exited the puddle, I got out to survey what happened. (my brother was behind me) Out of habit, I turned the jeep off. When I started it back up, it revved to 3000, and stayed there. I checked most of the vacuum lines, I sprayed the tbi with some cleaner, I checked the air-box, and nothing seems to cure it.
Now, in the morning, it will start up just fine.(hover around 700-1000 rpm)
However, i deliver pizzas as a second job (nothing like 65 hours a week)
About an hour into running around, it comes back....
Sometimes it will shoot right up and then come down, other times it will stay right at 2000rpm. (customers really don't like that sound at 2a.m.)
Any ideas?
I'm going to assume that it is a bad idea to shift into reverse or drive when it is displaying these symptoms?

88 waggy, 4.0L
new: tps (no, i didn't calibrate it), MAP sensor, new exhaust from the manifold back.
I haven't gotten around to the 02 sensor
Reply With Quote
  #2  
Old April 3rd, 2004, 09:55
88woody's Avatar
88woody 88woody is offline
NAXJA Forum User
 
Join Date: Feb 2004
Location: Maine
Posts: 104
Re: Very High Idle

I know I'm being impatient....

Anybody?
Reply With Quote
  #3  
Old April 3rd, 2004, 10:02
sidriptide's Avatar
sidriptide sidriptide is offline
nobody of any consequence
 
Join Date: Mar 2003
Location: western massachusetts
Posts: 4,792
Re: Very High Idle

i have the same problem with my 87.. if the new TPS doesnt fix my problem i an gonna look for vacuum leaks....

mike
Reply With Quote
  #4  
Old April 3rd, 2004, 11:36
CheapXJ's Avatar
CheapXJ CheapXJ is offline
NAXJA Forum User
 
Join Date: Jun 2002
Location: 570, 813 or 303
Posts: 1,359
Re: Very High Idle

so calibrate the TPS!!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
High Idle and starting issue 89 XJer OEM Tech Discussion 3 December 10th, 2003 07:18
High Idle - After Driving; Weird TPS... LynchMob OEM Tech Discussion 5 November 10th, 2003 16:41
High Idle still... BenXJCA OEM Tech Discussion 20 May 28th, 2003 02:28
Idle is high on 4.0l 88justin OEM Tech Discussion 6 April 14th, 2003 14:15
high idle problem frsno jeeper Sierra Chapter 6 January 12th, 2003 11:33


All times are GMT -7. The time now is 11:02.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014