NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 4th, 2006, 21:09
Big Red's Avatar
Big Red Big Red is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Roscoe, IL 61073
Posts: 3,512
Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

I have a 91' 4.0L HO, AW4 auto 231 stock XJ with 180K miles. I can get it started and just replaced the battery in it because the old battery was bad. I just passed smog and used my portable jump start to jump my old battery and I cannot. So I go to the store and get a new battery, put it in and get under 1/2 mile down the road and it dies. I start it up, rev it, and when I put it into drive it just sputters and dies even if I punch the gas..over and over again for an hour. I just have to get my Jeep less than a mile to get it home and I have it sitting in a parking lot at the moment. I'm waiting a few hours for the streets to clear of traffic in Sacramento before I'm going to attempt to limp it home again. 1 thing I noticed is I have a ground wire mounted to the passenger fender that is stock, but it broke from the neg battery terminal, I electric tied it to it is making contact, but a few times the Jeep wouldn't turn over and then when I touched the neg ground fender wire to the battery post, it will start. But I cannot even get a few feet of starting the Jeep and then putting it into gear where it just dies

To make a long story short....I get my jeep started, I put in in gear and it dies. I just need to get it home and don't want to pay $60 or so for under a mile to have it towed. Any ideas???

thanks,

Troy
Reply With Quote
  #2  
Old February 5th, 2006, 04:21
Big Red's Avatar
Big Red Big Red is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Roscoe, IL 61073
Posts: 3,512
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

I waited till 4 a.m. incase I had to tow the XJ with my 98' ZJ. It started right up and I drove it home no problem.


I had this same thing happen to me when driving my brother-in-law's 91' XJ. It was fine on 4 miles of surface streets and on 6 miles of hwy, but as soon as I got off the highway on the exit ramp and had to stop at a the light it died and everytime I put in in gear it died. I finally got my rpms up in neutral and through it into drive and get the revs up to make it the mile to my bro's house. Other times it starts and runs no problems. Does anyone know what it could be that it cranks over and is fine in park and neutral and dies even with the gas pedal planted when putting it in a drive gear?
Reply With Quote
  #3  
Old February 5th, 2006, 06:36
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

You need to clean/replace the battery connectors, look closely at the smaller wire comming off the + terminal.
Reply With Quote
  #4  
Old February 5th, 2006, 10:06
Big Red's Avatar
Big Red Big Red is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Roscoe, IL 61073
Posts: 3,512
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

Quote:
Originally Posted by langer1
You need to clean/replace the battery connectors, look closely at the smaller wire comming off the + terminal.
My battery cables are pretty corroded. I just put a new battery in and tried to get off as much corrosion as I could without tools. I started the XJ up and it drove fine after letting it sit for 6 hrs. Really weird. Is this a 91' 4.0L HO thing because this is the only XJ year I have seen this happen? I have had 3 89's, 3 91's, 1 95 and 1 96' XJ.
Reply With Quote
  #5  
Old February 5th, 2006, 11:46
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

Itís a common problem, you know where to start. Whats happening is your starting off the battery but running on the alternator because of a bad a connection.
As soon as you try to put it in gear your RPM is too low to stay running
Reply With Quote
  #6  
Old February 5th, 2006, 12:43
Big Red's Avatar
Big Red Big Red is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Roscoe, IL 61073
Posts: 3,512
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

Thanks langer1, I'll get some baking soda and a good brush and clean up those battery connections. What about the wire that mounts to the passenger side fender? Is that a main ground of some sort? The wire originally was connected to the negative battery connector, but it broke off and I tried as best I could with no tools to strip the wire protector off to get a decent connection. Many times I got the Jeep started, but then it would die in idle, I only had good luck starting it again once I got the fender wire connected to the neg. I let it sit for 6 hrs because I was waiting for the traffic to be way down incase I had to tow it with my ZJ, but it fired right up and I drove it the mile back home.
Reply With Quote
  #7  
Old February 5th, 2006, 14:33
langer1's Avatar
langer1 langer1 is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: Mineral City,Ohio
Posts: 5,006
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

The only thing I can tell you s it it's there you need it.
Someone may have added that one.
You also need a wire terminal brush to clean the clamps, if the are the bolt-on universal type get rid of them.
Here are some ground pictures on XJ's.
http://www.naxja.org/forum/showthread.php?t=76515

Last edited by langer1; February 5th, 2006 at 14:38.
Reply With Quote
  #8  
Old February 5th, 2006, 17:34
Big Red's Avatar
Big Red Big Red is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Roscoe, IL 61073
Posts: 3,512
Re: Jeep keeps dying when I put it in gear, starts in neutral and park, then dies...

You the man langer1, thanks alot.

Troy
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 04:18.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014