NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old August 9th, 2020, 19:48
McBergs McBergs is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: Canada
Posts: 14
Electrical or fuel starting problem

So recently bought an xj and putting quite a bit of work into it. Sometimes it just wonít start but not that often. Most of the time I just crank the wheel to the left while turning the key and then it starts, or Iíll just slowly turn it until it starts (important to note that it will cut out sometimes).

Today I wanted to see what happened if I just held the key and after about 5 seconds it just started. Not sure if turning the wheel even did anything before and it might have just been a coincidence that it started when I cranked it left. Read a post here that says something about the fuel pump check valve which seems to make sense, however Iím not sure if thatís consistent with the starter cutting out sometimes. Any help or advice is appreciated, thanks guys.

(Forum post https://www.jeepforum.com/forum/f11/...1500915/?amp=1 )
Reply With Quote
  #2  
Old August 10th, 2020, 06:23
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 13,954
Re: Electrical or fuel starting problem

What years and specs?
Reply With Quote
  #3  
Old August 10th, 2020, 12:12
McBergs McBergs is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: Canada
Posts: 14
Electrical or fuel starting problem

Quote:
Originally Posted by RCP Phx View Post
What years and specs?

98 5 speed 4x4. Just did spark plugs and wires but nothing to fuel like the fuel pump and didnít pressure test it.


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old August 11th, 2020, 09:17
Agreen Agreen is offline
NAXJA Forum User
 
Join Date: Nov 2016
Location: Charleston
Posts: 139
Re: Electrical or fuel starting problem

Even if the check valve has gone bad it'll still start. It might run a little rough at first until fuel pressure comes up, but it'll start.
If it's just not starting (and intermittently) try replacing the CPS. It's a likely culprit, but I'm absolutely not saying it's the problem for sure. You have to catch it in a no-start condition and see if it's spark or fuel causing it to not start. There's a schrader valve on the fuel rail. You can depress the valve stem to see if there's pressure, but don't do it on a hot engine (since the exhaust is right below). If you're going to test spark, do so before checking fuel pressure. If you suspect injector pulse, use an LED light and not an incandescent test light.
Reply With Quote
  #5  
Old August 11th, 2020, 10:58
McBergs McBergs is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: Canada
Posts: 14
Electrical or fuel starting problem

Iíll certainly look into it. Would that cause a code as well?


Sent from my iPhone using Tapatalk
Reply With Quote
  #6  
Old August 11th, 2020, 18:02
Agreen Agreen is offline
NAXJA Forum User
 
Join Date: Nov 2016
Location: Charleston
Posts: 139
Re: Electrical or fuel starting problem

Maybe, maybe not. I don't know what parameters it looks for to set the CPS engine light. I work on many models, so it's hard to keep track of which one does specifically what. However, they're all (generally) the same idea. I've had CPS codes when the car had no other issue, and I've had cars not start due to a faulty CPS and not throw any codes. I've also had to diagnose random misfire codes when there was no discernable misfire. I do know, however, that the CPS is a particularly troublesome part on pretty much every 4.0 jeep, so given the symptoms it's a likely culprit.
Reply With Quote
  #7  
Old August 11th, 2020, 18:45
McBergs McBergs is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: Canada
Posts: 14
Electrical or fuel starting problem

Quote:
Originally Posted by Agreen View Post
Maybe, maybe not. I don't know what parameters it looks for to set the CPS engine light. I work on many models, so it's hard to keep track of which one does specifically what. However, they're all (generally) the same idea. I've had CPS codes when the car had no other issue, and I've had cars not start due to a faulty CPS and not throw any codes. I've also had to diagnose random misfire codes when there was no discernable misfire. I do know, however, that the CPS is a particularly troublesome part on pretty much every 4.0 jeep, so given the symptoms it's a likely culprit.

Thatís weird that a CPS would have anything to do with the position of the steering wheel, Iíll check with a multimeter as well when I look into it. Thanks for the help!


Sent from my iPhone using Tapatalk
Reply With Quote
  #8  
Old August 12th, 2020, 04:03
Agreen Agreen is offline
NAXJA Forum User
 
Join Date: Nov 2016
Location: Charleston
Posts: 139
Re: Electrical or fuel starting problem

It doesn't. I'm guessing it's either a coincidence that turning the wheel helped or you may have bare wires touching the steering shaft.

When I worked for Dodge I had a Neon come to the shop because every time he turned left it would die. We could NOT reproduce the issue. Turns out the customer had driven the car until the gas was almost empty and was losing fuel pressure. I mean EMPTY. Then he filled up before bringing it to us. We all spent hours trying to diagnose the issue and eventually told him to call us when it happened again. We sent a tech out to him and that's when he saw the gas gauge was pegged low.

Regardless, check the wiring and see if something is chaffing.
Reply With Quote
  #9  
Old August 19th, 2020, 13:18
McBergs McBergs is offline
NAXJA Forum User
 
Join Date: Jul 2020
Location: Canada
Posts: 14
Electrical or fuel starting problem

Well I found the problem, turns out I had to jam the clutch as hard as I could for it to start. Even if it was to the floor the safety switch wouldnít make the connection, I had to literally stand on the clutch. Thanks for help anyways haha


Sent from my iPhone using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cherokee multiple cranks, starting issue. Very unusual starting / fuel issue. Intellect OEM Tech Discussion 6 November 17th, 2017 09:48
Fuel Pump Electrical Problem Rob Crouch OEM Tech Discussion 1 August 3rd, 2009 16:42
electrical problem PLEASE HELP, no fuel no starter no acc redrider2911 OEM Tech Discussion 12 July 21st, 2009 21:51
Small Starting/Electrical problem...maybe Blue96XJ OEM Tech Discussion 6 October 25th, 2007 16:27
Intermittent starting problem - fuel? or something else? br1anstorm OEM Tech Discussion 15 March 7th, 2007 15:47


All times are GMT -7. The time now is 21:29.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014