NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 5th, 2019, 11:34
rain164845 rain164845 is offline
NAXJA Forum User
 
Join Date: Sep 2019
Location: Usa
Posts: 39
Fuel pump problem

So, I replaced my fuel pump and gas tank 100 miles ago. The fuel pump is ac Delco and it has started HOWLING. The only thing that stops it is taking a hard left turn. After a left turn it is quiet for about 5 seconds.
Any ideas?
Thanks!

Sent from my SM-G975U using Tapatalk
Reply With Quote
  #2  
Old October 5th, 2019, 20:10
rain164845 rain164845 is offline
NAXJA Forum User
 
Join Date: Sep 2019
Location: Usa
Posts: 39
Fuel pump problem

Also, it takes a while for the whole to start from cold. Maybe a few minutes

Sent from my SM-G975U using Tapatalk
Reply With Quote
  #3  
Old October 6th, 2019, 06:14
CJR CJR is offline
NAXJA Forum User
 
Join Date: May 2005
Location: PA
Posts: 207
Re: Fuel pump problem

Many, many years ago my fuel pump started making noise. I did a search and found that this vibration had a fix requiring fuel pump removal and the removal of some sheet metal. I decided to run it until it failed. That was about 200,000 miles ago and it's still running. Likewise, the noise eventually went away. That was my experience.

Best regards,

CJR
Reply With Quote
  #4  
Old October 7th, 2019, 04:28
rain164845 rain164845 is offline
NAXJA Forum User
 
Join Date: Sep 2019
Location: Usa
Posts: 39
Fuel pump problem

I figured out part of the problem. I thought the gas gauge was broken. Turns out that it really was empty. I filled it up and it still makes a racket. I'll test the pressure and go from there.


Sent from my SM-G975U using Tapatalk
Reply With Quote
  #5  
Old October 7th, 2019, 19:30
rain164845 rain164845 is offline
NAXJA Forum User
 
Join Date: Sep 2019
Location: Usa
Posts: 39
Fuel pump problem

You know, maybe the whine is where I bypassed the fuel pump ballast and I'm overworking the thing.

Sent from my SM-G975U using Tapatalk
Reply With Quote
  #6  
Old October 8th, 2019, 16:42
Rob Mayercik's Avatar
Rob Mayercik Rob Mayercik is offline
NAXJA Member #920
 
Join Date: Jun 2002
Location: NJ, U.S.A.
Posts: 2,319
Re: Fuel pump problem

The ballast resistor? Not having it shouldn't be any strain on the pump, the XJ was designed to run without one. It was only added to make the pump quieter.

I deleted mine something like 10 years back, never noticed a difference.
__________________
1992 Cherokee Laredo: "A wonderful balance of grace and rust"
1984 Dodge Omni
2002 Volkswagen Jetta GLS TDI
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Yes another fuel pump problem Nwcharger OEM Tech Discussion 1 August 24th, 2015 19:44
Fuel pump problem? JBurian OEM Tech Discussion 4 April 18th, 2012 04:27
Fuel pump problem rredalty OEM Tech Discussion 2 October 28th, 2008 12:35
fuel pump problem vegeta OEM Tech Discussion 3 September 26th, 2008 17:06
88 xj fuel pump problem! dustin88 OEM Tech Discussion 2 June 11th, 2007 21:30


All times are GMT -7. The time now is 02:58.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014