NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old August 13th, 2019, 11:42
Rod Knee's Avatar
Rod Knee Rod Knee is offline
NAXJA Member
 
Join Date: Apr 2007
Location: Grand Jct., CO
Posts: 1,335
Rough idle problem with blower motor malfunction

Iím having a strange issue with my xj. Six weeks ago frame stiffeners were welded to the jeep at local shop. A rough idle was immediately noticed. A mechanic I took the vehicle to corrected a vacuum leak and I thought the problem had been rectified. Then while offroading, the idling problem reoccurred and blower stopped working simultaneously once it started raining. I have hood louvers.
The strange thing is the rough idle only occurs when the vehicle is in D and the switch for the blower motor for a/c and heat in the cab is not on the off position. The vehicle stalls in this situation when braking for a stop sign. I can make this problem disappear by turning the air conditioning/heater/defrost/vent switch to the off position.
Anybody had a similar experience? From my understanding the blower motor and idle control have nothing to do with each other. The throttle body is clean and so is the IAC sensor. I replaced the blower motor and resistor yesterday. Maybe the welding on of the frame stiffeners resulted in a wiring problem (?). The problem occurs immediately upon starting the vehicle when cold so I'm thinking its not heat soak effecting the injectors.
Any ideas?

1996 xj, automatic transmission, 4L straight 6
Reply With Quote
 


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
replaced heater core, now blower motor problem YFZsandrider OEM Tech Discussion 5 August 20th, 2013 20:26
Blower Motor Problem sixty7ss OEM Tech Discussion 20 September 2nd, 2012 13:04
New Blower motor problem.... and I searched Cherikon OEM Tech Discussion 2 September 28th, 2011 21:25
ZJ blower motor problem RNMedic Tow Rigs and Trailers 0 January 26th, 2011 16:46
2000 XJ Blower Motor/Circuit Problem tsc OEM Tech Discussion 0 February 10th, 2005 18:37


All times are GMT -7. The time now is 22:53.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014