NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 10th, 2007, 19:12
pressurerat's Avatar
pressurerat pressurerat is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Tennessee
Posts: 78
87 XJ engine just dies....help!

I have an 87 XJ 4.0 auto. While driving, the engine has started to just cut off and die, just like a switch was turned off. Everything else electrical still works. At first when it died the engine would restart right away. The last time it happened took 30 minutes before it would start. This problem just started three days ago and never happened before at all. It has done it about 6 or 7 times now with no apparent reason. There is no spark when dead, but plenty of fuel. What are the main culprits I need to check?
Reply With Quote
  #2  
Old March 10th, 2007, 19:51
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,064
Re: 87 XJ engine just dies....help!

Quote:
Originally Posted by pressurerat
I have an 87 XJ 4.0 auto. While driving, the engine has started to just cut off and die, just like a switch was turned off. Everything else electrical still works. At first when it died the engine would restart right away. The last time it happened took 30 minutes before it would start. This problem just started three days ago and never happened before at all. It has done it about 6 or 7 times now with no apparent reason. There is no spark when dead, but plenty of fuel. What are the main culprits I need to check?
Ignition switch, TPS sensor, loose wire or connector anywhere in the entire ignition circuit. Tough one to track down until it quites entirely, or unless you find an obvious burned/burning wire somewhere.
Reply With Quote
  #3  
Old March 10th, 2007, 21:37
scca28 scca28 is offline
NAXJA Forum User
 
Join Date: Dec 2005
Location: N.E.Philadelphia
Posts: 210
Re: 87 XJ engine just dies....help!

My '88 did the same thing for a few months after I got it. One day when it would not restart,stuck in traffic, I just started unplugging and reconnecting every plug under the hood. I don't know which plug fixed it, but when I got home I went through each plug, using contact cleaner, and needle nose pliers for squeezing down on the female contacts. Haven't had the problem since last summer. It's the easiest ( and cheapest) thing to do before you start testing for bad components, which you could mis-diagnose anyway if you have a bad connection somewhere.
Reply With Quote
  #4  
Old March 11th, 2007, 06:40
pressurerat's Avatar
pressurerat pressurerat is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Tennessee
Posts: 78
Re: 87 XJ engine just dies....help!

Thanks for teh input. I'm about 400 miles away from home is the crappy thing! I'm heading back this morning and I guess I need to check a couple of things.....bad part is I can't check till I'm broke down! Oh well. at least I have an 'extra' hour of daylight for my trip. The Haynes manual and voltmeter are in hand............I'll post back if I figure something out.
Reply With Quote
  #5  
Old March 11th, 2007, 21:49
pressurerat's Avatar
pressurerat pressurerat is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Tennessee
Posts: 78
Exclamation Re: 87 XJ engine just dies....help!

Ok....I think i narrowed it down to the coil or the ICM. When I tap on the coil with a wrench, the Jeep will start running again. I made it all the way home doing this for 400 miles. It stopped 5 or 6 times, but I made it. My question is: what years will the icm interchange with? Is it a Renix only piece or what? I'm going to the U-pull it yard tomorrow to try and find one.
Reply With Quote
  #6  
Old March 12th, 2007, 07:54
pressurerat's Avatar
pressurerat pressurerat is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Tennessee
Posts: 78
Re: 87 XJ engine just dies....help!

bump
Reply With Quote
  #7  
Old March 12th, 2007, 12:56
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,064
Re: 87 XJ engine just dies....help!

Quote:
Originally Posted by pressurerat
Ok....I think i narrowed it down to the coil or the ICM. When I tap on the coil with a wrench, the Jeep will start running again. I made it all the way home doing this for 400 miles. It stopped 5 or 6 times, but I made it. My question is: what years will the icm interchange with? Is it a Renix only piece or what? I'm going to the U-pull it yard tomorrow to try and find one.
Looks like the 86 -99 spark coil is the same. For the ICM check an online store like autozone for an 87, 92, and 97 year ICM to see if the part number changed!

It sounds more like a bad, loose connection than a bad part! Remove the coil from the ICM and clean and tighten the input connections (which are hidden under the coil) to the coil and see if that fixes the problem! Also clean and tighten the connector(s) to the ICM.
Reply With Quote
  #8  
Old March 15th, 2007, 07:17
pressurerat's Avatar
pressurerat pressurerat is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Tennessee
Posts: 78
Re: 87 XJ engine just dies....help!

I found a ICM/coil at the boneyard for $6.50 plus tax, it fixed the problem. It turned out not to be the connection or the wire harness, I cleaned and checked it. Thanks for all the input!
Reply With Quote
  #9  
Old March 15th, 2007, 08:16
skipc's Avatar
skipc skipc is offline
NAXJA Forum User
 
Join Date: Jul 2004
Location: Georgia & points west and south
Posts: 305
Re: 87 XJ engine just dies....help!

It actually sounds like it had been a bad ground at the coil. Could have been a bad coil, but 99% more likely the ground. Putting a new one in 'freshened up' the contacts and teh body connection. Bad grounding is the worst problem in the pre-91 XJs I've found.

BTW, a CPS that goes bad or needs to be reconnected won't make it quit. The Renix will keep going and estimate things. It's only during start that it needs good signal. It may not run perfectly, but it won't quit.

-Skip
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
engine dies soon after start... supergildo OEM Tech Discussion 2 December 18th, 2006 06:59
engine dies DurbElites OEM Tech Discussion 12 November 2nd, 2006 18:45
'00 XJ Engine cuts out and dies Craig OEM Tech Discussion 23 October 25th, 2005 21:55
No muffler, engine dies at 40 mph Chancer Tow Rigs and Trailers 7 January 20th, 2005 06:54
engine dies Steven Bills OEM Tech Discussion 2 October 14th, 2003 19:20


All times are GMT -7. The time now is 11:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014