NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 25th, 2006, 17:19
90xj06's Avatar
90xj06 90xj06 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: Peabody, MA
Posts: 1,742
Lightbulb magical xj

every time its time to get inspected my reverse lights work. but right when i get back home they stop. spooky then refuse to work until the day i need it inspected. till then i never have lights. its like it takes 365 days to "recharge" them to make them work.
Reply With Quote
  #2  
Old August 25th, 2006, 19:25
JeepFreak91 JeepFreak91 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: NC
Posts: 37
Re: magical xj

more than likely your neutral safety switch needs to be cleaned. if this is an auto there was a write up on here some where and you can clean it yourself.
Reply With Quote
  #3  
Old August 25th, 2006, 19:42
Tally_XJ Tally_XJ is offline
NAXJA Forum User
 
Join Date: Mar 2005
Location: Tallahassee, Florida
Posts: 267
Re: magical xj

Hmmm...if that is exactly correct, that your reverse lights only work once a year, then I suspect its not what you think.

How do you know your reverse lights are not working when you think they arent working?

Is the key switched ON when you select reverse position?

Is someone standing behind the Jeep checking the lights?

Maybe the light lenses are fogged with moisture and you just cant tell they are working at night?

The Neutral Safety switch definitely has the reverse circuit in it, and it cured my problems when I cleaned mine.
Reply With Quote
  #4  
Old August 25th, 2006, 20:32
90xj06's Avatar
90xj06 90xj06 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: Peabody, MA
Posts: 1,742
Re: magical xj

i have put a light in by my left knee with a manual switch occasionally it will go on but its kind of a hit or miss. i could be out there all day trying to get the darn thing off the tranny and then 3 days later they work. i may have exaggerated in when they work but every time i need a sticker they work.
i have tried to get the nss off and gave up. if i went at it any longer i would brake it or something else. so it starts up all the time. so its just seens to be the reverse function. and it doesn't start in any other gears other than park and neutral.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hey One-fuzz....magical cutting discs? Beezil Non-Tech / Off Topic 15 October 17th, 2003 11:19


All times are GMT -7. The time now is 18:07.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014