NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #16  
Old February 14th, 2018, 03:47
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,167
Re: Need some help.. Starting issue

Quote:
Originally Posted by in_motion View Post
... are there other bands that will work?
Most auto parts stores sell cheap crappy Chinese made parts, some that even come with a " Lifetime Warranty ". These parts are poorly manufactured and/or made from inferior materials. They are often out of specification, or even failed, right out of the box. The ones that are not faulty many times will have a short service life before they fail. Always buy top quality replacement parts and genuine Jeep engine sensors. Numerous threads detail long and frustrating searches for a "problem" that ended up being cured simply with genuine Jeep repair parts.

Cheap parts are cheap for a reason.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

I'm starting to realize people on the Jeep forums are highly expert mechanics .....
Reply With Quote
  #17  
Old February 18th, 2018, 23:20
Ou2mame Ou2mame is offline
NAXJA Forum User
 
Join Date: Apr 2016
Location: Long island, ny
Posts: 157
Need some help.. Starting issue

Ended up really simple.. I figured I would do a tune up even though the cap wires and plugs were only a couple years old.. Found this.

That'll do it! I had my mechanic do the cps after he said he checked it over. He had it for over a week! I don't go to him for much, maybe I need to start going to someone else. I would have done the cps myself but we just moved into our new house and when it broke down it was snowing and parked in the mud, and i didn't even have my tools unpacked yet. Lesson learned. Anyways thanks for the suggestion though. I'll be more prepared next time




Sent from my iPhone using Tapatalk
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cherokee multiple cranks, starting issue. Very unusual starting / fuel issue. Intellect OEM Tech Discussion 6 November 17th, 2017 09:48
'93 XJ STARTING ISSUE MEEMERS Modified Tech Discussion 14 February 14th, 2014 17:25
94 XJ starting issue MIKE.94XJ OEM Tech Discussion 7 July 20th, 2011 13:43
Random non starting issue to not starting at all XJ project Arizona Chapter 11 April 20th, 2009 08:37
Starting issue Jeff-97XJ OEM Tech Discussion 1 July 16th, 2008 17:38


All times are GMT -7. The time now is 23:55.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014