NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old September 4th, 2014, 09:34
nrwphoto nrwphoto is offline
NAXJA Forum User
 
Join Date: Jun 2009
Location: Appleton, WI
Posts: 125
Raw fuel coming out exhaust at idle

My 98' 4.0 drives down the road fine once it clears it's throat but when at idle the exhaust smell is really strong and it stumbles dropping cylinders and sprays a mist of unburnt fuel out the exhaust pipe. Of course mileage has dropped to 9.5mpg.

The O2 sensors are 2.5 years old but only have about 10k of mileage over them. Computer shows a Lean Code for Bank 1 and PO107 Generic (Manifold absolute pressure/ Baro Sensor Low Input)

Any suggestions on where to start?

Here are my numbers using an Innova 3140 scan tool

Air temp 101
#'s at Idle
_______ Engine Cold _______ Engine Warm
FS 1 ______ CL ______________ CL
FS 2 ______ N/A _____________ N/A
Load ______ 5.9% ____________ 5.9%
ECT F ______ 120 ____________ 199
STFT ______ 21.7 - 32.8 _______ 32.8
LTFT ______ 32 ______________ 32
MAP ______ 17.4 _____________ 13.3 - 17.4
RPM ______ 740 - 800 _________ 693 - 775
Spark Adv _ 8-18 _____________ 6 - 18.5
IAT F ______ 115 _____________ 156
TPS % _____ 14.9 ____________ 14.9
O2S B1 _____ 0 _______________ 0
STFT B1 ____ 22.7 - 32.8 ______ 22.7 - 32.8
O2S B2 _____ 1.02 ___________ .98 - 1
STFT B2 ____ 99.2 ____________ 99.2

Last edited by nrwphoto; September 4th, 2014 at 09:39.
Reply With Quote
  #2  
Old September 4th, 2014, 10:38
Digger87xj's Avatar
Digger87xj Digger87xj is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Buffalo Creek/Lakewood CO
Posts: 2,033
Re: Raw fuel coming out exhaust at idle

O2 bank one at zero. No good. bad sensor or sensor wire is shorted to ground fooling the PCM into thinking engine is running lean.

You can read the results of that in that the STFT 32 % rich. PCM is commanding a rich exhaust, and see also O2 bank 2 running at .98 to 1v (full rich) yet the B1S1 is still reading 0v, so the PCM threw a P0171
Reply With Quote
  #3  
Old September 5th, 2014, 09:20
nrwphoto nrwphoto is offline
NAXJA Forum User
 
Join Date: Jun 2009
Location: Appleton, WI
Posts: 125
Re: Raw fuel coming out exhaust at idle

Thanks I appreciate it. I didn't think the 0 was good but I couldn't remember what the proper ranges are suppose to be. Looks like I am heading out to chase wires and if that looks good replacing the up stream O2 sensor.
Reply With Quote
  #4  
Old September 5th, 2014, 09:25
scottmcneal scottmcneal is offline
NAXJA Member
 
Join Date: Mar 2007
Location: not here
Posts: 18,570
Re: Raw fuel coming out exhaust at idle

Make sure when you're done to change your oil. I bet it smells just like gas.
Reply With Quote
  #5  
Old September 8th, 2014, 20:52
nrwphoto nrwphoto is offline
NAXJA Forum User
 
Join Date: Jun 2009
Location: Appleton, WI
Posts: 125
Re: Raw fuel coming out exhaust at idle

Thanks for the added suggestion scottmcneal

Well I replaced the upstream O2 sensor with a new one this evening and still no change on the scan tool. Still reading 0. So other than chasing wires hoping to find a broken/exposed wire grounding out kind of thing. Any other ideas on what to look for? Thanks again.
Reply With Quote
  #6  
Old September 9th, 2014, 09:29
Digger87xj's Avatar
Digger87xj Digger87xj is offline
NAXJA Forum User
 
Join Date: Mar 2004
Location: Buffalo Creek/Lakewood CO
Posts: 2,033
Re: Raw fuel coming out exhaust at idle

that's all that's left aside from a failed PCM
Reply With Quote
  #7  
Old September 24th, 2014, 20:08
CharlesS's Avatar
CharlesS CharlesS is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Quezon Province, Philippines
Posts: 2,466
Re: Raw fuel coming out exhaust at idle

Check the MAP sensor and its wiring to see if there is a problem.
The MAP sensor is attached to the drivers side of the throttle body towards the rear.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Steam coming from exhaust MrAnderson OEM Tech Discussion 7 January 11th, 2013 21:18
white smoke and water coming out of exhaust blazinjames OEM Tech Discussion 12 February 22nd, 2010 09:09
Exhaust pipe coming off header. XJ_Otto OEM Tech Discussion 5 February 17th, 2009 22:08
Jet flame coming out of my exhaust Tyquan OEM Tech Discussion 8 March 22nd, 2008 14:44
Flames coming out of my exhaust!! Tyquan OEM Tech Discussion 12 March 22nd, 2008 09:11


All times are GMT -7. The time now is 02:50.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014