NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 21st, 2008, 23:32
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Question help oring filter adapter , still leaks after instaling new orings?

well i need some advice. I have just put new orings on the adapter for the oil filter twice today and it still leaks. the second time i took it back off
i made sure it lined up good and even used some orange rtv but it still leaks so im baffeled if anyone has done this recently or has any bright ideas please let me know thank 91 xj 4.0 h0.
Reply With Quote
  #2  
Old March 22nd, 2008, 03:51
91XJRubicXD's Avatar
91XJRubicXD 91XJRubicXD is offline
NAXJA Forum User
 
Join Date: Jan 2008
Location: Staten Island, NY
Posts: 231
Re: help oring filter adapter , still leaks after instaling new orings?

Quote:
Originally Posted by mramr1974
well i need some advice. I have just put new orings on the adapter for the oil filter twice today and it still leaks. the second time i took it back off
i made sure it lined up good and even used some orange rtv but it still leaks so im baffeled if anyone has done this recently or has any bright ideas please let me know thank 91 xj 4.0 h0.
Sounds to me like you have the wrong filter. If you look on the firewall on the passenger side of the truck, there may be a sticker regarding the upgrade of the oil filter threads. I have a 91 Cherokee and I have this in mine. Wrong threads even though it may screw down can easily cause the leaking. I'll give you a pic of the sticker I am referring of :
Reply With Quote
  #3  
Old March 22nd, 2008, 05:59
90Blue_XJ's Avatar
90Blue_XJ 90Blue_XJ is offline
NAXJA Forum User
 
Join Date: Jun 2005
Location: In yer postz fixin yer spellinz.
Posts: 2,512
Re: help oring filter adapter , still leaks after instaling new orings?

I don't think he's talking about the filter leaking but the adapter that bolts up to the block where the filter screws on to. The above diagram only details the oil filter onto that adapter.

Check that the complete old O-ring is out of the groove on both surfaces of the adapter. A small piece of the old ring still in there will keep it from sealing tightly.
Reply With Quote
  #4  
Old March 22nd, 2008, 06:40
icewolf73's Avatar
icewolf73 icewolf73 is offline
NAXJA Forum User
 
Join Date: Jun 2006
Location: Carrollton, TX
Posts: 259
Re: help oring filter adapter , still leaks after instaling new orings?

I just changed the o-rings in my '91. All I can tell you is make sure you have the correct ones (a Jeep dealer gave me the wrong ones) and make sure the bolt is tightened down well.
Reply With Quote
  #5  
Old March 22nd, 2008, 07:39
garr garr is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Nassau County NY
Posts: 1,421
Re: help oring filter adapter , still leaks after instaling new orings?

I just repaired my Leaking 01.
Make sure you soak the new "O" rings in fresh motor oil for a little while before installation. The ones on the E-Bolt (The large torx head bolt) need to spin during installation. And tighten it down good, But do not use a 3ft piece of pipe to tighten it down, You do not want to crush the big "O" ring.

I wonder if the large "O" ring is necessary? Would some RTV work in place of it? What do you guys think?
Reply With Quote
  #6  
Old March 22nd, 2008, 07:47
Narfxj Narfxj is offline
NAXJA Forum User
 
Join Date: Jun 2006
Location: Florida
Posts: 128
Re: help oring filter adapter , still leaks after instaling new orings?

I once read a post here that a guy did the same thing replaced the O-ring a couple times and still was leaking. In his case the oil pump was bad and was blowing out the new o ring. Hopefully in your case you just got the wrong O-ring. But just in case
Reply With Quote
  #7  
Old March 22nd, 2008, 10:49
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Re: help oring filter adapter , still leaks after instaling new orings?

thanks for the info im sure there the right o rings I checked them aginst the originals, i throughly cleaned out the original oings until the adapter sparckeld before i put in the new ones. i did pre oil them . i didnt letem soak though. but i do have that sticker , the filter i have on is what the book calls for, does that mean that sticker makes whats in the book incorrect ?the filter that on it is also the same one that was on it before i changed out the adapter . I guess it could be that simple but how could i tell if the filter is wrong? Im a nubie if you couldnt tell
Reply With Quote
  #8  
Old March 22nd, 2008, 10:56
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Re: help oring filter adapter , still leaks after instaling new orings?

i kinda dumbhow doi tell if the filter is wrong ?
Reply With Quote
  #9  
Old March 22nd, 2008, 11:12
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Re: help oring filter adapter , still leaks after instaling new orings?

well its not the filter i called the parts store the number on the sticker is the filter i got. i have to just take it apart again
Reply With Quote
  #10  
Old March 22nd, 2008, 14:12
garr garr is offline
NAXJA Forum User
 
Join Date: Dec 2007
Location: Nassau County NY
Posts: 1,421
Re: help oring filter adapter , still leaks after instaling new orings?

Is it leaking from the filter gasket?
where the large "O" ring mates the 2 surfaces?
Or from where the big torx head bolt mates to the adapter?

If it is leaking from the filter gasket it is probably the wrong filter.
Leaking from the other locations & it is probably a damaged or misaligned "O" ring.
Reply With Quote
  #11  
Old March 23rd, 2008, 00:58
Yucca-Man's Avatar
Yucca-Man Yucca-Man is offline
NAXJA Member # 683
 
Join Date: Jul 2003
Location: Castle Rock, CO
Posts: 6,251
Re: help oring filter adapter , still leaks after instaling new orings?

Leaving the old gasket on the adapter when you remove the old filter will also cause leaking. That's not uncommon, and should definitely be something to look at.

Out of curiosity, just what filter do you have on there? Parts houses aren't exactly sources of reliable information. You've got the horizontal filter, right? That can also trade that out for a larger filter (another 1/2-quart of oil capacity, and additional filter surface area) - http://www.yuccaman.com/jeep/filter.html

So where's the leak coming from?

Jim www.yuccaman.com
Reply With Quote
  #12  
Old March 23rd, 2008, 12:04
praetorian praetorian is offline
NAXJA Forum User
 
Join Date: Sep 2005
Location: La Mirada, CA
Posts: 537
Re: help oring filter adapter , still leaks after instaling new orings?

When I replaced my o-rings my engine dripped oil for another two weeks since the engine was extremely saturated with oil. Also how do you know its coming from the oil adapter? Could it be for rear main seal or valve cover leaking?
Reply With Quote
  #13  
Old March 23rd, 2008, 20:39
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Re: help oring filter adapter , still leaks after instaling new orings?

the leak looks like its coming where the filter adapter conects to the block .i couldnot see anywhere where the filter itself was leaking .im just about ready to go out and retest in a bit i think possibly i didnt have the pin in the block lined up in the right hole on the adapter theres two holes there 1 goes no where other goes up to filter i may have had in the hole that go to the filter i preaty sure thats the wrong one the pin just keeps it from moving when you tighten it.
Reply With Quote
  #14  
Old March 23rd, 2008, 20:40
mramr1974's Avatar
mramr1974 mramr1974 is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: idaho
Posts: 29
Re: help oring filter adapter , still leaks after instaling new orings?

ps mines just a 5/8 bolt
Reply With Quote
  #15  
Old March 23rd, 2008, 22:19
xj2win's Avatar
xj2win xj2win is offline
NAXJA Forum User
 
Join Date: Jun 2007
Location: MonTana
Posts: 153
Re: help oring filter adapter , still leaks after instaling new orings?

Quote:
Originally Posted by garr
I just repaired my Leaking 01.
Make sure you soak the new "O" rings in fresh motor oil for a little while before installation. The ones on the E-Bolt (The large torx head bolt) need to spin during installation. And tighten it down good, But do not use a 3ft piece of pipe to tighten it down, You do not want to crush the big "O" ring.

I wonder if the large "O" ring is necessary? Would some RTV work in place of it? What do you guys think?
Soaking the O-rings in oil sounds like a horrible idea, since that's what makes the adapter leak - years of hot oil against them eventually breaks down the rubber.
<br>
OP: If you're using the correct size O-ring and tightening it down correctly, it shouldn't leak. Be sure and clean the mating surfaces while you have it apart, and I'd just go ahead and put a nice bead of high temp RTV around all the O-rings. I've taken mine apart before and couldn't find one size of the O-ring, so I just RTV'd the whole thing really good and drove it like that for about two months before I got time to fix it again, it never leaked during the time.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
oil filter adapter shameless defect OEM Tech Discussion 10 June 26th, 2006 16:28
oil filter adapter scotttruhart OEM Tech Discussion 4 March 15th, 2006 18:54
4.0 Oil Filter Adapter REDSWAG OEM Tech Discussion 17 January 23rd, 2006 23:15
89 4.0 leaks oil, pan, filter housing, main RangerRick OEM Tech Discussion 11 December 8th, 2004 15:17
Oil filter adapter? Jeepster4wd OEM Tech Discussion 16 February 27th, 2004 00:15


All times are GMT -7. The time now is 12:20.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014