NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old January 6th, 2007, 13:15
PosiDave PosiDave is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: PA
Posts: 149
Voltage drop (Searched). Please help.

A little after thanksgiving I replaced my altenator and battery. The Altenator was bad but the battery was really old. I was making my 3 hour trip home this weekend and my Voltage dropped and it sits right above the red. The generator light came on. I didn't wanna have another break down so I drove the hour home and grabbed my other truck. I cleaned did a few things.
-Cleaned terminals
- Checked the altenator
- checked the ground on fender
- Checked tension of the belt

my oil pan has a leak by the starter and I cleaned those a little but didnt disconenct and reconnect.
The belt doesnt make any noises.
But the battery gauge is still right on the border of the red. Should I just switch the cable and go from there?

Its a 4.0 HO, Manual, with 232K. The Starter and selinoid were also replaced at 216k. The Battery Cables I do not know when they wer elast changed if ever.
Reply With Quote
  #2  
Old January 6th, 2007, 14:07
shelbyluvv's Avatar
shelbyluvv shelbyluvv is offline
NAXJA Forum User
 
Join Date: Dec 2003
Location: 29 Palms, CA
Posts: 2,642
Re: Voltage drop (Searched). Please help.

Check the cables first. They could be old and have to much resistance. I would then turn to the starter. I had a old Caprice that did the same thing every couple weeks. Changed the alt, battery, and cables and the problem still happened. I too had an oil leak right onto the starter. I changed it and never had the problem again. Try to spray some brake cleaner in the starter and let it completely dry before you try starting it. I may just be all the oil in it is causing it to pull down your charging system.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
voltage drop jeepnuts311 OEM Tech Discussion 5 January 2nd, 2007 08:53
Voltage drop on 01 XJ mudfun OEM Tech Discussion 7 June 5th, 2006 16:40
Voltage Drop juicexj24 OEM Tech Discussion 3 June 1st, 2006 05:18
voltage drop Andy in Co. OEM Tech Discussion 6 October 26th, 2003 19:32
ac and voltage drop? XJHOX Modified Tech Discussion 3 June 25th, 2003 18:34


All times are GMT -7. The time now is 05:01.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014