NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old July 12th, 2017, 07:44
Jimmothyb Jimmothyb is offline
NAXJA Forum User
 
Join Date: Jun 2017
Location: JBLM WA
Posts: 1
Turn signals not working

I have a 1990 jeep cherokee 4.0L manual and 2 days ago my turn signals stoped working. My hazards work just fine so it's not any of the bulbs and since then I've replaced the fuse, flasher relay and the turn signal switch and still no luck and the old fuse was blown and there was light corrosion on the contacts. The turn signal switch looked in good condition.
Reply With Quote
  #2  
Old July 12th, 2017, 07:52
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,159
Turn signals not working

I would check the fuse is getting power.
Could just be poor contact with the fuse.
I had trouble with turn signal relay when I put led bulbs in the tail lights. After I bought a new relay that didn't mind the led bulbs the turn signals worked fine.

I believe the renix c101 plug that could cause so many problems was eliminated by 1990.

If brake lights and turn signal were out then it could be a power line that attached at the batter terminal. Some times they corrode.



Sent from my iPhone using Tapatalk
Reply With Quote
  #3  
Old July 13th, 2017, 12:32
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,287
Re: Turn signals not working

Probably, since the old fuse blew, and the new fuse did not blow, then some where the power wire shorted to ground and melted the wire, so it is now an open circuit. Is the new fuse getting power. Is power getting to the other side of the new fuse? Is power getting to turn signal switch.

Time to follow the power wire to the point where the power dies.

Quote:
Originally Posted by Jimmothyb View Post
I have a 1990 jeep cherokee 4.0L manual and 2 days ago my turn signals stoped working. My hazards work just fine so it's not any of the bulbs and since then I've replaced the fuse, flasher relay and the turn signal switch and still no luck and the old fuse was blown and there was light corrosion on the contacts. The turn signal switch looked in good condition.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #4  
Old March 10th, 2019, 11:04
trooper06977 trooper06977 is offline
NAXJA Forum User
 
Join Date: Mar 2019
Location: Manteno Il
Posts: 1
Re: Turn signals not working

I have a 69 cherokee I had bad brake light switch replaced it replaces turn signal switch in columb all bulbs and multi flasher cube and still have no turn sognals or 4 way flashers
Reply With Quote
  #5  
Old April 7th, 2019, 11:24
crofoot crofoot is offline
NAXJA Forum User
 
Join Date: Nov 2005
Location: woodinville wa
Posts: 36
Re: Turn signals not working

I fought this problem for a while till i found that there are two flashers,one for 4 way and one for turn signals.I know it's simple but be sure you have changed the correct one.
Reply With Quote
  #6  
Old April 15th, 2019, 18:06
four_shot's Avatar
four_shot four_shot is offline
How 'bout it Gonzo
 
Join Date: Jul 2003
Location: Waukegan, IL
Posts: 720
Re: Turn signals not working

Make sure the terminals in the fuse box are good. The clutch master likes to leak into the fuse box and cause corrosion. The terminals will crack and appear to make contact. While in reality they are open circuit.
__________________
....
4shot
"Babs" 97 sport 4.0 aw4
R.I.P."Buster" 86 laredo 2.8 ax5 10/85-9/17
In memory of Dave "Gonzo" Steele 1975-2008
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Turn signals not working flingshot OEM Tech Discussion 1 June 22nd, 2016 18:53
99 with non-working turn signals Ben824 OEM Tech Discussion 6 November 4th, 2012 19:38
Turn signals only working for 1-5 flashes NYPDJeep OEM Tech Discussion 8 November 23rd, 2007 10:32
Turn signals not working quite right...help?! CoastieJ OEM Tech Discussion 4 June 29th, 2007 22:27
All 4 turn signals stopped working Maz OEM Tech Discussion 14 June 18th, 2005 08:26


All times are GMT -7. The time now is 21:14.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014