NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old February 21st, 2021, 15:06
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Need help after installing radio

Hi everyone, first off I apologize if this is t the right spot for this; first time XJ owner and first time posting. I recently bought a 99 XJ that was in fairly good condition. Very minimal rust, mechanically sound, outside the normal oil drip and completely stock. So I am excited to have a project to make my own. Now this isnít a daily driver and I wasnít looking to drop a grand in stereo, just upgrade the factory. So I installed an advanced auto $50 single din that has blue tooth and replaced the front door speakers. My issue is this, after replacing the stock radio and passenger speaker I hooked the battery back up to test it. When I did the horn started blaring and I heard the door locks cycle. Immediately disconnected the power and scratched my head. I used a wire harness for my XJ and didnít splice or cut any other wires. Went ahead and finished the driver speaker and still same thing. I put the power back on and I hear the locks cycle and the horn just honks. Any suggestions?
Reply With Quote
  #2  
Old February 21st, 2021, 16:25
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 7,297
Re: Need help after installing radio

Aftermarket remote start or security system ?

Failure of drivers door and tailgate wire harness is very common, and often leads to 12 volts positive short circuiting to other wires in the wire harness or to ground. Assuming the install was done correctly, I would begin with a visual inspection of both the door wire harnesses and some basic voltage and continuity testing of the door wire harness.


.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper


Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Reply With Quote
  #3  
Old February 21st, 2021, 17:39
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

No aftermarket remote start or security system that I can tell. Didnít come with fobs just two factory keys. Also from what I was able to tell Iím only the 3rd owner, second being the mom and pop car shop I bought it off of. I wired everything right, followed the wiring diagram as stated, plus matching red to red, orange to orange etc is kinda hard to mess up Iíd think. I did put an interior panel back on the lift gate, it didnít have one and the wires and such were just zip tied to it. Problem started prior to removing driver door panel and worked fine before installation of radio. Iíll have to dive into the tailgate wiring and see if I did something there. Thanks for giving me some direction to start in.
Reply With Quote
  #4  
Old February 21st, 2021, 18:51
JonnyCat63 JonnyCat63 is offline
NAXJA Member
 
Join Date: Apr 2015
Location: San Diego
Posts: 190
Re: Need help after installing radio

Not sure if this will work, but you can try it.

I know my example is not an XJ, but it's worth a try.

I have a 93 F250, and every time I disconnect and reconnect the battery, the alarm goes off. All I do is insert the key into the ignition and turn it on. Don't start the vehicle, just turn the key to on. It immediately turns the alarm off and everything works as normal after that.

I don't have the fobs for this truck either and never use the alarm, but it does it every time regardless. Yours sounds like an alarm issue to me.
Reply With Quote
  #5  
Old February 22nd, 2021, 06:24
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

Thanks Iíll give that a try as well when I get home tomorrow. When I do start the Jeep she does kind of sputter and stagger which she didnít do before. So maybe anti theft is an issue. 🤷🏼*♂️ Iíll try that check harnesses and advise you fine folks what happens.I donít mind pulling the fuse for the horn and rolling without it but itís the fear of parasitic load and killing my battery that worries me. Thanks again.
Reply With Quote
  #6  
Old February 24th, 2021, 12:14
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

Well the key in run position didn’t help. Checked the driver side door harness and it appears to be in good shape. The tailgate was pretty bad with exposed wires so I reworked that harness. Alas still hear locks cycle and horn blows when battery is reconnected. I figured since this all started post radio install why not unhook it. So I I did my wire harness from factory wire harnesses and still same issue. I’m at a complete loss as to what to do.
Reply With Quote
  #7  
Old February 24th, 2021, 12:20
RCP Phx RCP Phx is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 14,541
Re: Need help after installing radio

[QUOTE=LedXJ99;246722276] Iím at a complete loss as to what to do./QUOTE]

Don't buy a stereo from Advanced when you could get a good for the same price and buy the wiring harness adapter (it's plug-n-play).
Reply With Quote
  #8  
Old February 24th, 2021, 12:26
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

The wiring harness adapter I bought is plug and play. The “hooking it up” portion was from the aftermarket radio wires to the said harness. No cutting of factory wires happened. And again, after disconnecting the radio the problem persists.
Reply With Quote
  #9  
Old February 24th, 2021, 14:38
Unclewolverine Unclewolverine is offline
NAXJA Forum User
 
Join Date: Jun 2019
Location: Kansas
Posts: 321
Re: Need help after installing radio

Almost guaranteed it has a alarm/rke hidden somewhere.
Reply With Quote
  #10  
Old February 24th, 2021, 15:18
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

I havenít the faintest idea what to look for with that.
Reply With Quote
  #11  
Old February 24th, 2021, 16:18
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 7,297
Re: Need help after installing radio

Often poor installation workmanship is your first clue, loose wires running everywhere behind the dash, along with lots of black electrical tape, Walmart grade wire taps, and crimp-on butt connectors. The control unit will be very close to the steering column.


The wires in the door wire harness are good ?
__________________
.
.

Quote:
Originally Posted by bimmerjeeper


Go ahead and slam the liftgate down on a blanket, and see how long you are laughing.
Reply With Quote
  #12  
Old February 24th, 2021, 17:49
LedXJ99 LedXJ99 is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: Burnsville
Posts: 7
Re: Need help after installing radio

Yes the wires in the driver harness appear in good shape. I pulled the boot back and examined it. Iíll pull the kick plates and go up under the dash in the driver side next day Iím at home and see if I can see any random wires that donít look as though they should be there. I appreciate all the help everyone. Hopefully I can find something.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Complete CB radio set up with CB radio, antenna, mount, and cable john_yarbrough SoCal For Sale 0 December 13th, 2013 12:48
help installing cb radio hebertracing Modified Tech Discussion 5 December 26th, 2011 18:03
FS: OEM Radio (radio,cd, tape combo) out of a 98 Sport dan42green NAC Classifieds 10 August 8th, 2010 23:39
Radio Shack Mini CB Radio fast64 SEC For Sale / Wanted Forum 0 July 8th, 2008 19:29
Radio fuse short found, ?What radio to put in? 2lazy2p OEM Tech Discussion 13 June 19th, 2008 06:42


All times are GMT -7. The time now is 04:10.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014