NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 20th, 2021, 15:33
Sgtscrooge Sgtscrooge is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: British columbia canada
Posts: 2
87 RENIX cherokee low rough idle when cold and high idle when warmed up

Howdy, so ive been scowering old forum threads for a long time trying to figure out my issue but i just seem to have ALL of them. So i decided to finally
Register an account and ask myself. First of all, i have an 87í cherokee cheif running the origional Renix system with a 92í block. It allways starts up, gets me
Where ever i want to go and brings me back home too. So here the issue, ever since i baught the jeep, its allways had some idle issues. When its cold it has a slight missfire. It also needs to be given throttle to start or it will just go down to really low rpm sputter and die. And second, once its warmed up it idles in park at around 2,000 rpm, i can smell that it seems To be running on the rich side. Along with theese things the transmission doesnt like to shift until about 4,000 rpm under very little load. My next moves are to replace the MAP sensor, the TPS sensor and the IAC sensor and see where that gets me, ive also read that i should clean the factory grounds as they were a bit sub par.
Reply With Quote
  #2  
Old February 20th, 2021, 18:24
tjmotter's Avatar
tjmotter tjmotter is online now
NAXJA Member
 
Join Date: Sep 2011
Location: Houston
Posts: 476
Re: 87 RENIX cherokee low rough idle when cold and high idle when warmed up

Do all of those things but also check to ensure that the intake manifold bolts are tight.
Reply With Quote
  #3  
Old February 20th, 2021, 21:02
ljobbins ljobbins is offline
NAXJA Member
 
Join Date: Mar 2016
Location: SD County
Posts: 223
87 RENIX cherokee low rough idle when cold and high idle when warmed up

You have a renix system so first check all the sensors before just replacing. This site has testing instructions. http://www.lunghd.com/Tech_Index.htm

But temp related sounds to me like leak that seals up as the metal expands. If you havenít done seafoam or the like that works wonders for finding leaks in the exhaust as it will smoke if there is carbon on the pistons. BUT seafoam will kill your o2 sensor and possibly clog up a cat if itís really bad. I had a lot of corrosion in the old splices and connectors when I had a renix and I completely went through the entire electrical system and redid all the bad spots and the car ran better with updated grounds and wires.


Sent from my iPhone using Tapatalk
Reply With Quote
  #4  
Old February 20th, 2021, 23:43
Sgtscrooge Sgtscrooge is offline
NAXJA Forum User
 
Join Date: Feb 2021
Location: British columbia canada
Posts: 2
Re: 87 RENIX cherokee low rough idle when cold and high idle when warmed up

Quote:
Originally Posted by ljobbins View Post
You have a renix system so first check all the sensors before just replacing. This site has testing instructions. http://www.lunghd.com/Tech_Index.htm

But temp related sounds to me like leak that seals up as the metal expands. If you havenít done seafoam or the like that works wonders for finding leaks in the exhaust as it will smoke if there is carbon on the pistons. BUT seafoam will kill your o2 sensor and possibly clog up a cat if itís really bad. I had a lot of corrosion in the old splices and connectors when I had a renix and I completely went through the entire electrical system and redid all the bad spots and the car ran better with updated grounds and wires.


Sent from my iPhone using Tapatalk

Thanks for that link, saved me from buying manuals. thats probably the most helpful resource ive found so far, tomorrow morning im gonna go over and test the sensors and re-do my grounds, the emissions system on mine uh stopped working so i dont really need to worry about that what type of seafoam? because there is a spray type and a liquid type right? and the only other thing i was maybe thinking of if it doesnt get fixed was maybe if i could somhow put a holley efi system on it and completley remove the bendix stuff.
Reply With Quote
  #5  
Old February 21st, 2021, 06:04
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,820
Re: 87 RENIX cherokee low rough idle when cold and high idle when warmed up

Before wasting any time on other things, go to www.cruiser54.com and complete Tips 1 through 5. Checking the intake manifold manifold bolts to make sure they're snug is also an excellent idea.

Please report back after that and we can guide you further if needed. Tip 1 in particular is in play here, but don't skip the others.
Reply With Quote
  #6  
Old February 21st, 2021, 06:16
ljobbins ljobbins is offline
NAXJA Member
 
Join Date: Mar 2016
Location: SD County
Posts: 223
87 RENIX cherokee low rough idle when cold and high idle when warmed up

Check the sensors, do cruisers tips, check the intake/exhaust bolts FIRST. And you say that there is no emission stuff which I presume means you removed yourself. In that case make sure that you properly sealed vacuum tubes and electrical connectors or everything that you modified. An unsealed egr plate or leaking vacuum tube or connector grounding itself out by bouncing around sending false signals to the computer.


Sent from my iPhone using Tapatalk
Reply With Quote
  #7  
Old Yesterday, 10:02
8Mud's Avatar
8Mud 8Mud is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Central Germany
Posts: 8,618
Re: 87 RENIX cherokee low rough idle when cold and high idle when warmed up

I think you likely have multiple issues going on. Before you buy a new IAC clean out the IAC well and seat. Put a drop or two of penetrating oil down the IAC plunger shaft. Don't mess with the plunger at all, don't try to move it.
Then ohm test your TPS ground from the ground to battery minus. Then adjust the TPS. Be careful of the TPS screws, wiggle them before you try to loosen. If you manage to get them out without snapping one off, grease (or anti-seize) the threads before reinstalling. You may need a new TPS but it is worth a try to get a good ground and adjust it first. TPS hates water or most any other liquid.
Buying parts and hoping to get lucky is often the least rewarding way of solving issues. The connectors in the Renix are notorious for being corroded, the corrosion can mess with the sensor feeds, the same with the grounds.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1987 Cherokee Renix 4.0 - rough Idle/misfire Godenades OEM Tech Discussion 63 December 16th, 2015 17:30
Rough idle, then high idle when warm. Renegade_Azzy OEM Tech Discussion 11 March 19th, 2013 11:49
high idle - 90 Cherokee - RENIX NCSU90XJ OEM Tech Discussion 10 September 19th, 2011 17:47
'98 Rough Idle and CEL when warmed up sgtpepper OEM Tech Discussion 5 January 19th, 2007 12:32
4.0 ZJ rough cold idle AndyS Tow Rigs and Trailers 14 September 1st, 2004 07:50


All times are GMT -7. The time now is 19:15.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014