NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 9th, 2019, 18:14
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Engine missfiring when accelerating and at idle

So my jeep was running a bit rough and I suspected the stock injectors needed upgrading. I since installed the 4 hole injectors, new fuel pump, new fuel filter, new fuel regulator, new cap & rotor, new spark plugs & wires. Only engine code is 12 because I disconnected the battery to weld a crack I found on the exhaust manifold. Injector seem to be clicking when I listed with mechanic stethoscope. I am stumped as to why this thing is not running well because compression test was between 167-179 psi on cylinders?
Reply With Quote
  #2  
Old February 9th, 2019, 19:57
SleeperXJ's Avatar
SleeperXJ SleeperXJ is offline
NAXJA Forum User
 
Join Date: May 2009
Location: Valencia, CA
Posts: 541
Re: Engine missfiring when accelerating and at idle

My wife's Rubicon showed the same symptoms.
I used a bluetooth obd 2 scanner in test mode to
determine a tps fault. I tried replacing the coil rail
which indicated a low resistance reading across a
secondary coil. This wasn't the culprit.
Try to find the cause before you take the shotgun
approach. Ot could save some cash.
Reply With Quote
  #3  
Old February 9th, 2019, 20:46
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Re: Engine missfiring when accelerating and at idle

My 4.0 is OBD1 so a scanner is no help. Thinking my timing chain might be stretched since itís been 100k since I last replaced it or the crack in my exhaust manifold may have damaged my O2 sensor. I plan to drive it a while to see if the computer throws a code.
Reply With Quote
  #4  
Old February 9th, 2019, 21:07
SleeperXJ's Avatar
SleeperXJ SleeperXJ is offline
NAXJA Forum User
 
Join Date: May 2009
Location: Valencia, CA
Posts: 541
Re: Engine missfiring when accelerating and at idle

It could... sorry couldn't either my post.
CPS is another possibility. How many miles on your jeep?
Reply With Quote
  #5  
Old February 10th, 2019, 10:00
JohnX's Avatar
JohnX JohnX is offline
Sarge <3 Ben
 
Join Date: Nov 2004
Location: Rancho Cucamonga CA
Posts: 9,457
Re: Engine missfiring when accelerating and at idle

Should probably post in OEM tech.

However, start by finding which cylinder it is. Buy a cheap infrared temp. gun at harbor freight. Check each pipe while running.....looking for one that is cooler than the rest. Then you can test compression, spark plug, plug wire, and injector for that cylinder.
Test by moving one part at a time (trading with another cylinder). When you get to the faulty part, the colder pipe will change with it.
__________________
Praise Marty Moose!
Reply With Quote
  #6  
Old February 10th, 2019, 11:33
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Re: Engine missfiring when accelerating and at idle

Quote:
Originally Posted by JohnX View Post
Should probably post in OEM tech.

However, start by finding which cylinder it is. Buy a cheap infrared temp. gun at harbor freight. Check each pipe while running.....looking for one that is cooler than the rest. Then you can test compression, spark plug, plug wire, and injector for that cylinder.
Test by moving one part at a time (trading with another cylinder). When you get to the faulty part, the colder pipe will change with it.
Thanks, I'll try the heat gun!
Reply With Quote
  #7  
Old February 10th, 2019, 11:36
sidewaysstarion's Avatar
sidewaysstarion sidewaysstarion is offline
Coffee Drinker
 
Join Date: Jan 2012
Location: Torrance, CA
Posts: 2,786
Re: Engine missfiring when accelerating and at idle

Since I'm guessing you have a 94 xj? If you're up for it I can help you diagnose it.
__________________
Quote:
Originally Posted by cracker
I seem to have run out of self tapping washers
99 4.0/AW4/231, with a few basic bolt ons.

Click here to support
Reply With Quote
  #8  
Old February 10th, 2019, 16:56
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,264
Re: Engine missfiring when accelerating and at idle

Was the Ex-manifold/O2 sensor installed on the block when you welded? Might have fried a sensor or ground?

But it sounds like a bad TPS or ground or connector, or a Vacuum leak at the MAP sensor vacuum hose between the MAP and throttle body. Both would common causes.

Quote:
Originally Posted by 94sport View Post
So my jeep was running a bit rough and I suspected the stock injectors needed upgrading. I since installed the 4 hole injectors, new fuel pump, new fuel filter, new fuel regulator, new cap & rotor, new spark plugs & wires. Only engine code is 12 because I disconnected the battery to weld a crack I found on the exhaust manifold. Injector seem to be clicking when I listed with mechanic stethoscope. I am stumped as to why this thing is not running well because compression test was between 167-179 psi on cylinders?
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #9  
Old February 11th, 2019, 16:14
blu3fan's Avatar
blu3fan blu3fan is offline
NAXJA Forum User
 
Join Date: Apr 2009
Location: california
Posts: 327
Re: Engine missfiring when accelerating and at idle

CPS, TPS, Grounds. Kickdown adjustment. fuel pressure regulator.
check these first.
Reply With Quote
  #10  
Old February 11th, 2019, 16:32
blu3fan's Avatar
blu3fan blu3fan is offline
NAXJA Forum User
 
Join Date: Apr 2009
Location: california
Posts: 327
Re: Engine missfiring when accelerating and at idle

oh also. since your is a 94. make sure you do not still have the dreaded fuel pump ballast.
if you do. Smash it with a hammer and solder those two wires together... and curse the man who decided 12volts to the fuel pump is too loud... meh.
Reply With Quote
  #11  
Old February 11th, 2019, 18:50
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Re: Engine missfiring when accelerating and at idle

Thanks everyone for the advice! After throwing lots of time, money, and parts at this I dropped the jeep off at a local mechanic to diagnose this afternoon. I have 2 XJ's and this one is a 92 limited.
Reply With Quote
  #12  
Old February 14th, 2019, 19:22
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Re: Engine missfiring when accelerating and at idle

So the mechanic said the 4 hole injectors I bought as a upgrade were actually causing a run rich condition and the fuel pump I installed from AZ he said was not delivering enough fuel pressure which I doubt however I let him swap it out and my O2 sensor was not working because of a relay between the fuse box and battery that went bad.

My jeep now has a new fuel pump, fuel regulator, fuel filter, clean stock injectors, cps, cap, rotor, wires, plugs, oil & filter, alternator, and a catalytic converter.

I hope I get another 100,000 miles out of her.
Reply With Quote
  #13  
Old February 15th, 2019, 12:08
SleeperXJ's Avatar
SleeperXJ SleeperXJ is offline
NAXJA Forum User
 
Join Date: May 2009
Location: Valencia, CA
Posts: 541
Re: Engine missfiring when accelerating and at idle

Good to hear it's running well. Thanks for posting the findings as well
Reply With Quote
  #14  
Old February 15th, 2019, 12:51
Rob Mayercik's Avatar
Rob Mayercik Rob Mayercik is offline
NAXJA Member #920
 
Join Date: Jun 2002
Location: NJ, U.S.A.
Posts: 2,145
Re: Engine missfiring when accelerating and at idle

Just out of curiosity, what 4-hole injectors did you have in there that were overfueling? I have Bosch 703s in my '92 and they work great, no misfires.
__________________
1992 Cherokee Laredo: "A wonderful balance of grace and rust"
1984 Dodge Omni
2002 Volkswagen Jetta GLS TDI
Reply With Quote
  #15  
Old February 16th, 2019, 07:08
94sport 94sport is offline
NAXJA Forum User
 
Join Date: Dec 2010
Location: Whittier
Posts: 111
Re: Engine missfiring when accelerating and at idle

These are the ones I bought off of eBay. Hopefully you can get the website from this:

https://rover.ebay.com/rover/0/e1105...&sojTags=bu=bu
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine cuts out when accelerating glenmac OEM Tech Discussion 1 November 4th, 2013 22:54
Engine idle problems after engine rebuild (extremely high) SicNastyXJ OEM Tech Discussion 3 January 6th, 2012 16:46
What causes an engine not to idle? Cottontail Tow Rigs and Trailers 10 November 17th, 2010 12:01
3500-3800 RPM missfiring/bogging out? AJTorris OEM Tech Discussion 26 January 14th, 2010 14:36
Jeep missfiring and fire out of the exhaust!! Please HELP!! 89cherokee89 OEM Tech Discussion 21 November 21st, 2008 18:03


All times are GMT -7. The time now is 06:58.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014