NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 9th, 2019, 07:47
Lanser1999 Lanser1999 is offline
NAXJA Member
 
Join Date: Nov 2018
Location: Wisconsin
Posts: 28
2001 Jeep cherokee misfire/runs rough!!!

I have been chasing this issue for a few months now and it is becoming very annoying.
To start off with my jeep never starts on first try, probably the check valve not a big deal. However, everytime I cold start my jeep it will run rough/misfire for a while unless I shut it back off and restart it, then it will run fine. When its warm it runs fine but my fuel mileage hasn't been that great. Any help would be appreciated trying to have this resolved before Winterfest.

I also have a intermittent loud tea kettle noise coming from inside my engine bay, cant find it and is driving me up the wall!!


I also have a new coil pack, and new spark plugs.
Reply With Quote
  #2  
Old February 9th, 2019, 10:56
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,485
Re: 2001 Jeep cherokee misfire/runs rough!!!

Define and explain "fuel mileage hasn't been that great" ? What brand and type of spark plugs are installed ? A 30-40% drop in gas mpg's should make one suspect O2 sensor issues. Have you tested the O2 sensors and sensor fuses ? Have you had the battery Load tested and cleaned/snugged all the battery and alternator connections ? Rough starts can be a faulty check valve, and/or can be one or more drippy fuel injectors.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

I'm starting to realize people on the Jeep forums are highly expert mechanics .....
Reply With Quote
  #3  
Old February 10th, 2019, 07:11
Lanser1999 Lanser1999 is offline
NAXJA Member
 
Join Date: Nov 2018
Location: Wisconsin
Posts: 28
Re: 2001 Jeep cherokee misfire/runs rough!!!

Roughly 10 mpg, I have 2 new o2 sensors. I have copper spark plugs. I have not lid tested battery but connections are snug and clean.
Reply With Quote
  #4  
Old February 10th, 2019, 07:24
Agreen Agreen is offline
NAXJA Forum User
 
Join Date: Nov 2016
Location: Charleston
Posts: 24
Re: 2001 Jeep cherokee misfire/runs rough!!!

The whistling noise leads me to believe that you have a vacuum leak. Grab a can of carb cleaner (or some brake cleaner) and spray around the intake manifold to locate any vacuum leaks.
Reply With Quote
  #5  
Old February 10th, 2019, 07:55
Tim_MN's Avatar
Tim_MN Tim_MN is offline
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,485
Re: 2001 Jeep cherokee misfire/runs rough!!!

Checked all the O2 sensor fuses, and inspected the O2 sensor wire plugs and wire harnesses for corrosion and damage ? Any bent or pushed back wire plug pins ?



Quote:
Originally Posted by Lanser1999 View Post
Roughly 10 mpg, I have 2 new o2 sensors.....
Doesn't the 2001 have 4 O2 sensors ?

Bosch or NTK O2 sensors ? It is well proven that the OBD-II Jeep 4.0L and Bosch O2 sensors do not play well together and that Bosch O2 sensors commonly cause the CEL to illuminate and/or cause drivability issues.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

I'm starting to realize people on the Jeep forums are highly expert mechanics .....

Last edited by Tim_MN; February 10th, 2019 at 07:58.
Reply With Quote
  #6  
Old February 10th, 2019, 12:22
Lanser1999 Lanser1999 is offline
NAXJA Member
 
Join Date: Nov 2018
Location: Wisconsin
Posts: 28
Re: 2001 Jeep cherokee misfire/runs rough!!!

Replaced with Bosch then had to replace with NTK. It has 4 o2 sensors. I’ll have to check the fuses, but CEL is not on. Another thing is when I cold start it and it runs rough if I hold the RPMS around 2k the misfire clears up.
Reply With Quote
  #7  
Old February 10th, 2019, 12:36
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 12,023
Re: 2001 Jeep cherokee misfire/runs rough!!!

Have you ever replaced the injectors?
Reply With Quote
  #8  
Old February 10th, 2019, 12:38
Lanser1999 Lanser1999 is offline
NAXJA Member
 
Join Date: Nov 2018
Location: Wisconsin
Posts: 28
Re: 2001 Jeep cherokee misfire/runs rough!!!

I haven’t replaced the injectors yet. Was trying to gather information on how to test them/ how to tell.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 Cherokee misfire when cold Lanser1999 OEM Tech Discussion 20 December 22nd, 2018 17:27
1987 Cherokee Renix 4.0 - rough Idle/misfire Godenades OEM Tech Discussion 63 December 16th, 2015 16:30
cherokee runs rough, backfire, missfire, etc 89Cherokee95 OEM Tech Discussion 30 July 18th, 2014 13:57
1993 cherokee very rough idle/misfire offroadxj07 OEM Tech Discussion 3 January 26th, 2011 16:50
89 cherokee 4.0 runs rough nynatv OEM Tech Discussion 11 July 30th, 2009 17:05


All times are GMT -7. The time now is 07:00.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014