NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 9th, 2018, 23:58
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Member
 
Join Date: Nov 2008
Location: colorado, severance
Posts: 691
High idle in park

I went wheeling today, mostly in 4low. I came to a couple stops and put the jeep in park and the RPMs idled up above 10000. This happened a few times, but not every time it was in park.
Is this likely the IAC?

Thanks
Reply With Quote
  #2  
Old October 10th, 2018, 06:28
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,486
Re: High idle in park

Year?

When's the last time you cleaned your throttle body and IAC?
Reply With Quote
  #3  
Old October 10th, 2018, 17:33
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Member
 
Join Date: Nov 2008
Location: colorado, severance
Posts: 691
Re: High idle in park

99 216000

Cleaned about a year ago. It was driven roughly 2hr before putting it in park, snowy weather. Being that this was inconsistent, I don't think it's a vacuum leak.

I also don't want to just throw new money at the IAC unless it's a very good bet that's the issue.

This far it hasn't reproduced the symptoms in town.
Reply With Quote
  #4  
Old October 10th, 2018, 17:43
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,486
Re: High idle in park

Did you remove the throttle body and thoroughly clean it? Remove the IAC as well?
Reply With Quote
  #5  
Old October 11th, 2018, 01:38
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Member
 
Join Date: Nov 2008
Location: colorado, severance
Posts: 691
Re: High idle in park

Not as of yet, I shall this weekend.
Reply With Quote
  #6  
Old October 11th, 2018, 12:16
devildog0's Avatar
devildog0 devildog0 is offline
NAXJA Member
 
Join Date: Apr 2005
Location: Hunt County Texas
Posts: 463
High idle in park

Check the grey wire on the front connector of the ECU. When this wire is grounded out it puts he Jeep into high idle mode. This was an option on fleet jeeps to keep radios charged and increased coolant flow it would bump up the idle to 1000rpm.

Sent from my SM-G892A using Tapatalk
__________________
1995 XJ Country/4.0L/AW4/231/UpCountry Suspension
2004 Suzuki DL650 VStrom/1978 Suzuki GS1000E/2003 Yamaha TW200
1982 Suzuki GS850G (barnfind project)
Reply With Quote
  #7  
Old October 14th, 2018, 08:12
sidewaysstarion's Avatar
sidewaysstarion sidewaysstarion is offline
Coffee Drinker
 
Join Date: Jan 2012
Location: Torrance, CA
Posts: 2,694
Re: High idle in park

Also if the tps gets wet, it will think the throttle is cracked open and Target ~1500-2000 rpm idle.


Also the police package extended idle is only 1,000 rpms when in park/neutral.
__________________
Quote:
Originally Posted by cracker
I seem to have run out of self tapping washers
99 4.0/AW4/231, with a few basic bolt ons.

Click here to support
Reply With Quote
  #8  
Old October 14th, 2018, 11:15
WAZZUXJ's Avatar
WAZZUXJ WAZZUXJ is offline
NAXJA Member
 
Join Date: Dec 2011
Location: Mission Viejo, CA
Posts: 563
Re: High idle in park

Hopefully you meant 1,000 and not 10,000 rpms. lol

I just had the same thing on '98. Pulled and cleaned IAC and reinstalled. No issues after.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
98 XJ intermittent high rpm in idle, park, and stopped killnine OEM Tech Discussion 8 April 29th, 2016 14:10
96 XJ High idle in park/neutral some times fishinpolejoe OEM Tech Discussion 49 January 25th, 2015 23:32
high idle in park after being in gear MONSTERxbla OEM Tech Discussion 1 July 19th, 2009 19:13
high idle in park and neutral Spongebob91785 OEM Tech Discussion 15 February 10th, 2009 13:21
TPS code 24 problem...high idle at park dumbagain OEM Tech Discussion 10 July 11th, 2006 13:32


All times are GMT -7. The time now is 19:05.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014