NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old October 13th, 2018, 03:44
Ralph77 Ralph77 is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: East Coast
Posts: 281
Slight Mod to Oil Pressure Sending Unit On '00 XJ

So I have been meaning to check my oil pressure with a mechanical gauge. This is the tool I have to do so.

https://www.amazon.com/OTC-Tools-561.../dp/B000R5G0DO


So as some of you know I always come up with these dumb ideas.

This involves putting in a "T" fitting to make is so I can put the mechanical gauge on the Jeep anytime I want without having to remove the sending unit. I figure I have to pull the sending unit to check the pressure so why not set this up when I do so.
I believe everything to be 1/8" pipe thread. I believe the gauge itself to also be 1/8" pipe thread.

So I am thinking using something like this:

https://www.zoro.com/parker-street-t...-2/i/G4582103/

Something like this to plug the opening in the "T" where the mechanical gauge would go when not in use.

https://www.zoro.com/zoro-select-hex...yABEgL4h_D_BwE

Been poking around and have seen where guys have done similar stuff to run both the gauge in the cluster and a mechanical one at the same time.
I don't see a problem with this.
Am I missing something?
Reply With Quote
  #2  
Old October 13th, 2018, 10:09
lazyxj's Avatar
lazyxj lazyxj is online now
NAXJA Member #1310
 
Join Date: Mar 2004
Location: Los Angeles
Posts: 2,219
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

Nothing wrong or unusual about installing a tee.
You can get the tee and plug at any home center, in the plumbing area.
__________________
Both XJs are still Real XJs http://www.naxja.org/forum/showthrea...hlight=real+XJ
01 Sport, 4.6L Russ Pottenger. stroker, AW4, 4" lift, 33 X 10.50 KM2, 4.56-8.25 TruTrac, D-30-E-Locker with alloy shafts, Hidden M8000 winch, Vanco front and ZJ rear disc brakes, Frame stiffeners, Lots of armor, Towing baseplate. http://www.flickr.com/photos/lwade/c...7603770130683/
1997 Country, Mostly stock, 2" lift, Engine mods, Towing baseplate
Reply With Quote
  #3  
Old October 13th, 2018, 13:42
Rick.rob Rick.rob is offline
NAXJA Forum User
 
Join Date: Jan 2017
Location: Mi
Posts: 26
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

I have a T in mine with a mechanical gauge installed inside the jeep, the sensor still works but sometimes there's 20psi difference between the gauge in dash and mechanical one.
Reply With Quote
  #4  
Old October 13th, 2018, 14:12
Ralph77 Ralph77 is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: East Coast
Posts: 281
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

Quote:
Originally Posted by Rick.rob View Post
I have a T in mine with a mechanical gauge installed inside the jeep, the sensor still works but sometimes there's 20psi difference between the gauge in dash and mechanical one.
Little confused. Sometimes but not all the time there is a 20 PSI difference between what your mechanical gauge and the one in the dash says?
Reply With Quote
  #5  
Old October 16th, 2018, 10:08
Ralph77 Ralph77 is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: East Coast
Posts: 281
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

So did I rigged up around like the oil pressure sender like I wanted to and checked it with my OTC tester.

So with both the cluster and the mechanical gauge hooked up on start up the mechanical jumped to 70 but settled down to 60 pretty quick. Cluster went to 60 but settled at 52 pretty quick.

For awhile the mechanical was reading a little higher then the cluster gauge. But as the Jeep got hotter then it started reading a lower.

The sensor in there now has been in there for about 3 years. It is the Echlin one at Napa. For the longest time it would read 22ish at a very hot idle. But in the last 6 months I noticed it reading just a little higher.

Anyway to bottom line it. I let the Jeep idle for about an 75 minutes in the driveway. Pressure on the mechanical gauge read about 22. I am OK with that.

Finding the fittings I use for the set up proved to be a little harder then I thought it would be. I figured we would have them at the store but no. Struck out at an Auto Zone and Advance too. Even Home Depot did not have what I wanted. Ended up finding them at O'reilly's.

https://www.oreillyauto.com/detail/b...q=209200&pos=0

https://www.oreillyauto.com/detail/b...q=227200&pos=0
Reply With Quote
  #6  
Old October 16th, 2018, 17:41
Rick.rob Rick.rob is offline
NAXJA Forum User
 
Join Date: Jan 2017
Location: Mi
Posts: 26
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

Quote:
Originally Posted by Ralph77 View Post
Little confused. Sometimes but not all the time there is a 20 PSI difference between what your mechanical gauge and the one in the dash says?

Yes sometimes there is a 20psi difference between the mechanical guage and the gauge on the dash in the cluster.
Reply With Quote
  #7  
Old October 17th, 2018, 01:32
Ralph77 Ralph77 is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: East Coast
Posts: 281
Re: Slight Mod to Oil Pressure Sending Unit On '00 XJ

Quote:
Originally Posted by Rick.rob View Post
Yes sometimes there is a 20psi difference between the mechanical guage and the gauge on the dash in the cluster.
I have noticed that the Napa Echlin sensor I installed about 3 years ago has been reading a little higher then usual starting a couple months ago. Normally 22ish at a hot idle. Pretty much what the mechanical gauge said yesterday. Everybody says to buy Mopar sensors but I decided to chance the aftermarket. Point being that if I had done this about 3 months ago feeling that my cluster gauge and the mechanical gauge were pretty much inline with each other.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sending unit Pz10420 OEM Tech Discussion 3 June 27th, 2012 18:59
Oil Pressure sending unit Sflxj OEM Tech Discussion 6 February 4th, 2011 21:33
Oil Pressure Sending Unit leaks out back of unit? mramr1974 OEM Tech Discussion 3 March 25th, 2008 02:44
Need Help!! Oil Pressure sending unit? Jeeperz83 Modified Tech Discussion 5 March 16th, 2007 21:56
Oil pressure sending unit Akumachan Wanted: Private Party Only 1 January 7th, 2007 09:01


All times are GMT -7. The time now is 09:42.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014