NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 30th, 2007, 15:22
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
96 OBD II engine misfire codes and rough idle

I need some ideas guys! My sons Ford Taurus, 96 lost the coolant recently due to a hose rupture. We fixed that. Now it wants to throw random cylinder # misfire codes, and it idles real rough especially when its cold, first start of the day. The idle smooths out when it warms up, and it stops throwing codes once it is good and hot!
I have a code scanner, and I have cleared the codes, and run it hot and cold, running tests in the driveway in gear and in park after clearing the codes. Only codes it has thrown so far are engine missfire cylinder numbers, and not always the same cylinder. It also posted a single Cl-fault on fuel system #2 once, but has not repeated that code since I cleared it.

Ideas????

My problem is I think it is the HV coil or secondary system, wires or ECM for the spark based on some other tests ( Iam planing more tests there right now), but it started right after it overheated???

Any good Ideas out there???

Oh, And just pretend it is a 96 Jeep 6 banger I am asking about!
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #2  
Old November 30th, 2007, 15:41
McQue's Avatar
McQue McQue is offline
NAXJA Forum User
 
Join Date: Oct 2007
Location: Plainville, Connecticut
Posts: 864
Re: 96 OBD II engine misfire codes and rough idle

Hmmm...Ignition system damage from the hose rupture, etc...

So... I am thinking all the typical stuff...plugs, wires, cap, rotor, coil, etc...maybe a/some sensors got wet with coolant and is/are now performing erratically until they warm up...intermittent connection problems...

might want to change all the hoses...if one went...who's next?

Good luck with it...McQue
Reply With Quote
  #3  
Old November 30th, 2007, 18:03
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

The hose that leaked was at the very bottom of the entire system, bottom of the radiator, and nothing above it got wet. Rest of the hoses seem OK.

I just ohmed three of the six HV wires, I got 5,000 to 8,000 ohms, or about 5,000 ohms per foot. I also just used an inline lighted neon spark intensity tester on Cyl 5, and it looks real good. There is no typical cap, rotor or distributor on this beast, just a box with 6 HV secondary wires.

I found a realy cool ford OBD-II manual that describes how the 1996 year OBD-II system works. It is quite revealing.

http://www.motorcraftservice.com/vdi...f/obdsm962.pdf

Quote:
Originally Posted by McQue
Hmmm...Ignition system damage from the hose rupture, etc...

So... I am thinking all the typical stuff...plugs, wires, cap, rotor, coil, etc...maybe a/some sensors got wet with coolant and is/are now performing erratically until they warm up...intermittent connection problems...

might want to change all the hoses...if one went...who's next?

Good luck with it...McQue
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #4  
Old November 30th, 2007, 18:23
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

I just dug this out of the manual, looks like its not spark related after reading all this,

It has an Electronic Ignition systems (Electronic Distributorless
Ignition System - EDIS) systems.

The EDIS system uses a chip to process the 36 (or 40) tooth crankshaft position signal, generate a low data rate
PIP signal for the PCM microprocessor and control a 4 or 6 terminal coil pack which fires a pair of spark plugs. One
of these sparkplugs is on the compression stroke, while the other is on the exhaust stroke. The EDIS chip can be
incorporated within the PCM or in a separate ignition control module.
The ignition system is checked by monitoring three ignition signals during normal vehicle operation:
Profile Ignition Pickup (CKP, commonly known as PIP), the timing reference signal derived from the
crankshaft 36-tooth wheel and processed by the EDIS chip. PIP is a 50% duty cycle, square wave signal
that has a rising edge at 10 deg BTDC.
Camshaft IDentification (CMP, commonly known at CID), a signal derived from the camshaft to identify the
#1 cylinder
Ignition Diagnostic Monitor (IDM), a signal that indicates that the primary side of the coil has fired. This
signal is received as a digital pulse width signal from the EDIS chip. The EDIS chip determines if the
current flow to the ignition coil reaches the required current (typically 5.5 Amps for COP, 3.0 to 4.0 Amps
for DIS) within a specified time period (typically > 200 microseconds for both COP and DIS). The EDIS
chip also outputs status information when the engine is not running.
First, the relationship between successive PIP events is evaluated to determine whether the PIP signal is rational.
Too large a change in 3 successive PIP indicates a missing or noisy PIP signal (P0320). Next, the CMP edge
count is compared to the PIP edge count. If the proper ratio of CMP events to PIP events is not being maintained
(for example, 1 CMP edge for every 8 PIP edges for an 8-cylinder engine), it indicates a missing or noisy CMP
signal (P0340). Finally, the relationship between IDM edges and PIP edges is evaluated. If there is not an IDM
edge (coil firing) for every PIP edge (commanded spark event), the PCM will look for a pattern of failed IDM events
to determine which ignition coil has failed. If the ignition coil cannot be identified or if the engine is running and
there are no IDM edges, the IDM circuit is malfunctioning (P1351).
I starting think it may be clogging fuel injectors, but who knows.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #5  
Old November 30th, 2007, 19:30
codyj86 codyj86 is offline
NAXJA Forum User
 
Join Date: Jun 2007
Location: co springs
Posts: 201
Re: 96 OBD II engine misfire codes and rough idle

to me it kinda sounds like it was a fluke that a hose blew out then started missing.
be sure to check simple things that can bite you too. such as fuel pressure, spark plugs, etc.
i would say it sounds like an injector, but that wouldn't make sense because injectors usually open up after it gets hot (heat + coils = higher resistance.), but be sure the check those too, sound to me like you've got one hell of problem.
Reply With Quote
  #6  
Old November 30th, 2007, 20:13
McQue's Avatar
McQue McQue is offline
NAXJA Forum User
 
Join Date: Oct 2007
Location: Plainville, Connecticut
Posts: 864
Re: 96 OBD II engine misfire codes and rough idle

Thats a pretty descriptive manual you found...I have been reading through it. If you are thinking injector problems keep in mind that I read "If a single cylinder is indicated to be consistently misfiring in excess of the catalyst damage criteria, the fuel injector to that cylinder may be shut off for a period of time to prevent catalyst damage. Up to two cylinders may be disabled at the same time. This fuel shut-off feature is used on many 8-cylinder engine and some 6-cylinder engines."

Since the problem seems to be temp related, your gonna have to remember to do your testing when it's failing, but you already know that....hate to rule out something that tests good when it's all warmed up...

McQue



Reply With Quote
  #7  
Old November 30th, 2007, 21:40
98XJeep 98XJeep is offline
NAXJA Forum User
 
Join Date: Aug 2007
Location: st.joseph mo.
Posts: 227
Re: 96 OBD II engine misfire codes and rough idle

3.0 v6's in the taurus cars a notoroius for headgasket leaks,I've done 4-5 in the last year,alot of them started just as your's did..........blown hose,missfire,overheat,etc. Like yours it was not always the same cyl,but in most of the one's I did the rear cyl were the one's with the problem,also IIRC 2 of the engines wound up needing at least one head and I know 1 needed both
Reply With Quote
  #8  
Old November 30th, 2007, 22:02
8Mud's Avatar
8Mud 8Mud is offline
NAXJA Forum User
 
Join Date: Sep 2003
Location: Central Germany
Posts: 8,676
Re: 96 OBD II engine misfire codes and rough idle

Just an idea. But glycol is insidious stuff, it is a pretty good conductor. Anything it gets into is likely to short, much more so than regular water. It only takes a little film or residue to do it. When I get a coolant spew, I wash the motor with hot whatever and then repeat, I've learned that lesson the hard way.. When it gets hot and dries it conducts less. Glycol is a desiccant, if it dries out it reabsorbs moisture from the atmosphere.
Could also be a head gasket like mentioned. Sometimes the misfiring plug will show a slight tint the same color as the coolant.
The coolant may foam and bubble with the radiator cap off. You can sometimes pump some air into a suspicious cylinder and get the coolant level to rise and/or bubble.
If it gets really bad you can have drops of moisture coming out of the exhaust, often with a tint the same as your coolant color. I sometimes use a white piece of toilet paper to check this.
Reply With Quote
  #9  
Old December 1st, 2007, 07:22
98XJeep 98XJeep is offline
NAXJA Forum User
 
Join Date: Aug 2007
Location: st.joseph mo.
Posts: 227
Re: 96 OBD II engine misfire codes and rough idle

this also happens in the ranger's with 3.0's but not as often, not sure why?
Reply With Quote
  #10  
Old December 1st, 2007, 11:33
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

What is really weird is that it almost immediately throws a misfire cyl code on cold start up, at ECT = 60 F. Then if I clear the code after it warms up and restart it, I can not force it to throw a misfire code again, even with multuiple restarts until it cools down to say 70 F.

The Coolant temp is running about 210 F with out any fans on at all. Takes about 20 minutes of idle at 80 F ambient just to trigger one elec fan to run for about 30 seconds, which drops the ECT from about 220 F to about 190 F in just 30 seconds. One electric fan runs on the ECT switch through the PCM, the second electric fan is operated with the A/C on. There is no fan clutch, or mechanical fan on this beast. I see no signs (yet) of coolant / head gasket leaks in either direction, and the misfire code switches between at least 3 (or 4?) cylinders so far. It has not thrown any other codes at all after 16 restarts and about 60 minutes of idling during those start run operations.

I did find a disconected vacuum hose to the fuel pressure regulator during the first test, fixed that, but the codes did not change, except for the freeze frame data which went from Fuel sys #1 reading "CL" to reading "OL" now, ????

Fuel sys #2 in the freeze frame of the missfire code is always reading CL-Fault, but I have not been able to find any references yet that tell me what " CL, OL, or CL-Fault" in the Fuel Sys means, nor why, or what the 2 fuel systems are, like what is the difference between fuel sys #1 and #2?

Thanks for all the replies and help guys!

I am going to run fuel pressure and vacuum tests today.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #11  
Old December 1st, 2007, 11:41
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

I have told my son repeatedly not to run the fuel tank dry, but alas Humans seem to learn many lessons the hard way. Trash in the fuel system is a high priority possiblity in my book, but if I am right it is only part of the poroblem, and is a roaming trash in the fuel injectors problem that is coming and going with this tank of fuel.
I did notice in that on line manual I linked to at Ford, that this beast fires the spark plugs on both the compression stroke and the exhaust stroke (unlike the Jeep which has a camshaft position sensor) , so it is concievable that a stuck opem FI that is leaking might ignite on the exhaust stroke and throw a misfire code????


Quote:
Originally Posted by codyj86
to me it kinda sounds like it was a fluke that a hose blew out then started missing.
be sure to check simple things that can bite you too. such as fuel pressure, spark plugs, etc.
i would say it sounds like an injector, but that wouldn't make sense because injectors usually open up after it gets hot (heat + coils = higher resistance.), but be sure the check those too, sound to me like you've got one hell of problem.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #12  
Old December 1st, 2007, 11:43
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

Yes I found that OBD-II ford feature description quite enlighting too! I wonder if OBD-II Jeeps do that too?

Quote:
Originally Posted by McQue
Thats a pretty descriptive manual you found...I have been reading through it. If you are thinking injector problems keep in mind that I read "If a single cylinder is indicated to be consistently misfiring in excess of the catalyst damage criteria, the fuel injector to that cylinder may be shut off for a period of time to prevent catalyst damage. Up to two cylinders may be disabled at the same time. This fuel shut-off feature is used on many 8-cylinder engine and some 6-cylinder engines."

Since the problem seems to be temp related, your gonna have to remember to do your testing when it's failing, but you already know that....hate to rule out something that tests good when it's all warmed up...

McQue



__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #13  
Old December 1st, 2007, 11:59
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

Quote:
Originally Posted by 98XJeep
3.0 v6's in the taurus cars a notoroius for headgasket leaks,I've done 4-5 in the last year,alot of them started just as your's did..........blown hose,missfire,overheat,etc. Like yours it was not always the same cyl,but in most of the one's I did the rear cyl were the one's with the problem,also IIRC 2 of the engines wound up needing at least one head and I know 1 needed both
Your giving me HEAD ache with this, LOL, as I already have my first head gasket job waiting for me on the 89 XJ, but thanks for the feedback, even if I don't like the answer.

So since this is a V-6, it hads two heads. The codes I recall were 1, 2 and 5 so far, and I think 4 once, but more often it has been #1 and #2, say on 3/4ths of the codes thrown so far. 1,2 % 3 are on the rear side.

Now, correct me if I am wrong here, but I know that antifreeze (silicone) is death to an O2 sensor, but so far I have no O2 sensor or Cat codes and no signsd of coolant leakage or overheating. Also, it only throws codes at cold start up, never when it is heated up. Also it has the rough idle ALL the time, and smooth as silk at other rpms with one exception. He has had this beast for 12 months, and 20,000 miles and it has always had problems getting over 3,800 rpm in park, or in drive, where it rapidly runs up and down in RPMs like a really bad TPS on a jeep would do.

So does this still sound like a head gasket. Also he said it died and coasted to stop when it starting leaking and overheating, and he did not try to restart it. The way he explained it, it sounded to me like it did not run long enough to damage the heads.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #14  
Old December 1st, 2007, 12:02
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

Quote:
Originally Posted by 8Mud
Just an idea. But glycol is insidious stuff, it is a pretty good conductor. Anything it gets into is likely to short, much more so than regular water. It only takes a little film or residue to do it. When I get a coolant spew, I wash the motor with hot whatever and then repeat, I've learned that lesson the hard way.. When it gets hot and dries it conducts less. Glycol is a desiccant, if it dries out it reabsorbs moisture from the atmosphere.
Could also be a head gasket like mentioned. Sometimes the misfiring plug will show a slight tint the same color as the coolant.
The coolant may foam and bubble with the radiator cap off. You can sometimes pump some air into a suspicious cylinder and get the coolant level to rise and/or bubble.
If it gets really bad you can have drops of moisture coming out of the exhaust, often with a tint the same as your coolant color. I sometimes use a white piece of toilet paper to check this.
Come to think of it, the O2 sensor is low enough and close enough to perhaps have seen some antifreeze on the outside, which I know is death to an O2 sensor. Hmmm!
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
  #15  
Old December 1st, 2007, 12:14
Ecomike's Avatar
Ecomike Ecomike is offline
NAXJA# 2091
 
Join Date: Dec 2006
Location: MilkyWay Galaxy
Posts: 15,358
Re: 96 OBD II engine misfire codes and rough idle

I found some of the fuel system details at:
http://findarticles.com/p/articles/m...n13486252/pg_3


UEL STAT 1 = Fuel System 1 Status: Fuel system status will display more than just Closed Loop (CL) or Open Loop (OL). You might find one of the following messages: OL-Drive, indicating an open-loop condition during power enrichment or deceleration enleanment; OL-Fault, indicating the PCM is commanding open-loop due to a system fault; CL-Fault, indicating the PCM may he using a different fuel control strategy due to an oxygen sensor fault.

But still looking for more details on this.
__________________
Quote=8Mud: "Go ahead and put up the best fence you can build, I'll bet on some Mexican with a few dollars of nails and a pile of scrap lumber."
34 MPG , '85 2WD Cherokee Pioneer with custom installed, 64 hp, 2.2 L Nissan SD22 Diesel 5 spd Manual; & 4 Renix XJs, '87 Wagoneer 4.0, 4WD, 89-Cherokee, 4WD, '87 Cherokee 2WD, & '89 Cherokee Pioneer 2WD, all 4dr. #2091
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
4.0L Rough Engine Idle After Restart Following a Hot Soak wcbuyer OEM Tech Discussion 7 June 25th, 2007 00:02
Engine - rough idle & low temp Spidey OEM Tech Discussion 6 November 7th, 2006 20:54
Check engine light and rough idle! shelbyluvv OEM Tech Discussion 2 October 25th, 2006 17:42
Rough idle and dieing once engine is warm NitroDuck OEM Tech Discussion 11 September 13th, 2005 15:26
misfire off-idle beav350 OEM Tech Discussion 5 March 5th, 2005 21:31


All times are GMT -7. The time now is 23:28.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2021, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014