NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old December 13th, 2016, 04:23
Patriotsix's Avatar
Patriotsix Patriotsix is offline
NAXJA Forum User
 
Join Date: Dec 2016
Location: Jacksonville MC / Demorest GA
Posts: 55
Question Over Head Console Install Issues have me stumped?!

I just bought a 97 XJ Country Edition with 180k miles on it. Came from some one who treated it pretty well, the inteior is in pretty good shape other than a seat and the headliner. Any way, I decided to buy an over head console online to install because I plan on using this Jeep as a distance commuter and I'd love to be able to track my MPG so I can adjust my driving style to save as much gas as possible. I bought an overhead console from a trusted source online that came out of another 97 and it came with its wiring harness. I decided before going through the trouble of installing it that I'd wire it up to confirm that it works first. Each plug had a place to go near the fuse box and hooked in no problem. I had to get an ambient temp sensor to complete the circuit for the computer screen. Now that it works I'm just not getting any readings from it at all (MPG, Mileage, etc). All of them show dashes or 0s. I've driven 2-3 total
Hours with it hooked up and still nothing, just dashes. The screen also shuts off when I turn off my running light/headlight switch. What am I missing? I can't figure it out.
Reply With Quote
  #2  
Old December 13th, 2016, 04:31
Patriotsix's Avatar
Patriotsix Patriotsix is offline
NAXJA Forum User
 
Join Date: Dec 2016
Location: Jacksonville MC / Demorest GA
Posts: 55
Over Head Console Install Issues have me stumped?!




Sent from my iPhone using Tapatalk
Reply With Quote
  #3  
Old December 13th, 2016, 05:13
90xj06's Avatar
90xj06 90xj06 is offline
NAXJA Forum User
 
Join Date: Aug 2006
Location: Peabody, MA
Posts: 1,685
Re: Over Head Console Install Issues have me stumped?!

did you have to do any splicing or was this completely plug and play? does it have the red 6 wire connector or the bigger black connector on the module?
Reply With Quote
  #4  
Old December 13th, 2016, 05:14
Patriotsix's Avatar
Patriotsix Patriotsix is offline
NAXJA Forum User
 
Join Date: Dec 2016
Location: Jacksonville MC / Demorest GA
Posts: 55
Re: Over Head Console Install Issues have me stumped?!

I'm on duty right now but I'll check when I get home. I didn't have to do any splicing but I will if I want my under dash lights to work after I totally install it.
Reply With Quote
  #5  
Old December 13th, 2016, 10:13
Tim_MN's Avatar
Tim_MN Tim_MN is online now
Freakish Hand Strength
 
Join Date: Mar 2003
Location: Minneapolis, MN
Posts: 6,162
Re: Over Head Console Install Issues have me stumped?!

Quote:
Originally Posted by Patriotsix View Post
... not getting any readings from it at all (MPG, Mileage, etc). All of them show dashes or 0s. The screen also shuts off when I turn off my running light/headlight switch. What am I missing? I can't figure it out.
1997-01 the OHC is plug and play. I have tested more than a dozen of them and they all functioned correctly. The symptoms suggest a short circuit or open circuit in the OHC wire harness.

Try disconnecting the key-less entry module, it can be faulty which causes some odd malfunctions. Also try disconnecting the 3 wire dome lamp plug at the fuse box.


.
__________________
.
.

Quote:
Originally Posted by bimmerjeeper

I'm starting to realize people on the Jeep forums are highly expert mechanics .....
Reply With Quote
  #6  
Old December 13th, 2016, 10:41
Patriotsix's Avatar
Patriotsix Patriotsix is offline
NAXJA Forum User
 
Join Date: Dec 2016
Location: Jacksonville MC / Demorest GA
Posts: 55
Re: Over Head Console Install Issues have me stumped?!

I just swapped he keyless entry module from my Jeep with the one that came in the console last night and haven't tried it again since then, so I'll try that as soon as I'm off duty and try unplugging then one wire like you said. Thanks
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AW4 Electrical issues have me stumped M50B06 OEM Tech Discussion 4 June 13th, 2012 19:45
Pre 97 Over Head Console JOE399 SoCal For Sale 1 April 24th, 2011 23:32
Over head console YosemiteMatt Colorado Chapter 2 December 19th, 2008 19:14
over head console Gnat5680 OEM Tech Discussion 3 July 3rd, 2006 10:41
over head console xj99_jeep Wanted: Private Party Only 2 July 22nd, 2004 19:07


All times are GMT -7. The time now is 03:53.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014