PDA

View Full Version : Rubbing on front sway bar


pantherchams
January 25th, 2009, 18:20
I can't seem to find much info on this topic.

My jeep has a 2.5" RE BB plus GC front coils, and I have 32x11.5x15 BFG M/T KM2's. I have recently finished lots of trimming, and my only remaining problem is rubbing bad on my front sway bar. It is worse when I turn left, but I get it turning both ways. It is rubbing when I am very close to full lock. I am running stock front sway.

Are there swaybar discos that improve clearance? Is there a solution other than going with no front sway? This is not my only vehicle, but I tend to drive it long distances frequently. It's mostly annoying while parking.

Any help/advice appreciated.

Thanks!

Ben

Muddy Beast
January 25th, 2009, 18:25
What wheels are you using? You'll rub if you don't have proper back spacing on your wheels with that wide of tire.

I have 31x10.5 tires on 15x8 rims with 3.75 backspacing, no rub even at a good tuck, for the record.

~Scott

pantherchams
January 25th, 2009, 19:30
Im using TJ canyon rims (15x8 i believe). Not sure on backspacing.

1990JEEPXJ
January 25th, 2009, 19:44
your tires rub the sway bars? ive never heard of that happening

OverTheHillsATTW
January 25th, 2009, 19:44
Wheel spacers or diff. rims.
Or just disconnect your sway bar its no so bad driving when you have stiff springs like v8 zjs. I am running like that with my 89.

I've seen it happen on the LCA maybe?

pantherchams
January 25th, 2009, 19:51
They for sure are rubbing sway bars, but i cant find evidence of them rubbing anywhere else. I guess just getting rid of the sway may be the way to go.