View Full Version : AW4 won't shift into 4th gear

April 10th, 2008, 02:39
My 99 XJ with 4 Liter Engine and AW4 had a front collision, and during repairs the engine and torque converter had been removed.
After the repairs It drives and shifts just normally, but without going into the 4th gear.
ATF Fluid has been replaced fully, so it's new. and filled with Dextron III to the correct level.

I tried the manual shifting test (ie. disconnected the TCU) and tried to shift manually, and it's still not shifting into 4th gear. (3 & D position makes no difference)

The TCU Diagnostic reads no error. So it's definitely a mechanical fault.

What should I look for next, and what could be causing this no shifting?

April 10th, 2008, 15:27
Just noticed that it's not shifting into 1st gear too, and after checking the FSM it seems that there is a problem with the No 2 solenoid. It should be stuck in the ON position wich brings the 2nd and 3rd gear.
But doesn't those solenoids need to be electrically controlled? Or could it be the valve which this solenoid operates got stuck?
Any suggestions?