PDA

View Full Version : build-up pics


stoveguy
May 14th, 2007, 23:12
Well Ive introduced myself a few months ago and since have just been reading and stockpiling parts. Well I started turning wrenches on my 86 wagoneer 2 weeks ago and thought Id share. brief description it is an 86 wagoneer limited. That had the required rod hanging out of the side of it when I got it. Ive put in a 92 chevy cpi 4.3 th700r trans and a 231c transfercase. I used aa mounts. RE 4.5 front springs s10 rear sitting on 35" procomp xterrains.Im almost done fabbing a long arm setup modeled after claytons with a little teraflex. almost done wiring the cpi engine. I have swaped out the d35 for a ford 8.8 with 4.10's and a ls. Ive got a milemarker hyd winch Im putting in after I fab a bumper. and I changed the brake booster for a hydroboost that came out of the astro van the eng came from. pics are here http://s210.photobucket.com/albums/bb183/stoveguy/

PornstaR
May 15th, 2007, 01:47
Looking good but "holy wires batman". Looks like you may have to do some fender trimming too. Clean looking rig tho.

stoveguy
May 15th, 2007, 07:36
Yea I already started trimming yesterday. I used the 35's well because there what I had from an old project. I really like how it looks so Im gonna trim just enough to clear Im considering going 2 more inches.

IslanderOffRoad
May 15th, 2007, 08:51
I wouldnt have gone with the CPI 4.3 having owned a truck with one, great, powerful motor, but the injector setup sucks and will fail, not to mention the TBI and the CSFI ones have more upgrades available.

Nice work on the Jeep though

stoveguy
May 15th, 2007, 09:42
well Im planning on up grading the injector setup when it does fail. for a 100 more I can up grade it with a 6 injector setup instead of the single with 6 poppets

xjjeeper19
May 15th, 2007, 21:59
That motor is great, my mom's blazer had one of those and it had 0ver 100K and the injectors never failed, plus it had more than enough power. I want to do this some day...