PDA

View Full Version : Blew a PS hose


AndyS
July 16th, 2005, 13:31
I blew out a power steering line last night, about 25 miles from my house. The metal tip popped (rusted out), right where the line goes into the steering box. What a mess..... I didn't have any PS fluid with me, and since it was in the middle of the night, I wasn't going to find any, so I chanced it and drove home. I *think* the pump is still ok.....

Anyways, I need to identify whether it's the high pressure or low pressure side. It's a '94 4.0, and it's the line that comes off the top of the pump (longer of the two lines...). Can someone confirm that this is the pressure side of the pump for me?

Thanks once again.

Andy

Lou
July 16th, 2005, 13:55
If it's coming off the pump, that should be the high-pressure side. The low-pressure feeds into the reservoir mounted on the pump.

AndyS
July 16th, 2005, 16:16
Good point - it's a pump AND reservoir assembly, not just a pump... Indeed, the hose is coming off the top of the pump, and the other line feeds into the bottom of the reservoir.

Thanks for the wake up!

AndyS
July 16th, 2005, 16:19
Now that I think about it, I should probably just replace both hoses. If one was rotted enough to pop through the metal, then the other is surely not far behind.

A lot of stuff has rusted/corroded to the point of failure on this vehicle. Granted, I'm in the northeast rust belt, but I've had older cars whose fasteners and other stuff didn't corrode as bad as on my XJ.... Just an observation....