PDA

View Full Version : HUGE PROBLEMS, no start


tealcherokee
July 8th, 2005, 20:48
ok, i got my motor in, she ran great, next day, dead

no spark, no fuel...... Relays dont click when the key is on, yet the board has power, cycle the key, NO CEL, NO GEN lights

im convinced its the computer, i have a 1991 computer, that i was going to try, but i cant find where my computer is in my jeep, ive got half the dash off, and no luck

PLEASE HELP

ps my jeep is a 1996 4.0

ren
July 8th, 2005, 21:30
try looking under the hood for the 'puter. I think that it is on the passenger side inner fender, towards the front area. It has a large fletish plug about 6" long and 1" thick. I believe that it is black in color, but some of them are grey on the really new ones ( I think those are also on the drivers' side, anyway) Hope this helps some.
Ren

tealcherokee
July 8th, 2005, 21:45
definalty not under the hood, just went out and looked, unless its very different, theres a metal box, with 3 large connectors coming out of it, on the drivers side, theres a plastic shield over it

ren
July 8th, 2005, 21:52
Bingo, that sounds like what you are looking for. I was not sure of when the factory changed the sytle and location, but that is the one.
Ren

tealcherokee
July 8th, 2005, 22:40
im not so sure, all the parts books show a black plastic box, one big connector..... any one else?

bbell90xj
July 9th, 2005, 08:27
Yes that is your computer. It should have 3 plugs coming out of it. Mounted on drivers side inner fender.

old_man
July 9th, 2005, 08:59
Before you start throwing expensive parts at it, do a little troubleshooting. Does the engine crank? If you want help, we can't read your mind. If your mind is made up that it is the computer, why bother to ask? People around here are pretty willing to help if you use some common sense and some respect.

badge714
July 9th, 2005, 09:08
http://www.autozone.com/servlet/UiBroker?ForwardPage=/az/cds/en_us/0900823d/80/15/23/89/0900823d80152389.jsp check this out. check battery cables and connections that theyre clean and tight badge 714 jeepman600@sbcglobal.net

tealcherokee
July 9th, 2005, 09:49
my problem now is, i cant find the computer..... im guessing that its differnet in the 1996, i definatly have a metal box, on the right fenderwall, i guess that has to be it

old_man
July 9th, 2005, 10:07
9 times out of 10, it isn't the computer. The symptoms you describe, are not normally attributed to the computer. If you will answer the questions, we can help you walk through the troubleshooting process, but if you want to throw money and parts at it, have at it.

The computer on your rig is the box mounted on the drivers side inside fender well just forward of the wheel. It has several cables going to it.

Panama XJ
July 9th, 2005, 12:13
For a 96 XJ, the computer is located at the right side (drivers side) in front near air box (like 95) but it is gray with 3 plastic connectors, in 97 they change location to the firewall in passenger side. but check battery cables first, main fuses in fuse box (the one in motor conpartment passenger side near battery. and check ground cable near motor coil. And the 91 ECU donīt work with 96 because 96 is ODBII and 91 is ODBI.

Panama XJ
July 9th, 2005, 12:17
the fuel pump is not controled by the ECU, it took power from the power switch (Key) then to the stop relay and it give power to the fuel pump relay, each relay have it own fuse.

langer1
July 9th, 2005, 14:06
ok, i got my motor in, she ran great, next day, dead

no spark, no fuel...... Relays dont click when the key is on, yet the board has power, cycle the key, NO CEL, NO GEN lights

im convinced its the computer, i have a 1991 computer, that i was going to try, but i cant find where my computer is in my jeep, ive got half the dash off, and no luck

PLEASE HELP

ps my jeep is a 1996 4.0
Hook the ground wire backup that does from the engine to the firewall.:wave:

tealcherokee
July 9th, 2005, 19:40
ground is good :(

Eagle
July 9th, 2005, 20:01
Do you have a factory service manual (FSM) for your year XJ? If not, get one. That will have the best trouble-shooting diagnostic tree in it that you'll find anywhere.

Do NOT throw in the '91 computer. First off it probably won't connect up anyway, but just in case, be advised that they are totally different. 1996 was the first year for OBD-II so the electronics in your '96 are not compatible with the '91 computer.

Eagle
July 9th, 2005, 20:03
For a 96 XJ, the computer is located at the right side (drivers side) in front near air box (like 95)
Unless you live in England, the right side of an XJ is the passenger side, and the driver's side is the left side.

tealcherokee
July 9th, 2005, 20:35
na, i dont live in england, fellow CT-er actually

i have located the ECU, and have a chiltons book.....im trying to figure out what does what now....

tealcherokee
July 9th, 2005, 23:18
heres what i got so far, chiltons book is saying brn/yellow wire, but i found 2 of them....no power to either