PDA

View Full Version : tow brackets/sway bar


SPSERG
April 19th, 2004, 09:10
I installed sway bar disconnects yesterday, then went out for a little jaunt with the wife and kids. I was looking at them this morning, and noticed that the sway bar it rubbing the carriage bolt that attaches the rear tow hook bracket to the frame. Not severly, that would bind things up. Is this common??

Yucca-Man
April 19th, 2004, 09:48
Clarification - when you say "rear tow hook bracket" you are not talking about anything involving the rear axle are you?

If you're talking about the rear of the front bracket, which side is hitting and how much lift do you have? Passenger side and about 3" lift? The axle is likely pulled to the driver's side because the trackbar is too short, or the swaybar bushings themselves may be allowing the swaybar to move out-of-center

SPSERG
April 19th, 2004, 19:09
Its the rear bolt of the front tow hook mount. They are Rusty's tow hooks. Its the round head of a carriage bolt. The XJ has just 2 inches of lift with spacers. Its not hanging up on it, but I can see where my new black paint has been scraped up. Mainly drivers side that I can see

n1ywb
May 2nd, 2007, 12:43
I'm having the same problem on my rig. Front sway bar is rubbing badly on the aft bolts on the factory tow hook brackets. It's worst on the left side where it's ground off about 1/4 of the head of the bolt, although it's rubbing on the right side as well. I have 4.5" lift with terra sway bar discos. I should mention that the sway bar mounts are aftermarket with urethane bushings, and the left hand one has a cracked bushing which probably isn't helping. The bolts are regular hex head. Are those not-stock? I could replace the mounts...