PDA

View Full Version : 2001 Fog Light fuse keeps blowing?


Redsnake
September 27th, 2017, 07:57
So the mini 15 amp fuse in the engine bay keeps blowing when I try and flip on my fog / driving lights on my '01 XJ.

The in cabin switch light is on and the bulbs are good in the housings. I can't find any exposed wires or other things that would be obvious... so I'm asking for some help.

I've switched in 2 new mini 15 amp fuses and as soon as I turn on the fog light switch it pops that fuse. So I'm sure there's something going on that I can't seem to figure out.

Could it be my fog light switch going bad? If so, how does one test that?

Any other suggestions? I'd like to get them working again...

Heavyopp
September 27th, 2017, 08:10
OHM Meter -- somewhere something is grounding out and blowing the fuse -- Most likely in the wire by the lights

If you don't have meter you could test one portion of the circuit at a time by blowing fuses

Test the switch by removing the wire heading to the fog lights -- Keep power and ground hooked up to the switch -- turn it on, did fuse blow? If yes then the switch, no then somewhere else -- reconnect wire

Check the wire to the fog lights by disconnecting wire at the fog lights -- turn on switch -- Did fuse blow -- Yes bad wire, no then at least one bad light -- test the lights separately to figure out which one

Ivan
September 27th, 2017, 15:46
Try by-passing / jumpering the fog light switch to fire off the fog lights. They've been know to fall apart internally and short out. If your fuse survives the jumpering, then it's your switch that is probably bad....