NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 18th, 2003, 21:25
onetallmj onetallmj is offline
NAXJA Forum User
 
Join Date: Aug 2003
Location: San Bernardino Ca
Posts: 423
dead battery now no start

Went to start truck( 88 MJ with 4.0 auto), no start. Found battery very dead. Jump with cables, got it to turn over but very weak even after a long charge time. Replaced battery with an almost new battery. Engine turned over but no go!! Everything was working fine last night . Do I need to reset something after replacing the battery?
Help

Wade
Reply With Quote
  #2  
Old August 18th, 2003, 21:58
RichP's Avatar
RichP RichP is offline
NAXJA Forum User
 
Join Date: May 2002
Location: Effort, Pa
Posts: 15,585
Clean your grounds on the engine, firewall and frame first. What is the voltage on the 'almost new' battery ??
Reply With Quote
  #3  
Old August 18th, 2003, 23:36
91xjtim's Avatar
91xjtim 91xjtim is offline
NAXJA Forum User
 
Join Date: Apr 2003
Posts: 126
First thing Id do is take apart all connections and clean them off real good with a wire bruch or baking soda. Also, get an vom meter and check battery voltage.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need Help! Won't Start...Stuck At Work! pancake OEM Tech Discussion 11 October 16th, 2003 21:57
Incab battery shut off switch Speed_racer OEM Tech Discussion 7 August 22nd, 2003 16:31
Battery going dead, Help GRNT Modified Tech Discussion 3 June 25th, 2003 09:48
'88 Chief Rough Idle or No Start or Perfect Start Hawaiian Style OEM Tech Discussion 8 June 9th, 2003 15:51
Push Button Start? FatXJ Modified Tech Discussion 10 April 5th, 2003 19:17


All times are GMT -7. The time now is 12:02.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014