NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 21st, 2017, 15:20
Intellect Intellect is offline
NAXJA Forum User
 
Join Date: Oct 2016
Location: Tampa Florida
Posts: 183
How to diagnose bad ecm? Check engine light and fuel pump delay upon cold starts.

1995 cherokee 4.0 i6 4wd. Tittle says it all. Usually only when cold starting.. ill turn the key to acc (you expect mr pump to whuuuuur) but nope. Sometimes it takes 20 seconds to 3 minutes. Sometimes itll whuuur right away.

Side note, was just chasing bleed off issues so i KNOW the pumps good. 110%. Good. Bosch and good.

I know it is an electrical issue because know how the check engine light comes on when you turn the key to acc? Well... Whenever the fuel pump DOESNT whuuuuur, the check engine light DOESNT come on either. They are both delayed. They will come on at the same time... Wether its a 25 second delay or 5 minute delay. Sure enough, whenever the whuuur finally happens, than i see mr check engine illuminate.

Odd part, when the delay happens, the radio, headlights, abs light, ebrake light, all work fine....

I have a seperate forum open that i was informed my above issue is the ignition switch, so i tried a new ignition switch. Identical problem... So im back here

(Abs light is on cause i clipped the lines when i got rid of my turdy 35, and brake light is on cause ebrake is up, ebrake also does nothing when i swapped axles i deleted it)

Side note, anyone ever hot wired a switch to the pump? Imagine its a terrible idea.

No ballest resistor.. 1995 return style...

New fuel pressure reg, pump, injectors, filter, etc. Bosch and name brands. Warrantied multiple parts multiple times to eliminate them from possibilities. (During my bleed off issue, which is FIXED)

Back to topic at hand... I researched it for hours. Here and other forums. No direct answers. Ecm,pcm,ignition switch etc are some of the things i was told could be it. I can use a multimeter if someone can help me. It sucks cause its an intermittent issue, USUALLY when cold. (Hasnt ran within 3 hours seems to be the cap off).

MAP/IAC/TPS/ GOOD GOOD GOOD. 125% GOOD. (Replaced, tested, multimetered, GOOD)

Cps.. 85% its good, only multimetered/tested. Via bleepin jeeps tutorial.

Also , ONLY WHEN COLD usually. Florida.."cold"... If its been running i can usually recrank within an hour - three no issues...

Let me paint a picture.

(Fuel gauge hooked to rail and within view)

Get in the jeep, half turn key, no check engine light or fuel pump whuuur.... Wait 20-400 seconds... Finally! Pressure builds some. Half turn it again, 50/50 change of the check engine light/pump instantly working or waiting 20-400 seconds again, lets say it works instantly, pressure builds more and to spec (49psi ish), i go to crank. (Has full pressure), starter works, engines turning, but acts as if no fuel or something because it doesnt want to start. At this point i can forcefully hold the gas down some and cause terrible idling like a car running with no gas/bad plug/ cant even describe it/misfire ish? , For about 2 minutes, than it be fine. Or i can crank it 3-12 times and wait for the one that actually turns over and stays without stalling... I can make a video if need be.

After this though, i can highway it fine.. offroad 6 hours fine... Stop for lunch and gas and brakes just fine, as long as it isnt off TOO long, i can hop in, crank it up like oem, and head off!

1995 4.0 Cherokee 4wd i6

Sent from my Moto G (5S) Plus using Tapatalk


Excuse any double posting. Not my fault. Tap a talk app.. not sure if the apps glitching or my posts didnt post.
Reply With Quote
  #2  
Old November 28th, 2017, 17:50
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,303
Re: How to diagnose bad ecm? Check engine light and fuel pump delay upon cold starts.

Put a voltmeter on the power lead to the fuel pump, right at the tank. Verify when you think the pump should be running that there is 12v. or hook up a fuel pressure gauge at the same times.
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.

Last edited by old_man; November 28th, 2017 at 18:01.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Delay in fuel pump/check engine light. Electrical grimlens? Need help! Intellect OEM Tech Discussion 12 November 30th, 2017 18:20
Fuel pump/ check engine light delay. Electrical? Need help. 95 cherokee. Intellect OEM Tech Discussion 2 November 20th, 2017 18:58
Check engine light/Fuel smell USAF007 OEM Tech Discussion 4 June 12th, 2013 22:36
AFE cold air intake installed, check engine light comes on cherokee chuck Modified Tech Discussion 8 July 29th, 2008 22:34
Bouncing idle,high rpm on cold start and now check engine light? Rem870XJ OEM Tech Discussion 8 May 10th, 2006 00:09


All times are GMT -7. The time now is 19:44.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014