NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 19th, 2017, 21:13
alexgalexg's Avatar
alexgalexg alexgalexg is offline
NAXJA Forum User
 
Join Date: Jan 2013
Location: Connecticut
Posts: 227
Coolant Question

Okay so my head blew due to the people I had make it do a questionable job. But this question is more related to when I put it back together. Right before the head started letting coolant into the engine I did a water pump. After filling the rad with coolant I stuck a funnel on the filler for the rad while the Jeep was parked on an incline and let it run so I could bleed out the bubbles. I noticed this time that it would suck in a ton of coolant and then spit it back out soon after. Once I finally got it to bleed the air out I did maybe half an hour of driving with perfect temp and good heat in the cab. The next day I found my reservoir was filled to max and opening the coolant cap led to coolant shooting out even though the car sat overnight. Are you not supposed to bleed these on an incline?
Reply With Quote
  #2  
Old November 20th, 2017, 05:05
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 10,565
Re: Coolant Question

What year?
Reply With Quote
  #3  
Old November 20th, 2017, 06:55
alexgalexg's Avatar
alexgalexg alexgalexg is offline
NAXJA Forum User
 
Join Date: Jan 2013
Location: Connecticut
Posts: 227
Re: Coolant Question

1998 with 4.0
Reply With Quote
  #4  
Old November 20th, 2017, 10:39
RCP Phx RCP Phx is online now
NAXJA Forum User
 
Join Date: Mar 2003
Location: Phoenix,Az
Posts: 10,565
Re: Coolant Question

It sounds like you might be getting combustion gases in there. Best to check it with a sniffer! The late years don't really require burping and shouldn't be backfilling the reservoir (possible bad cap also).
What did you do to solve the original problem? New head? Did the block need surfaced?

Last edited by RCP Phx; November 20th, 2017 at 10:46.
Reply With Quote
  #5  
Old November 20th, 2017, 20:33
alexgalexg's Avatar
alexgalexg alexgalexg is offline
NAXJA Forum User
 
Join Date: Jan 2013
Location: Connecticut
Posts: 227
Re: Coolant Question

Put in a new head. Block was good. My best guess is that the head wasnt made well. Not sure how else I have a bad head. The head issues would explain why the coolant put up such a fight. I just put up a video on taking the recent head off the truck if you want to see it and put in your 2 cents
https://youtu.be/zTAmSDXdFek
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
was using coolant, took head off, now question md21722 OEM Tech Discussion 12 April 12th, 2015 11:36
Another Coolant Leak Question javajeep OEM Tech Discussion 18 May 21st, 2009 14:24
Coolant Question mcnamaag OEM Tech Discussion 7 October 28th, 2006 08:33
96 4.0 85,000 miles Coolant Question edmaude OEM Tech Discussion 3 August 5th, 2005 20:43
Just changed the oil/coolant question. Whitetail Modified Tech Discussion 6 April 29th, 2005 02:18


All times are GMT -7. The time now is 08:23.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014