NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old September 27th, 2017, 19:07
chrisjeep chrisjeep is offline
NAXJA Forum User
 
Join Date: Jul 2014
Location: ny
Posts: 5
hard start/low idle after TB/TPS/IAC sensor cleaning

I cleaned the TPS/TB/IAC and now I have a rough start , low idle and a slight miss.
I changed the fuel pump(bosch),was getting 25-30 psi before the change and the same after change. I installed a check valve near the tank, no change. changed plugs. I hate throwing part at issues, can someone tell me the order in which I should go about fixing this. it's a 1994, 4.0 .
Reply With Quote
  #2  
Old September 28th, 2017, 05:56
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: colorado, Foco
Posts: 430
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Injectors stock? They could be bleeding down pressure
Reply With Quote
  #3  
Old September 28th, 2017, 06:39
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,240
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

That fuel pressure is loooow.
Reply With Quote
  #4  
Old September 28th, 2017, 20:27
chrisjeep chrisjeep is offline
NAXJA Forum User
 
Join Date: Jul 2014
Location: ny
Posts: 5
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

stock injectors. fuel pressure on gauge goes right to zero when engine is turned off. would like to know what series of test I can do instead of throwing parts at it.



Quote:
Originally Posted by 4x4JeePmaNthINg View Post
Injectors stock? They could be bleeding down pressure
Reply With Quote
  #5  
Old September 29th, 2017, 06:19
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,240
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

What happens if you pinch the fuel return line with the pressure gauge on it?

Replacing those injectors with the Volvo 746s is never a bad idea. Under $100

https://www.cherokeeforum.com/f72/78...ectors-222140/

Last edited by cruiser54; September 29th, 2017 at 06:34.
Reply With Quote
  #6  
Old September 30th, 2017, 07:44
chrisjeep chrisjeep is offline
NAXJA Forum User
 
Join Date: Jul 2014
Location: ny
Posts: 5
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

going to do the injector swap, keep you guys posted. thanks for the help



Quote:
Originally Posted by cruiser54 View Post
What happens if you pinch the fuel return line with the pressure gauge on it?

Replacing those injectors with the Volvo 746s is never a bad idea. Under $100

https://www.cherokeeforum.com/f72/78...ectors-222140/
Reply With Quote
  #7  
Old October 1st, 2017, 18:02
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,539
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Quote:
Originally Posted by chrisjeep View Post
stock injectors. fuel pressure on gauge goes right to zero when engine is turned off. would like to know what series of test I can do instead of throwing parts at it.

Bad fuel pressure regulator?
Reply With Quote
  #8  
Old October 1st, 2017, 19:49
4x4JeePmaNthINg's Avatar
4x4JeePmaNthINg 4x4JeePmaNthINg is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: colorado, Foco
Posts: 430
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

try priming the injector first by turning the key to on a few times, but dont start it until the 4th or 5th time. if it stumbles starting the injectors may be leaking and the engine is clearing its self because its flooded.
however if it fires right up instead, the fuel pressure regulator isnt a bad bet, its starving/ hard starting until fuels getting pumped to the injectors.
Reply With Quote
  #9  
Old October 4th, 2017, 20:06
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,303
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Throttle position sensors do not respond well to cleaning and routinely fail afterwards.
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.
Reply With Quote
  #10  
Old October 4th, 2017, 21:37
Runnin'OnEmpty's Avatar
Runnin'OnEmpty Runnin'OnEmpty is offline
NAXJA Forum User
 
Join Date: Apr 2003
Location: Southeast USA
Posts: 1,008
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Quote:
Originally Posted by chrisjeep View Post
stock injectors. fuel pressure on gauge goes right to zero when engine is turned off. would like to know what series of test I can do instead of throwing parts at it.
The fuel pressure shouldn't bleed down nearly that fast.
When you replaced the fuel pump, did you check the upper
section for cracks? The hose tends to crack near the clamp
and will release pressure back into the tank.
Reply With Quote
  #11  
Old October 4th, 2017, 21:54
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,303
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Quote:
Originally Posted by Runnin'OnEmpty View Post
The fuel pressure shouldn't bleed down nearly that fast.
When you replaced the fuel pump, did you check the upper
section for cracks? The hose tends to crack near the clamp
and will release pressure back into the tank.
X2
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.
Reply With Quote
  #12  
Old October 4th, 2017, 22:22
trippled trippled is offline
NAXJA Member
 
Join Date: Apr 2006
Location: colorado springs, co
Posts: 1,589
Re: hard start/low idle after TB/TPS/IAC sensor cleaning

Quote:
Originally Posted by Runnin'OnEmpty View Post
The fuel pressure shouldn't bleed down nearly that fast.
When you replaced the fuel pump, did you check the upper
section for cracks? The hose tends to crack near the clamp
and will release pressure back into the tank.
X3, however usually new fuel pumps include that piece of hose as long as it was used. I would say you have a failing regulator. If it was an injector bleeding of 10psi running it would probably hydrolock the motor or have a lot of black smoke. Pinch the return line momentarily and see if the pressure comes up.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard to start, no idle Makapo OEM Tech Discussion 3 February 1st, 2015 20:26
hard start and slow idle in the mornings hightime81 OEM Tech Discussion 2 August 4th, 2009 18:53
Hard start, lopey idle xj2win OEM Tech Discussion 3 April 6th, 2009 19:14
Hard Start/Non-Idle XpedientJ OEM Tech Discussion 1 December 31st, 2007 21:20
Rough Idle, Hard Start logdog OEM Tech Discussion 3 April 16th, 2004 18:58


All times are GMT -7. The time now is 21:59.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014