NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 4th, 2017, 15:48
cletus141 cletus141 is offline
NAXJA Forum User
 
Join Date: Jun 2016
Location: Reno, NV
Posts: 35
Mods, please delete this thread

I'm baffled. Fuel pressure holds at about 32psi, but will slowly bleed down to about 28 after 5 mins. I checked spark to all 6 cylinders and it's there. I originally checked 1 cylinder and wasn't getting spark, then read something about unplugging the CPS for 5 minutes, re-plugging, and trying again. Now spark to all 6. So maybe I didn't check it correctly the first time.

Timing issue?

Last edited by cletus141; March 4th, 2017 at 16:27.
Reply With Quote
  #2  
Old March 4th, 2017, 16:07
cletus141 cletus141 is offline
NAXJA Forum User
 
Join Date: Jun 2016
Location: Reno, NV
Posts: 35
Re: I'm baffled. Getting spark AND fuel, but cranks and no start

I've also sprayed Starting Fluid into the intake and no fire up
Reply With Quote
  #3  
Old March 4th, 2017, 16:25
cletus141 cletus141 is offline
NAXJA Forum User
 
Join Date: Jun 2016
Location: Reno, NV
Posts: 35
Re: I'm baffled. Getting spark AND fuel, but cranks and no start

ok. I googled "spark and fuel, no start" and read something on Cherokee forum about it being flooded and try starting at WOT. So, I cranked and cranked at WOT and it eventually started. Being flooded made sense since I'd been cranking all morning checking fuel pressure and spark.
Reply With Quote
  #4  
Old March 4th, 2017, 16:31
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,050
I'm baffled. Getting spark AND fuel, but cranks and no start

So it Is running now?


Sent from my iPhone using Tapatalk
Reply With Quote
  #5  
Old March 4th, 2017, 16:36
cletus141 cletus141 is offline
NAXJA Forum User
 
Join Date: Jun 2016
Location: Reno, NV
Posts: 35
Re: I'm baffled. Getting spark AND fuel, but cranks and no start

yes. I posted in the other thread and I've asked a Mod to delete this thread. Can you check out my questions in there?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Has spark, has fuel, cranks but wont start...I'm desperate nicpaige OEM Tech Discussion 41 March 12th, 2016 17:48
it cranks, has fuel, no spark Eagle02 OEM Tech Discussion 13 March 23rd, 2009 18:06
'91 4.0 cranks but no start has fuel and spark Avanteone OEM Tech Discussion 8 January 28th, 2009 04:45
Have Spark, Have Gas, Cranks, No Start Powderhound OEM Tech Discussion 32 December 18th, 2007 10:57
Cranks, No Start. Have spark & fuel. DonkRado OEM Tech Discussion 9 December 3rd, 2006 12:59


All times are GMT -7. The time now is 13:46.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014