NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA's Technical Forums > Modified Tech Discussion
Register FAQ Users List Calendar Mark Forums Read
HOME Member FAQ Sponsor Info Rules Donate Bylaws Store Members Chat E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #76  
Old April 22nd, 2011, 14:33
Darky's Avatar
Darky Darky is offline
NAXJA Forum User
 
Join Date: Apr 2004
Location: 29 Palms, CA
Posts: 13,339
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by cal View Post
Oh hey! What do you know, you're so full of it your eyes are brown.

You *ARE* wildjeepchick. You know when you log in with two accounts on the same computer, the system reports that to moderators right?
Reply With Quote
  #77  
Old April 22nd, 2011, 14:37
.40CalPatriot's Avatar
.40CalPatriot .40CalPatriot is offline
NAXJA Forum User
 
Join Date: Sep 2005
Location: Westminster, CO
Posts: 3,975
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Reply With Quote
  #78  
Old April 22nd, 2011, 14:56
DeftwillP's Avatar
DeftwillP DeftwillP is offline
NAXJA Forum User
 
Join Date: May 2004
Location: Round Rock TX
Posts: 4,849
Queue 3rd troll account.....


Sent from tapatalk on iJunk
Reply With Quote
  #79  
Old April 22nd, 2011, 15:09
techno1154's Avatar
techno1154 techno1154 is offline
NAXJA Member
 
Join Date: Apr 2003
Location: In the islands
Posts: 2,081
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by cal View Post
Oh hey! What do you know, you're so full of it your eyes are brown.

You *ARE* wildjeepchick. You know when you log in with two accounts on the same computer, the system reports that to moderators right?

It never ceases to amaze me how some people change their screen name and adress and think they fool others. It is sooooo easy to find out where an e-mail come from including the computer and the exact place/address the computer was when the e-mail was sent.
__________________
Patrick

#594
1996 XJ; 4.0L; AW4; NP231; SYE; D30 and D44; ECTED; 4.10 gears; 30X9.5 -15 BFG/AT/KO; 3" lift; Rusty's LCA; JKS ADJ UCA; Kevins ADJ Track bar; Drawtite Front Receiver; Dual Electric Fans; Dual Battaries.
Reply With Quote
  #80  
Old April 22nd, 2011, 15:41
GSequoia's Avatar
GSequoia GSequoia is offline
Everyone says I'm a jerk.
 
Join Date: Feb 2003
Location: Torrance, CA
Posts: 20,677
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by cal View Post
we may never know
They were talking about wildjeepchick, not you.
__________________
President & SoCal Chapter President
'89 Laredo '96 Country WFW WWU?
Adopt-A-Trail keeps trails open
Have you volunteered this month?
Reply With Quote
  #81  
Old April 22nd, 2011, 15:58
Hammered's Avatar
Hammered Hammered is offline
NAXJA Forum User
 
Join Date: Nov 2007
Location: Jeep Fiend Club
Posts: 5,266
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by cal View Post

At the end of the day, reputations are earned and not given.

Truth be told
Reply With Quote
  #82  
Old April 22nd, 2011, 18:33
Talyn's Avatar
Talyn Talyn is offline
NAXJA Member
 
Join Date: Apr 2003
Location: Radford, Communistwealth of Virginia
Posts: 7,315
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by cal View Post
You *ARE* wildjeepchick. You know when you log in with two accounts on the same computer, the system reports that to moderators right?
AAAAAAAHHHAAAAA!!!!
Reply With Quote
  #83  
Old April 22nd, 2011, 18:38
Boostwerks.com's Avatar
Boostwerks.com Boostwerks.com is offline
NAXJA Supporting Vendor
 
Join Date: Sep 2006
Location: Colorado
Posts: 2,533
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

...and now the reputation deepens further into the negative area. Smooth.
__________________
99 XJ Sport Build Thread:
http://www.naxja.org/forum/showthread.php?t=1059015
Check out our website!
www.BoostwerksEngineering.com
Reply With Quote
  #84  
Old April 22nd, 2011, 19:11
4wdParakeet's Avatar
4wdParakeet 4wdParakeet is offline
NAXJA Forum User
 
Join Date: Feb 2007
Location: Olathe, Ks
Posts: 1,041
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

This thread has made my day. For that Troll I thank you.


Parakeet
Reply With Quote
  #85  
Old March 17th, 2012, 10:18
ScienceguyXJ ScienceguyXJ is offline
NAXJA Forum User
 
Join Date: Mar 2006
Location: Colorado Springs CO
Posts: 166
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Update...... Had the 4.9L for almost two years now. Still running strong with no major problems. One year left on the warranty.
Reply With Quote
  #86  
Old March 18th, 2012, 16:25
praetorian praetorian is offline
NAXJA Forum User
 
Join Date: Sep 2005
Location: La Mirada, CA
Posts: 534
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Thanks for the update. What kind of gas mileage are you getting? Also what did you do to get this running? Larger injectors and/or adjustable MAP sensor? Anything else? Sorry if you've already said in a prior post.
Reply With Quote
  #87  
Old March 19th, 2012, 10:14
om3gadagg3r's Avatar
om3gadagg3r om3gadagg3r is offline
NAXJA Forum User
 
Join Date: Jul 2009
Location: Upper Michigan
Posts: 18
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

I have had a Titan 4.7 in my renix XJ for over 2 years now and am very pleased. Service was excellent and they answered all my questions. You guys that dont have personal experiance with a company shouldnt spread rumors. In my case Titan provided a great product and I would not hesitate to buy from them again. I am from Northern Michigan and am in no way affiliated with Titan, so dont even go there.

If you havent dealt with a company, dont badmouth them.
Reply With Quote
  #88  
Old March 19th, 2012, 12:31
VAhasnoWAVES VAhasnoWAVES is offline
NAXJA Forum User
 
Join Date: Sep 2008
Location: Lake City, Mi
Posts: 5,319
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by om3gadagg3r View Post
If you havent dealt with a company, dont badmouth them.
tell a politician that.
Reply With Quote
  #89  
Old March 20th, 2012, 06:38
cal's Avatar
cal cal is offline
NAXJA Warranty Voider
 
Join Date: Nov 2004
Location: Hammertown, USA
Posts: 16,631
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by om3gadagg3r View Post
If you havent dealt with a company, dont badmouth them.

We have dealt with them. We've dealt with them coming on to our forums, creating multiple fake accounts and using them to lie about their products.

Not the actions of a respectable company.
Reply With Quote
  #90  
Old March 20th, 2012, 11:11
Darky's Avatar
Darky Darky is offline
NAXJA Forum User
 
Join Date: Apr 2004
Location: 29 Palms, CA
Posts: 13,339
Re: Titan Monster 4.9 300 Cubic Inch Jeep Stroker

Quote:
Originally Posted by HttpWayne View Post
I just typed up a 2000 word paragraph on exactly why not to purchase anything from Titan (I have, recently, and it didn't run) and the page went backwards. Don't you just hate heat sensing touchpads?

So here's the background: I purchased the Cam, Crank, and Rods separately. I told them the specs and they said they could build it for me (4.6 stroker). So after I get the engine and swap all the parts over to the new longblock (after we cleaned them, minus the dist and alternator), we crank it up and break in the new cam. It was at someone's house who helped me. We were also installing a suspension kit and 4WD on it. A few days later I crank it up and go to drive it about 3-4 miles back to my house. The whole time it was acting erratic. In mid-drive it would start shaking the jeep horribly, oil pressure would drop from 40 to 20 gradually, and at lower rpm it would feel like it's about to shut off. During driving when it started doing that I would hit the gas more and it would go away. And that is how I drove it back to my house. During that time it felt like it had no power at all considering how much throttle I gave it. It had a lot less pep and pull than before. I didn't understand any of this since it ran fine during the cam-break in procedure. So that's when I called Titan back... they had me do the timing (myself, and I'm not ASE certified like the guy that helped me). I messed it up. I took it to a mechanic who did it two different times with the same results that I had while I was driving it. They talked with Titan over the phone both times to confirm they were doing it correctly. So in the end I paid them 80 bucks and towed it back to Titan so THEY could do it.

It's been sitting in their parking lot being on the bottom of the totem pole in between other jobs for the past 17 days. They managed to adjust the timing after the first 7 days and decided (because it ran just like it did for us, crappy) that they need to take off the valve cover and look at the cam. They came to THAT decision 10 days ago. Subtract a weekend and you have 8 business days. In that time they have not even TOUCHED the valve cover. They won't do that until "monday" so I'm to call back Tuesday; and just so you all know, any time you are told to call back just know that they won't have touched it by then and they'll give you another 2 day time frame to call back... at which point they MIGHT have started. It was like me calling them was the only thing reminding them that they needed to work on the $2400 engine I purchased that never ran more than 4 miles... and has been there in their parking lot for over 2 weeks.

It took them 7 days to check the timing which was "way" off. I don't know if that's true or if they're saying that so they can nickel and dime me for every penny and blame the timing on why it didn't run.
I do know that when we first put it in and ran it, it was spot on. From there when I tried to drive it back to the house 2 days later is where we had the problem.
The engine wold drop oil pressure to 20 from 40 and bounce between 20 and 30 eventually just tapering off from 20 to 10 and shutting off. The engine would start vibrating horribly and then the whole vehicle would shudder with it in tune before it shut off. So keep in mind I told him it ran fine... and gradually degraded this way. He tells me to adjust the timing, so I did. I know I XXXXed it up. So I took it to another ASE certified mechanic and they did it while they were talking to Titan over the phone. They got it to where it ran like it did before I touched it. So I took it back to Titan.

That was 17 days ago. 7 days to set the dist timing and come to the conclusion that they're going to open up the valve cover, another 12 days to actually open the valve cover and look at the cam. Or maybe it's 12 to open the valve cover and another 3 before actually looking at the cam. or no.. I call back in 3 and they tell me to call back in 2 because they haven't touched it. Then when I call that time I call the next day; oh, by the way, our warranty isn't covering this. You'll be paying for it.

I sense that this coming weekend they still aren't going to have touched it. If that's the case I'm going back down to Florida and paying a company to have it towed to NC. I'm going to take it to the hobby shop on base and work on it my damn self. Titan has been a complete waste of money.

They have a sign in their parking lot that says "Not responsible for vehicles that have been here over 30 days," and their business is right next to the ghetto. With the way they're taking their sweet ass time it'll be stolen before they even get started on it.

I honestly feel like Titan carries the true F'you'over mechanic spirit that goes with the typical persona applied to a "mechanic." Only they charge you for an initial gauranteed pricey job that they didn't do correctly, then charge you more for the follow on problems you have that they deem aren't part of their warranty.

All I wanted to do was come back from Okinawa after two years, put in the 4.6 and add all my accessories and go off-roading. I wanted to be able to do that within my 30 days on leave before going to Camp Lejeune, but I guess that was way too much to ask. The more I think about this the more it pisses me off. And they're charging me to look at the cam, and do anything form there on too. That's a kickass warranty system they have going.

So if you want to run the risk of going through this process, just call Titan Engines and they'll hook you right up.


CoffeeCommando~
Quote:
Originally Posted by HttpWayne View Post
Cheap cork gaskets were also supplied. The valve cover leaked so I bought a felpro to replace it.

You'll want to replace the following:
Oil Pump (should be provided if you buy a stroker)
Water Pump
Timing Chain (should be provided if you buy a stroker)
Timing Chain Gasket Set
All new hoses
Ignition Coil (if you drop yours while transferring. Mine had a paper thin crack and wouldn't work)
Distributor Rotor
Spark-Plugs
Spark-Wires
Fuel Injectors (you should have already bought these, 24lbs)
Harmonic Balancer
1 Big Jug of Purple Power

If you can, have all these before hand. We had to halt progress in order to get the harmonic balancer, then again for the ignition coil. Both had to be ordered.
And a lot of purple power and hard tooth brushes/scuzz brushes to clean off the items you transfer to the new block (oil pan, IM - extremely gunky item, valve cover, etc. etc.)
Quote:
Originally Posted by Gojeep View Post
Read this report.
http://www.naxja.org/forum/showthread.php?t=939290
I like to add that the one I fitted for a customer has since died too!
Quote:
Originally Posted by HttpWayne View Post
Also, just a little more. The timing was spot on from the time it initially started up, and we broke the cam in just fine (the guy helping me ias ASE certified, owned his own mechanic shop for about 8 years and had his own lift as well as every tool known to man, to include air tools, in his back yard garage). He drives his own race car and builds engines on the side as well as doing auto repair for anyone who needs anything.
So from the time it broke in, and I turned it on for a few minutes each day just to listen to it for the next 3 days afterwards, it was fine.
When I actually went to drive it to my house I got 2 out of 5 miles before it started doing what it did to me.
Titan told me the timing was off and directed me on how to do ith, which I am not mechanically inclined and I know I messed it up. Then I had some other mechanic do it for me and they did it twice, both times it was running just the way it did before.
From then on Titan wants to blame everything that's wrong with it on the initial break in being wrong and me having the timing off... and I think they're doing this so they don't live up to the warranty and I have to pay for it.
As it turns out they open up the valve cover and the #3 rocker (pertaining to the number 2 cylinder) isn't "acting likie it's supposed to." From which I asked another renowned mechanic I know, and he said it has to be either the lifters or rockers on their part.
Just FYI, if you go with Titan make sure you have a veteran automechanic to cut out the bull shit they throw your way so they don't F you over and make you pay the cost of work that they didn't do properly on your end.

DO NOT buy from Titan.

Coffee Commando~
Quote:
Originally Posted by bpmolinari View Post
I bought a titan 4.6 and I didn't come with the head gasket on and it didnt fit a renix and getting them to take it back was like pulling teeth and shipping was on my dime both ways. X2 on rebuilding what you got I forgot how great a new 4.0 is plus I still get over 20 mpg, jeep got it right

Sent from my DROIDX using Tapatalk
Quote:
Originally Posted by om3gadagg3r View Post
If you havent dealt with a company, dont badmouth them.
So how about all the people above you who have dealt with them and say they're crap?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Titan Stroker jdwest Modified Tech Discussion 1 May 14th, 2008 10:26
Titan 4.6 stroker, 5k miles, $1200 ZachMan SEC For Sale / Wanted Forum 6 February 18th, 2008 13:20
Titan 4.7 Stroker (Lifter Noise or Worse?) rbishop Modified Tech Discussion 6 March 7th, 2007 09:48
Titan stroker? JeepDoggyDog Street and Performance 22 October 8th, 2006 14:29
titan stroker? 1989xj Street and Performance 3 January 13th, 2006 08:49


All times are GMT -7. The time now is 07:17.


Powered by vBulletin® Version 3.8.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014