NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old March 8th, 2005, 14:57
Noodle Noodle is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Kansas
Posts: 20
Melted Fuseable Link

I Was Trying To Figure Out Why My 89 Xj Will Not Start And Was Running A Jumper From The Battery To The Wires Connected To The Ballast Resistor And Got It Started And Then The Orange Fuseable Link Connected To The Top Spade Terminal Melted And Smoked! Any Ideas On Why That Would Happen?
Thanks For The Help In Advance!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
drag link / sway bar link mount interference sarvermr Modified Tech Discussion 21 March 14th, 2007 07:19
Tubing size for suspension link? Jeff 98XJ WI Modified Tech Discussion 10 December 23rd, 2004 14:57
How to torque connecting link nuts and bolts phred OEM Tech Discussion 3 November 3rd, 2004 14:33
front 3 or 4 link planning....some brainstorming needed gearwhine Advanced Fabrication and Engineering 20 August 7th, 2004 17:30
3 link 4 link Potato potaaahto semantics? TOZOVR Modified Tech Discussion 38 January 7th, 2004 23:51


All times are GMT -7. The time now is 13:53.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014