NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 23rd, 2008, 20:21
J33PsRock's Avatar
J33PsRock J33PsRock is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Vegas Baby, Vegas
Posts: 38
Unhappy Loud Clunk When Putting Into Drive

When I go from Reverse to Drive, there is a pretty loud clunk coming from the tranny area under my 90 Cherokee 4.0, 225k miles. I also notice this when I accelerate up to about 30 or 40 and then let off the gas and then accelerate again.

I have searched and don't think it is engine or tranny mounts, but I guess I am not sure. It just sounds like some grinding POP. Things are smooth as far as shifting up and down the gears while I am driving...no other drive line problems. This noise is just so loud I am afraid I am about to break something.

Checked the tranny fluid, it was a little low, topped it off.

I have never had the transmission serviced. I got this jeep at about 175k miles and a friend said (before finding ) changing the fluid and doing the flush can break up so much that you may have problems...so I never changed the tranny fluid.

I put a Jasper engine in this about 4 years ago, love that decision, but I am hoping I am not about to lose my transmission. Talking about transmissions is scarier to me than f'in around with electricity...help me out brothers.
Reply With Quote
  #2  
Old November 23rd, 2008, 20:23
t_aldrich t_aldrich is offline
NAXJA Forum User
 
Join Date: Sep 2008
Location: Woburn, MA
Posts: 1,013
Re: Loud Clunk When Putting Into Drive

transfer case chain?
ujoints?
rear-end play?

doesnt sound like a transmission problem to me.
Reply With Quote
  #3  
Old November 23rd, 2008, 20:29
blondejoncherokee's Avatar
blondejoncherokee blondejoncherokee is offline
NAXJA Member
 
Join Date: Oct 2007
Location: sacramento
Posts: 12,367
Re: Loud Clunk When Putting Into Drive

with 225k if you havent changed your motor or tranny mounts id do those first along with your control arm bushings. is it lifted? are you running a tcase drop if it is lifted? t case drop can cause the tranny and motor mounts to prematurely wear out. i just replaced my tranny and motor mounts twice each this year. first with some used ones that were better than my crappy worn out mounts, that i still had issues with and then finally with some new stock mounts. i plan on swapping in the brown dog motor mounts soon though, the stock mounts dont look like they are made to take lockers, gears and 33's too well.....are you running stock or aftermarket control arms? how are your rear driveshaft u joints? just a few things to check. id bet on tranny and motor mounts. id say if youre gonna wheel it do the more bombproof or the browndog mounts, or the summit mounts, something that is better than stock, its worth the extra cash for peice of mind along with a better product.
__________________
As soon as I crest the top i'ma turn driver and floor it!

1998 4.6 stroker , aw4 XJ on 60/14b , 5.38s, grizzly/detroit, cage, 40s, psc big bore box , assist, 3 link,transgo aw4 reprogram
Reply With Quote
  #4  
Old November 23rd, 2008, 20:32
blondejoncherokee's Avatar
blondejoncherokee blondejoncherokee is offline
NAXJA Member
 
Join Date: Oct 2007
Location: sacramento
Posts: 12,367
Re: Loud Clunk When Putting Into Drive

i forgot to second the rear end play. i pulled a 35 outta guys jeep for him and he was complaining about some terrible noises and clunking. i could slide his chunk back and forth in the diff after i pulled the cover! and it was very low on fluid. overall it was a scary thing, i gave him my old 35 that was in decent shape.
__________________
As soon as I crest the top i'ma turn driver and floor it!

1998 4.6 stroker , aw4 XJ on 60/14b , 5.38s, grizzly/detroit, cage, 40s, psc big bore box , assist, 3 link,transgo aw4 reprogram
Reply With Quote
  #5  
Old November 23rd, 2008, 20:36
J33PsRock's Avatar
J33PsRock J33PsRock is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Vegas Baby, Vegas
Posts: 38
Re: Loud Clunk When Putting Into Drive

Not lifted. Bone stock when it comes to suspension and driveline. Not really a wheeler, it my DD.
Reply With Quote
  #6  
Old November 23rd, 2008, 20:37
blondejoncherokee's Avatar
blondejoncherokee blondejoncherokee is offline
NAXJA Member
 
Join Date: Oct 2007
Location: sacramento
Posts: 12,367
Re: Loud Clunk When Putting Into Drive

check your rear diff, mounts and lca and uca bushings
__________________
As soon as I crest the top i'ma turn driver and floor it!

1998 4.6 stroker , aw4 XJ on 60/14b , 5.38s, grizzly/detroit, cage, 40s, psc big bore box , assist, 3 link,transgo aw4 reprogram
Reply With Quote
  #7  
Old November 23rd, 2008, 20:48
J33PsRock's Avatar
J33PsRock J33PsRock is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Vegas Baby, Vegas
Posts: 38
Re: Loud Clunk When Putting Into Drive

I'll check on those things. I also just thought of another couple of things that could be related.

1) My rear leaf springs are so flat they are almost inverted the other way. I know this is pretty easy to replace, I just haven't had the days off to tackle that yet, but quite a bit of sag. When I a hot a bump one of the rear wheels scrapes the upper wheel well.

2) I began to notice this (clunking) after pulling a light trailer camping. The trailer and all of the gear and everything was probably no more than 1500 lbs. max. (Fold-up trailer and just tent, sleeping bags, kids bikes, and coolers.) IT has gotten progressively worse since then.
Reply With Quote
  #8  
Old November 23rd, 2008, 21:22
t_aldrich t_aldrich is offline
NAXJA Forum User
 
Join Date: Sep 2008
Location: Woburn, MA
Posts: 1,013
Re: Loud Clunk When Putting Into Drive

check all the things we said.

still sounds most like a ujoint or t-case chain to me
Reply With Quote
  #9  
Old November 23rd, 2008, 21:29
blondejoncherokee's Avatar
blondejoncherokee blondejoncherokee is offline
NAXJA Member
 
Join Date: Oct 2007
Location: sacramento
Posts: 12,367
Re: Loud Clunk When Putting Into Drive

your springs are a very good place to start as well if they are that flat and sagging. might as well lift it while youre at it....
__________________
As soon as I crest the top i'ma turn driver and floor it!

1998 4.6 stroker , aw4 XJ on 60/14b , 5.38s, grizzly/detroit, cage, 40s, psc big bore box , assist, 3 link,transgo aw4 reprogram
Reply With Quote
  #10  
Old November 23rd, 2008, 21:38
hanaxj87's Avatar
hanaxj87 hanaxj87 is offline
NAXJA Forum User
 
Join Date: Feb 2006
Location: Cincinnati,Ohio
Posts: 1,510
Re: Loud Clunk When Putting Into Drive

Sounds like a bad u-joint.

Good Luck

Nick
Reply With Quote
  #11  
Old November 30th, 2008, 13:40
J33PsRock's Avatar
J33PsRock J33PsRock is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Vegas Baby, Vegas
Posts: 38
Re: Loud Clunk When Putting Into Drive

No play whatsoever in the U-Joints. Definitely coming from the rear end, where the drive shaft goes into the diff. Other than the oil, what else can I check without taking stuff apart? I am thinking I will have to take it to a driveline shop.

Any ideers?
Reply With Quote
  #12  
Old November 30th, 2008, 20:00
J33PsRock's Avatar
J33PsRock J33PsRock is offline
NAXJA Forum User
 
Join Date: Dec 2004
Location: Vegas Baby, Vegas
Posts: 38
Re: Loud Clunk When Putting Into Drive

So...turns out it was the rear U-joint. I am such an idiot. I was thinking big $ for a transmission or a differential rebuild or something...and it was a $16 u-joint.

I couldn't tell that there was any play in it before, then I just changed it...fixed the problem. Thanks fellas.
Reply With Quote
  #13  
Old November 30th, 2008, 20:19
hanaxj87's Avatar
hanaxj87 hanaxj87 is offline
NAXJA Forum User
 
Join Date: Feb 2006
Location: Cincinnati,Ohio
Posts: 1,510
Re: Loud Clunk When Putting Into Drive

Glad to hear you found the problem and it didn't cost ya alot..

Nick
Reply With Quote
  #14  
Old November 30th, 2008, 21:41
matt vanjeep matt vanjeep is offline
NAXJA Forum User
 
Join Date: Dec 2005
Location: vancouver
Posts: 19
Re: Loud Clunk When Putting Into Drive

Gotta check for play in the driveshaft with the tranny in neutral, or else you won't really notice much wiggle.
Reply With Quote
  #15  
Old December 1st, 2008, 01:05
Blaine B.'s Avatar
Blaine B. Blaine B. is offline
NAXJA Forum User
 
Join Date: Jul 2006
Location: Northwest Indiana
Posts: 6,137
Re: Loud Clunk When Putting Into Drive

x2^
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Very loud front-end clunk when turning SpenceXJ Modified Tech Discussion 28 August 26th, 2008 13:55
Lurch when putting into drive? darjevon OEM Tech Discussion 3 May 11th, 2007 10:17
Drive train clunk oldebrush OEM Tech Discussion 5 May 23rd, 2006 23:53
Loud noise in 4 wheel drive Lunatic728 Modified Tech Discussion 0 November 14th, 2005 05:41
Loud clunk in the night... 4xBob Modified Tech Discussion 0 May 6th, 2005 23:45


All times are GMT -7. The time now is 13:50.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014