NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 9th, 2018, 20:16
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Oil pressure gauge

89 XJ 4L bone stock suddenly after a short drive last week the oil pressure gauge stopped moving, stuck at zero psi. Confirmed that I have adequate oil pressure with tester so guessing this is electrical. New sender and no change any ideas?
Reply With Quote
  #2  
Old February 9th, 2018, 21:36
BALTANAKT BALTANAKT is offline
NAXJA Forum User
 
Join Date: Jul 2015
Location: Boulder, Colorado
Posts: 126
Re: Oil pressure gauge

Loose ground somewhere
Reply With Quote
  #3  
Old February 9th, 2018, 21:40
lawsoncl lawsoncl is online now
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,617
Re: Oil pressure gauge

Quote:
Originally Posted by Jeff/Alaska View Post
89 XJ 4L bone stock suddenly after a short drive last week the oil pressure gauge stopped moving, stuck at zero psi. Confirmed that I have adequate oil pressure with tester so guessing this is electrical. New sender and no change any ideas?
Did you replace it with the correct sender meant for a gauge and not a switch for the idiot light? The switch physically smaller and maybe $20 and the sender is $45 as I recall. This is from memory, but I think on the sensor higher pressure=higher resistance, so reading zero means it's shorted to ground and unhooking the wire makes the gauge peg itself.
Reply With Quote
  #4  
Old February 9th, 2018, 21:43
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Thanks I'll do some searching out the grounds and was thinking along that path. FYI all other gauges working normally.
Reply With Quote
  #5  
Old February 9th, 2018, 22:08
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

I did replace it with the correct sender a Wells PS 133 from Rock Auto which was the same part number I ordered a couple years ago when I broke off the terminal on the original, which worked fine until this last month. Just tested the resistance on the one that I replaced and 1 ohm @ 0psi is the stated value which I have.
Reply With Quote
  #6  
Old February 9th, 2018, 22:20
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Do gauges besides ground or power issues suddenly fail? If so anyone out there willing to part with a working gauge if I need one?
Reply With Quote
  #7  
Old February 10th, 2018, 01:30
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,111
Oil pressure gauge

Thereís a way to test the gauge, I think it was just unplugging it a d grounding it. It should spike one way. And not grounding it goes the other extreme.

The wire is more likely to go bad than the gauge in the cluster, that test should show you some kind of results if the wire is good. But itís possible the gauge is bad, I forget how itís supposed to react to the ignition being turned to on.

Iíll try to see if I can find the testing procedure from the Jeep electrical troubleshooting book, but if memory serves it was essentially grounding the sending gauge wire.


Sent from my iPhone using Tapatalk
Reply With Quote
  #8  
Old February 10th, 2018, 01:35
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Green and everyone thanks for your responses. I thought about grounding the sensor wire but it is carrying full battery voltage 13volts + running so would I not see some sparks or burning up a wire, blown fuse etc.?
Reply With Quote
  #9  
Old February 10th, 2018, 01:46
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,111
Oil pressure gauge

No. Itíll be fine. Your not trying to put the full battery through that wire, just testing resistance.

In fact it doesnít need to be running for the test, just ignition to on


Here is the jeep trouble shooting guide for 1988. If you can zoom in it should explain everything like 1 ohm = 0 psi, 88 ohm 80 psi.
Basically disconnected the gauge should read H , grounded L, if that checks out the sender is bad, if not the gauge is bad. But keep in mind that sender wire could have a problem too.







Sent from my iPhone using Tapatalk
Reply With Quote
  #10  
Old February 10th, 2018, 01:52
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Thanks again I will try your suggestions tomorrow and report back with the results.
Reply With Quote
  #11  
Old February 10th, 2018, 01:52
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,111
Oil pressure gauge

BTW there could be a bad ground some place, but if the other gauges work Iíd guess the ground to the cluster is good. If non of the gauges work then bad ground or the fuse is blown.

Thereís also the c101 plug on the engine harness that caused problem with Renix jeeps, however I believe 89-90 Renix jeeps were fixed and donít have the c101 plug


Sent from my iPhone using Tapatalk
Reply With Quote
  #12  
Old February 10th, 2018, 02:03
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Not entirely sure of perfect grounds on this old guy but will inspect and clean them, I checked and replaced the fuse as number 1 troubleshooting item. All of the other gauges are working perfectly. It's got that bulkhead connector if that is the c101 you reference? I cleaned out that bugger several years ago but may be time to inspect it again. The weather is a bit cold for working with anything plastic at the moment though.
Reply With Quote
  #13  
Old February 10th, 2018, 02:13
Green Mesa XJ's Avatar
Green Mesa XJ Green Mesa XJ is offline
NAXJA Forum User
 
Join Date: Aug 2004
Location: Pensacola, FL
Posts: 1,111
Oil pressure gauge

No, itís some kind of weird plug Renix jeeps has 87-88 model years. Yours shouldnít have it.
http://cruiser54.com/?p=24

If youíre bulkhead had issues then maybe itís still a problem. By bulkhead I am thinking of where the engine harness bolts to the dash harness at the firewall behind the fuse box. Those things are usually greased up good enough they donít have too many problems unless brake fluid leaks on them and the fuse box from the clutch master cylinder .

More likely itís simple, either bad sender, wire or gauge, even a weird failure of the ignition switch not Turing on the accessories. this is assuming the rest gauges work, that should indicate the rest of the grounds and wiring is working. Although those jeeps like to cause problems if any of the grounds are bad.



Sent from my iPhone using Tapatalk
Reply With Quote
  #14  
Old February 10th, 2018, 04:34
Jeff/Alaska Jeff/Alaska is offline
NAXJA Forum User
 
Join Date: Jun 2003
Location: Alaska
Posts: 31
Re: Oil pressure gauge

Will be removing the dash cluster and testing from that end in a day or two so wish me luck.
Reply With Quote
  #15  
Old February 10th, 2018, 08:59
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,324
Re: Oil pressure gauge

Ground the wire with the key on and observe the gauge. This is the starting point.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure gauge XJeeper87 OEM Tech Discussion 6 September 12th, 2010 19:59
Oil Pressure Gauge darkoverlift OEM Tech Discussion 4 April 28th, 2009 12:53
Oil pressure gauge malfunction or oil pressure spike? Daedalus454 OEM Tech Discussion 5 August 5th, 2008 22:09
Oil pressure gauge mudslinger4x4 OEM Tech Discussion 2 February 5th, 2008 08:34
oip pressure gauge help lenny OEM Tech Discussion 5 August 1st, 2005 16:07


All times are GMT -7. The time now is 13:40.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014