NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old February 9th, 2015, 08:46
Redsnake Redsnake is offline
NAXJA Forum User
 
Join Date: May 2004
Location: Tulsa, OK
Posts: 1,029
01 Rear Hatch Glass washer pump ?

OK... so a few days back my rear washer stopped working. The pump was still humming when I tried to use it and the reservoir was full. So I tried some basics... I went ahead and pulled the old pump out, drained the fluid tank and then disconnected the rear hose from the wiper.

To verify there wasn't any obstruction, I had my wife stand at the rear hatch and hold her finger over the hole and blew some mild air thru the hose from where it attaches to the motor out the back. There was sufficient air for her to feel it and it sounded smooth. Reconnected with new pump motor and filled the fluid bottle back up... activated the rear pump motor/switch (could hear the new pump running) and after several seconds of priming and trying to get fluid to flow there was nothing.

Pulled the rear inner hatch liner and checked the check-valve w/the little ball 'thingy' and that was clean and functioning fine. I also hooked up my mighty vac to the tubing to check for leaks. Mighty vac held pressure for a couple minutes no problem.

I'm at a loss here... Can't find any leaks, pump is new and running... what else could it be? Any other ideas of what to check?

Appreciate any ideas...
Reply With Quote
  #2  
Old February 9th, 2015, 09:05
Lowrange2's Avatar
Lowrange2 Lowrange2 is offline
Member# 2368
 
Join Date: Nov 2006
Location: Abbeville, SC
Posts: 15,748
Re: 01 Rear Hatch Glass washer pump ?

Is it pumping directly at the pump? Pulled the hose from the pump and turned the pump on?

Obstruction in the fluid tank?
Reply With Quote
  #3  
Old February 9th, 2015, 09:10
Redsnake Redsnake is offline
NAXJA Forum User
 
Join Date: May 2004
Location: Tulsa, OK
Posts: 1,029
Re: 01 Rear Hatch Glass washer pump ?

I wouldn't think there is any obstruction in the tank as fluid poured out twice... both when I pulled the upper (rear) old pump off to change it and then again when I pulled it a second time to run air thru the hoses again to check for air flowing throughout the lines. The front washer pump works great and it's the lower pump of the 2 in question.

I didn't try running the pump while in the reservoir tank with the output hose disconnected as I didn't want to clean up the mess it would cause... I guess I could try that and see if fluid goes shooting out. :|
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
pre 97 rear hatch glass & 2 door side glass 1999mj NAC Classifieds 0 March 10th, 2012 16:21
Rear hatch glass xjfrankie SoCal For Sale 1 December 6th, 2010 17:22
rear glass, door glass, hood, hatch, doors, alternators, lights and other body parts blondejoncherokee Sierra Chapter For Sale 1 June 17th, 2010 02:16
97+ Rear Hatch Glass MELKORsXJ SEC For Sale / Wanted Forum 9 February 7th, 2008 20:36
1999 Rear wiper motor. Hatch Solenoid. Hatch glass (tinted) Odarby For Sale: Private Party Only. XJ ITEMS ONLY 0 June 21st, 2007 16:14


All times are GMT -7. The time now is 04:07.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014