NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old June 8th, 2005, 17:41
Storydude Storydude is offline
NAXJA Forum User
 
Join Date: Jan 2005
Location: buffalo
Posts: 288
Coolant Temp Sensor causes High Idle RENIX?

Hi all. Just trying to figure out this high idle problem.
88 MJ RENIX 4 cyl. 4 speed.

Replaced the Intake/exhaust gasket because it was toasted, Idle came down about 300-500 RPM.

When it's cold, it idles right at 750RPM. As it warms up, idle keeps climbing, untill it's around 2500-3K at fully warm. Idle Speed motor is working, and adjusted correctly. I tested the CTS, and it's cooked. All new Vac. lines, and no leaks around intake, or TB. Throttle plate is closed all the way.

Will a Blown CTS cause a rich running condition, and high idle???
Reply With Quote
  #2  
Old June 8th, 2005, 18:14
rockwerks's Avatar
rockwerks rockwerks is offline
NAXJA Forum User
 
Join Date: May 2002
Location: Chito Beach Resort, WA
Posts: 3,976
Re: Coolant Temp Sensor causes High Idle RENIX?

Quote:
Originally Posted by Storydude
Hi all. Just trying to figure out this high idle problem.
88 MJ RENIX 4 cyl. 4 speed.

Replaced the Intake/exhaust gasket because it was toasted, Idle came down about 300-500 RPM.

When it's cold, it idles right at 750RPM. As it warms up, idle keeps climbing, untill it's around 2500-3K at fully warm. Idle Speed motor is working, and adjusted correctly. I tested the CTS, and it's cooked. All new Vac. lines, and no leaks around intake, or TB. Throttle plate is closed all the way.

Will a Blown CTS cause a rich running condition, and high idle???
might but my quess would be the map senser, if you rev the motor will the idle come down?
Reply With Quote
  #3  
Old June 8th, 2005, 18:18
Storydude Storydude is offline
NAXJA Forum User
 
Join Date: Jan 2005
Location: buffalo
Posts: 288
Re: Coolant Temp Sensor causes High Idle RENIX?

Quote:
Originally Posted by xjnation
might but my quess would be the map senser, if you rev the motor will the idle come down?
Nope. And MAP sensor tested within spec.

That's the ONLY sensor that's bad, and I'm wanting some background before dropping 25 bones on a THERMOMETER. Other than the high idle, it runs GREAT....but I want to fix it before I melt my new Clutch because of the high idle. It'll lope along at 45 in 4th with my foot off the gas.

EDIT: I went out and re-torqued the intake, all were where I left them. sprayed Carb cleaner around the intake, and no change in idle speed, so there is no leak there. I removed that big Black Vac. Block to the left of the TB, and ran ALL new lines to replace it. New TB gasket, and no Vac. Leaks I can find.

It seems like an old Carbed engine when the choke sticks..
Reply With Quote
  #4  
Old June 8th, 2005, 19:34
georgemu georgemu is offline
NAXJA Forum User
 
Join Date: Mar 2003
Location: crestwood,ky
Posts: 34
Re: Coolant Temp Sensor causes High Idle RENIX?

Unplug the CTS and jump the plug with a resistor, RadioShack?, and see if it helps.
I'd pick a value for 190 to 210 degrees F.

Go here for resistance / temp values:http://www.angelfire.com/my/fan/CTS.html

Let us know.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Coolant gauge reading low... rough idle.. 4.0 Talyn OEM Tech Discussion 3 December 3rd, 2004 08:56
very high idle Mudskipper OEM Tech Discussion 6 October 24th, 2004 20:33
High Idle - After Driving; Weird TPS... LynchMob OEM Tech Discussion 5 November 10th, 2003 17:41
Idle is high on 4.0l 88justin OEM Tech Discussion 6 April 14th, 2003 15:15
high idle problem frsno jeeper Sierra Chapter 6 January 12th, 2003 12:33


All times are GMT -7. The time now is 07:03.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014