NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old April 9th, 2012, 21:48
AnthonyZ28's Avatar
AnthonyZ28 AnthonyZ28 is offline
NAXJA Forum User
 
Join Date: Feb 2012
Location: Hallettsville, Texas
Posts: 162
Voltage problem with coolant temp sensor.

I have a error code #22 thats causing my check engine light to be one. Code #22 is the coolant temp sensor is recieving too much or not enough voltage. Today I replaced the sensor itself and the code was still there. The thing still drives like a champ but the check engine light bothers me. Im not quite sure how to resolve this problem.
Reply With Quote
  #2  
Old April 10th, 2012, 08:03
whitexj98 whitexj98 is offline
NAXJA Forum User
 
Join Date: Feb 2007
Location: Fraser, MI
Posts: 2,140
Re: Voltage problem with coolant temp sensor.

Its not thats its recieving but that it is returning to high/to low... to low is below .5v, to high is above 4.5v need to figure out which one it is high or low... this can be done with a DRB or by backprobing... also need to carfully inspect the wires as far back as you can.
Reply With Quote
  #3  
Old April 10th, 2012, 15:18
AnthonyZ28's Avatar
AnthonyZ28 AnthonyZ28 is offline
NAXJA Forum User
 
Join Date: Feb 2012
Location: Hallettsville, Texas
Posts: 162
Re: Voltage problem with coolant temp sensor.

I drove it to and from school today and the light was off. So hopefully that was my problem.
Reply With Quote
  #4  
Old April 11th, 2012, 07:22
bmsmalley bmsmalley is offline
NAXJA Forum User
 
Join Date: May 2011
Location: Montgomery Texas
Posts: 100
Re: Voltage problem with coolant temp sensor.

are you talking about the sensor that is on the back of the head? If so, I broke mine off while trying to replace it. Do you know if there is an alternate location I can install the new one....getting whats left of the old one out is going to be a PITA.
Reply With Quote
  #5  
Old April 11th, 2012, 18:22
ca_digger's Avatar
ca_digger ca_digger is offline
NAXJA Forum User
 
Join Date: Mar 2008
Location: corona,ca
Posts: 30
Re: Voltage problem with coolant temp sensor.

bm i have mine in the water neck in front alot easier to change out
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
P0117 Coolant sensor low voltage CEL alaskan OEM Tech Discussion 11 January 22nd, 2010 20:51
Coolant temp. sensor RyleyF OEM Tech Discussion 8 July 14th, 2008 11:35
Engine Coolant Temperature Circuit Sensor Low Voltage 98XJSport OEM Tech Discussion 15 February 15th, 2007 07:52
Coolant temp. sensor? TBLimited OEM Tech Discussion 16 February 15th, 2005 08:18
Coolant Temp. Sensor Xtreme XJ OEM Tech Discussion 8 June 30th, 2003 18:16


All times are GMT -7. The time now is 07:09.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014