NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old August 29th, 2009, 06:10
FallibleXJ FallibleXJ is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: Rochester, NY
Posts: 370
Jeep won't start

hey folks. I've been on a road trip from CA to NY. Last night as I pulled into a hotel after driving for 11-12 hours I pulled into the awning area so I could go find a room. my electric fan didn't turn off (this has been a recurring problem) so I popped the hood and reset its relay, I have done this a few times before. When I came back out to move my jeep about 10minutes later it wouldn't fire. Turns over just fine, there is fuel pressure in the fuel rail, and the battery is putting out over 12 volts.

I had to get my jeep out from under their awning so a local truck came by and we pushed it out of the way. He tried listening for the fuel pump through the gas tank? He also tried hitting the gas tank to try "vibrating the fuel pump so it will start" I hadn't heard of either of these techniques, but hey what do I know.

I thought maybe I had pumped on of the other relays while I was in there, and it is certainly possible. I pulled out the Fuel Pump and ASD relays and reset them just as a check and still no go. I had it shut down at a rest stop about 45minutes prior to the failure and it started just fine then.

The past month or two I have been having a few odd problems, just throwing them out here too just incase it is related:
  • Speedometer and RPM gauge die periodically and come back again after a few minutes
  • Cruise control dies periodically, same time as above
  • Electric Fan stays on after jeep has been shut off
  • Takes several seconds to start up some mornings

Its a 97' Cherokee
Reply With Quote
  #2  
Old August 29th, 2009, 07:22
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: Jeep won't start

You say "reset" the relays, which makes me think you have pulled them and put them back in the same spot.

Have you tried swapping the relays?

The fan staying on sure sounds to me like a sticking relay. Check the numbers and try swapping them around--not sure on the 97 if the ASD is the same as the others. If the problem is the relays stop at a salvage yard and grab yourself a handful so you have some spares on board.

Last edited by joe_peters; August 29th, 2009 at 07:28.
Reply With Quote
  #3  
Old August 29th, 2009, 07:35
winterbeater's Avatar
winterbeater winterbeater is offline
NAXJA Forum User
 
Join Date: Jul 2008
Location: Royal Oak, Michigan
Posts: 5,315
Re: Jeep won't start

You could try unplugging and replugging the crank position sensor a few times to refresh the connection. Maybe corrosion over time decreased continuity. (admittedly a long shot)
Reply With Quote
  #4  
Old August 29th, 2009, 08:00
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: Jeep won't start

Quote:
Originally Posted by winterbeater View Post
You could try unplugging and replugging the crank position sensor a few times to refresh the connection. Maybe corrosion over time decreased continuity. (admittedly a long shot)
x2, not all that much of a long shot. Your fan staying on may not have any relation to the no start.
Reply With Quote
  #5  
Old August 29th, 2009, 08:11
FallibleXJ FallibleXJ is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: Rochester, NY
Posts: 370
Re: Jeep won't start

It was very humid and rainy throughout the day, which could add to the corrosion. I'll check that

EDIT: This could have been a rookie mistake. Since I have been driving cross country I've had to refuel many times. Normally I put in 97 Octane, however there was once that I put in 86 octane due to availability, and a couple times I put in 89 because it was cheap (comparatively).

Last edited by FallibleXJ; August 29th, 2009 at 08:15.
Reply With Quote
  #6  
Old August 29th, 2009, 08:58
FallibleXJ FallibleXJ is offline
NAXJA Forum User
 
Join Date: Nov 2008
Location: Rochester, NY
Posts: 370
Re: Jeep won't start

ASD relay!

Good call guys. Peace out, thanks much
Reply With Quote
  #7  
Old August 29th, 2009, 13:21
joe_peters joe_peters is offline
NAXJA Forum User
 
Join Date: Apr 2008
Location: Grants Pass, OryGun
Posts: 13,746
Re: Jeep won't start

Great! Hope your trip goes on w/o any more problems.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Jeep no start HeavyMetal OEM Tech Discussion 5 April 17th, 2009 03:35
Please help! jeep won't start rc_mx5 OEM Tech Discussion 9 January 1st, 2009 07:48
Jeep won't start ZacSquatch OEM Tech Discussion 5 February 20th, 2007 18:32
Jeep will not start Undeclared OEM Tech Discussion 1 March 2nd, 2005 16:53
Jeep No start buffalomatt350 OEM Tech Discussion 4 August 4th, 2004 19:43


All times are GMT -7. The time now is 15:21.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2018, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014