NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old October 2nd, 2017, 18:44
Francesco Francesco is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: Ventura County
Posts: 112
Renix Issue

Hello all,
I'm stupmed. My renix 4.0 is running very funny. When it's cold I have around a half second delay in any gas pedal usage, and my idle bounces from 1k to almost stalling every second or two. If I give it a little gas, the rpms still bounce, just at a higher rpm(think leaving foot on the gas a bit) so its not just idle related. Here is a list of what I've done:
Checked:
Intake air temp
O2 sensor
Coolant temp
EGR and it's sensor
Replaced: (somewhat recently)
IAC
TPS
O2 sensor
Knock sensor
Fuel filter
So to recap, my idle bounces a lot when cold, and still does when warm, but a lot less. It has a delay in throttling up, more pronounced when cold. I also cleaned the throttle body about a year ago, so it had been a little bit but I wouldn't expect it to be gunked up yet. The engine runs well other than this, however it seems slower than it should be. Any suggestions? I will update this as I go , in hopes that this will be figured out.
Thanks
Francesco
Reply With Quote
  #2  
Old October 3rd, 2017, 06:43
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,229
Re: Renix Issue

Have you ever visited my website?
www.cruiser54.com

Do tips 1 through 5 first.

Did you adjust your new TPS?

What brand O2 sensor did you use?
Reply With Quote
  #3  
Old October 3rd, 2017, 07:51
burntkat burntkat is offline
NAXJA Member #1145
 
Join Date: Apr 2003
Location: Charleston, SC
Posts: 827
Re: Renix Issue

Shouldn't this be in OEM Tech?
__________________
-89 S-10: SAS, D44s front/rear. 5.7L V8. 700R4 with 4L60E upgrades. Built in my driveway.
-90 XJ 4.0, AW4, 231J: Clayton's longarms, RE 5.5" coils, hybrid 6" leaf pack, 33/12.50/15" MTs, Rancho 99012s and 99624s, Tera HD SYE, custom sliders, BW flares. Next: finish front, build rear bumpers, Dana 44's front and rear.
-94 ZJ: Budget boost, 31's. The wife's mall crawler. She's gotten inchitis over my S10 though...
-97 XJ: Son's DD. Mild mods for the new driver.
Reply With Quote
  #4  
Old October 3rd, 2017, 07:55
Francesco Francesco is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: Ventura County
Posts: 112
Re: Renix Issue

Maybe it should be in OEM Tech, I didn't even think about it, I apologize. And to Cruiser, I have been to your website, and I've done almost all of your suggestions.

Edit: to be more exact, I have:
cleaned grounds
1990 so no c101 connector
replaced coil recently and cleaned it
cleaned sensor grounds, and added 2 extra ground straps per your suggestions
tested egr via your method(engine almost stalls out when pulling back pin, and there is no vacuum at idle)
CPS timing advance mod
Volvo injector swap

Last edited by Francesco; October 3rd, 2017 at 08:09.
Reply With Quote
  #5  
Old October 4th, 2017, 18:47
Francesco Francesco is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: Ventura County
Posts: 112
Re: Renix Issue

Any suggestions? I have a new fuel pump ballast resistor coming in(mine is literally cracked in half, figured it's good to replace anyways), but I'm fresh out of ideas.
Thanks
Reply With Quote
  #6  
Old October 4th, 2017, 20:02
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,573
Re: Renix Issue

Hook up a vacuum gauge and see what it is doing. Hook up a timing light and see what it is doing. These will tell you a lot about what is happening.
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.
Reply With Quote
  #7  
Old October 4th, 2017, 20:09
Rob Mayercik's Avatar
Rob Mayercik Rob Mayercik is offline
NAXJA Member #920
 
Join Date: Jun 2002
Location: NJ, U.S.A.
Posts: 1,942
Re: Renix Issue

Don't know about the Renix, but on an H.O. like mine, the ballast resistor can be bypassed and eliminated - I believe all it does is knock down the voltage to the fuel pump slightly to reduce noise. When mine fell apart, I threw it away and spliced the two wires together.

If yours is cracked, maybe the connection through it is intermittent or weak. You could try jumping around the resistor temporarily and see if it changes how it runs.
__________________
1992 Cherokee Laredo: "A wonderful balance of grace and rust"
1984 Dodge Omni
2002 Volkswagen Jetta GLS TDI
Reply With Quote
  #8  
Old October 4th, 2017, 20:40
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,229
Re: Renix Issue

Quote:
Originally Posted by Rob Mayercik View Post
Don't know about the Renix, but on an H.O. like mine, the ballast resistor can be bypassed and eliminated - I believe all it does is knock down the voltage to the fuel pump slightly to reduce noise. When mine fell apart, I threw it away and spliced the two wires together.

If yours is cracked, maybe the connection through it is intermittent or weak. You could try jumping around the resistor temporarily and see if it changes how it runs.
Yup. It's only there to reduce noise.
Reply With Quote
  #9  
Old October 5th, 2017, 09:46
burntkat burntkat is offline
NAXJA Member #1145
 
Join Date: Apr 2003
Location: Charleston, SC
Posts: 827
Re: Renix Issue

Quote:
Originally Posted by Rob Mayercik View Post
Don't know about the Renix, but on an H.O. like mine, the ballast resistor can be bypassed and eliminated - I believe all it does is knock down the voltage to the fuel pump slightly to reduce noise. When mine fell apart, I threw it away and spliced the two wires together.

If yours is cracked, maybe the connection through it is intermittent or weak. You could try jumping around the resistor temporarily and see if it changes how it runs.
Can confirm this works. I threw away mine in the 90, worked fine after.

Personally, I LIKE hearing my fuel pump during crank cycle.
__________________
-89 S-10: SAS, D44s front/rear. 5.7L V8. 700R4 with 4L60E upgrades. Built in my driveway.
-90 XJ 4.0, AW4, 231J: Clayton's longarms, RE 5.5" coils, hybrid 6" leaf pack, 33/12.50/15" MTs, Rancho 99012s and 99624s, Tera HD SYE, custom sliders, BW flares. Next: finish front, build rear bumpers, Dana 44's front and rear.
-94 ZJ: Budget boost, 31's. The wife's mall crawler. She's gotten inchitis over my S10 though...
-97 XJ: Son's DD. Mild mods for the new driver.
Reply With Quote
  #10  
Old October 5th, 2017, 15:30
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,229
Re: Renix Issue

Yup. 87s didn't even have a resistor.
Reply With Quote
  #11  
Old October 6th, 2017, 13:38
Rob Mayercik's Avatar
Rob Mayercik Rob Mayercik is offline
NAXJA Member #920
 
Join Date: Jun 2002
Location: NJ, U.S.A.
Posts: 1,942
Re: Renix Issue

Quote:
Originally Posted by cruiser54 View Post
Yup. 87s didn't even have a resistor.
Precisely - if memory serves, they first appeared under a TSB because people were complaining about "that strange humming noise from the back".

Mine's been gone so long I don't remember if I used to hear it priming prior to starting, but I don't recall any difference in noise once the engine was going.
__________________
1992 Cherokee Laredo: "A wonderful balance of grace and rust"
1984 Dodge Omni
2002 Volkswagen Jetta GLS TDI
Reply With Quote
  #12  
Old October 6th, 2017, 17:11
lawagoneer lawagoneer is offline
NAXJA Member
 
Join Date: Apr 2010
Location: Fordoche, LA
Posts: 163
Re: Renix Issue

How is your battery and charging system. Before I upgraded my system, alternator, battery, cables my Renix did all sorts of weird things with drivability and idle. Fully charged battery, properly functioning alternator, good cables, clamps and grounds and the idle and drivability weirdness went away. Everyone knows that a Renix is sensitive to grounds but they also like good clean power from the charging system.
Reply With Quote
  #13  
Old October 6th, 2017, 21:24
cruiser54's Avatar
cruiser54 cruiser54 is offline
NAXJA Forum User
 
Join Date: Nov 2009
Location: Prescott, Az
Posts: 6,229
Re: Renix Issue

Quote:
Originally Posted by lawagoneer View Post
How is your battery and charging system. Before I upgraded my system, alternator, battery, cables my Renix did all sorts of weird things with drivability and idle. Fully charged battery, properly functioning alternator, good cables, clamps and grounds and the idle and drivability weirdness went away. Everyone knows that a Renix is sensitive to grounds but they also like good clean power from the charging system.
Grounds are more important than the charging system.
Reply With Quote
  #14  
Old October 7th, 2017, 10:14
Francesco Francesco is offline
NAXJA Forum User
 
Join Date: Dec 2015
Location: Ventura County
Posts: 112
Re: Renix Issue

Regardless, I have cleaned the ground at the block, the ground at the valve cover, added an extra ground from firewall to fuel rail, and from battery to core support area. I really don't think it's a grounding issue. I also have pulled the main harness plug, cleaned that, and filled with ox-gard equivalent.
Reply With Quote
  #15  
Old October 7th, 2017, 10:46
Wayne Sihler's Avatar
Wayne Sihler Wayne Sihler is offline
NAXJA Member
 
Join Date: May 2002
Location: Maurertown,Va.
Posts: 2,545
Re: Renix Issue

Dont see anything about a MAP sensor or the related vac hoses.
Problem like this on the 87 was the rubber part on the TB had failed.
__________________
Wayne
Member#17
NRA Life member, AARP NovaJeepers
96XJ,4.0,AW4,D30/D44,4:10s,Detroit,4.5" lift 33,s
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Renix Issue!!!! JustinTurney OEM Tech Discussion 11 October 3rd, 2012 13:14
88 4L Renix cranking issue DaveVmax OEM Tech Discussion 83 March 24th, 2011 23:15
renix running issue ctxjlimited OEM Tech Discussion 7 August 30th, 2009 09:32
Renix issue? jujuscisyn OEM Tech Discussion 99 July 6th, 2009 19:27
Please help! Renix with an issue! Bensride OEM Tech Discussion 5 August 23rd, 2007 20:30


All times are GMT -7. The time now is 06:04.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014