NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 30th, 2017, 06:59
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
96 no start after changing the battery

My Cherokee battery was over five years old and wasn't cranking over anymore, so I went and brought a new one.
Put the key in and now I don't hear the fuel pump turn on.Try replacing the fuel
pump relay and that didn't work. Any suggestion on what I should check?

Thanks in advance, Chris
Reply With Quote
  #2  
Old November 30th, 2017, 16:24
JeepNoob JeepNoob is offline
NAXJA Forum User
 
Join Date: Oct 2014
Location: Pueblo, Colorado
Posts: 266
Re: 96 no start after changing the battery

Any other electric stuff not working? There's a fusible link wire (or there SHOULD be, at least) at the front of the engine fuse box between two studs. If multiple things aren't working or don't have power, I'd check that first.
Reply With Quote
  #3  
Old November 30th, 2017, 22:14
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,539
Re: 96 no start after changing the battery

Quote:
Originally Posted by JeepNoob View Post
Any other electric stuff not working? There's a fusible link wire (or there SHOULD be, at least) at the front of the engine fuse box between two studs. If multiple things aren't working or don't have power, I'd check that first.

Had that issue with a 93 ZJ after having the battery replaced. Turned out they squished the wire and connector that was next to the battery. The Jeep would die when it hit a bump, I'd tow it home, and it'd be fine once it hit the driveway. It finally stayed dead so I could chase it down and found out that all the computer and sensor grounds merged together into that single wire.
Reply With Quote
  #4  
Old December 2nd, 2017, 10:23
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
Re: 96 no start after changing the battery

Took the cover off the front of the fuse box and there are just two wires held down by a nut, no fuse block. Checked on a different Cherokee and the same thing, no fusible link.
Going to change the positive cable to see if that does anything.
Thanks again for the help. I need to get it running again before it snows.
Reply With Quote
  #5  
Old December 2nd, 2017, 11:15
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,539
Re: 96 no start after changing the battery

Do you have a meter or a test light? That would make testing power cables and such much quicker instead of ripping and replacing at random. Measure various points while trying to crank to see if you have voltage where you're supposed to and no voltage where you're not (ie, ground wires).

If you have power to other things while hitting the key to crank, it's probably not the power cable to the fuse box. I don't recall whether the starter has it's own cable from the battery to the solenoid, or whether the feed came off the stud at the fuse box.
Reply With Quote
  #6  
Old December 2nd, 2017, 14:21
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
Re: 96 no start after changing the battery

It's weird that not I am getting no power to the fuel pump. It cranks and all the other electrical components work but I don't hear the pump turn on and there is no fuel in the rail. How do I check the wiring to see if I'm getting power to the fuel pump?
Reply With Quote
  #7  
Old December 2nd, 2017, 15:28
lawsoncl lawsoncl is offline
NAXJA Forum User
 
Join Date: Jan 2006
Location: North Idaho
Posts: 4,539
Re: 96 no start after changing the battery

Quote:
Originally Posted by 1995xjrd View Post
It's weird that not I am getting no power to the fuel pump. It cranks and all the other electrical components work but I don't hear the pump turn on and there is no fuel in the rail. How do I check the wiring to see if I'm getting power to the fuel pump?

You tried swapping out the ASD relay? That will kill spark as well.
Reply With Quote
  #8  
Old December 2nd, 2017, 23:39
Dragonslayer Dragonslayer is offline
NAXJA Forum User
 
Join Date: Feb 2004
Location: Los Angeles
Posts: 275
Re: 96 no start after changing the battery

"Took the cover off the front of the fuse box and there are just two wires held down by a nut, no fuse block. Checked on a different Cherokee and the same thing, no fusible link."

The fusible link is not a "fuse block" - it is incorporated within the 10 gauge green cable
at the front of the Power Distribution Center (PDC) - held down by a stud and nut.

The green cable emerges out of the PDC and is routed underneath the PDC.
You'll then see a plastic splice there. The cable then disappears into the wire harness.
It then emerges from the wire harness as a 6 gauge Black/White wire that terminates at the back of the alternator.

Disconnect the fusible link at the PDC, and the alternator, and then test it for continuity.

Of course, you'll want to disconnect the battery before doing any of this.
Reply With Quote
  #9  
Old December 5th, 2017, 07:54
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
Re: 96 no start after changing the battery

To test the fusible link is the cable going down to the alternator connects into a black plastic box located on the back of the alternator the one i should disconnect?
Reply With Quote
  #10  
Old December 5th, 2017, 14:29
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
Re: 96 no start after changing the battery

I disconnected the black wire that comes out of the plastic black box and is grounded to the back of the alternator and used that wire to test the fuse and there is no continuity.
Did I use the right wire?
Reply With Quote
  #11  
Old December 11th, 2017, 14:49
1995xjrd 1995xjrd is offline
NAXJA Forum User
 
Join Date: May 2016
Location: nj
Posts: 6
Re: 96 no start after changing the battery

Checked the fusible link and it has continuity. I can't seem to figure out how I don't have power to the fuel pump? Anybody have any suggestions on what to check next?

Thanks, chris
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
battery died, now crank no start ehall OEM Tech Discussion 7 February 9th, 2011 19:16
A short kills my Battery right after start up. it will only start with a jump help! paxj1112 OEM Tech Discussion 4 June 30th, 2007 21:22
Alternator not changing battery? BrokenXJ OEM Tech Discussion 2 February 23rd, 2004 21:01
disconnect battery when changing oil? dogtired OEM Tech Discussion 8 February 2nd, 2004 08:58
dead battery now no start onetallmj OEM Tech Discussion 2 August 18th, 2003 23:36


All times are GMT -7. The time now is 04:00.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014