NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > Modified Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

Modified Tech Discussion Forum for Tech related discussion for Modified XJ's and MJ's.

Reply
 
Thread Tools Display Modes
  #1  
Old April 9th, 2017, 22:12
1989AMCXJ 1989AMCXJ is offline
NAXJA Forum User
 
Join Date: Sep 2016
Location: Big Bear Lake
Posts: 31
89 Renix XJ warm engine no-start

I have been researching this issue for quite some time now and can't seem to find a solution, so here it goes...starts cold perfectly. Runs perfect. Stop and let it sit, won't start. Wait for 20 30 minutes starts, but rough at first, then smooths out. If you crank it too much in the no start condition, it will flood out. And you will wait longer to get it to start once cold. New parts: all sensors are new. The entire fuel system front to back is new. New bad part? Maybe. Diagnostics all within range. Please help...


Sent from my iPhone using Tapatalk
Reply With Quote
  #2  
Old April 10th, 2017, 12:19
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,303
Re: 89 Renix XJ warm engine no-start

Try cycling the key a few times before starting, if that fixes it then you have a heat soak problem. That is where the fuel in the rail basically boils off from the residual heat in the engine and it takes the fuel pump a bit to get the bubble through the system.

If not, I would think about the ignition module or coil. You can kind of test it with a squirt bottle of water. Get it hot to the point where it won't start, then spritz the coil/module several times to cool them off and see if that fixes it. If so you have either a bad coil or ignition module.
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.
Reply With Quote
  #3  
Old April 10th, 2017, 13:17
cwyman6 cwyman6 is offline
NAXJA Forum User
 
Join Date: Aug 2014
Location: socal
Posts: 59
Re: 89 Renix XJ warm engine no-start

I had this problem on my 88. Turned out to be the ignition switch. Still could be a heat soak problem if the fuel pump check valve has gone bad or fuel pressure is low
Reply With Quote
  #4  
Old April 10th, 2017, 13:59
1989AMCXJ 1989AMCXJ is offline
NAXJA Forum User
 
Join Date: Sep 2016
Location: Big Bear Lake
Posts: 31
Re: 89 Renix XJ warm engine no-start

Thank you both for a response. first off, the coil is about three years old, but I did replace the Coil module (made in USA). along with all relays and the starter relay. I do however have a new Delphi GN10155 Ignition Coil on order. Sometimes, at first, I could cycle the key, and after the fuel pump stops its initiation, it would start...but now it wont at all. I will try the squirt bottle approach, but if it is in fact a heat soak issue, any thoughts on a fix? to cwyman6, the entire fuel pump assembly is new, along with all high pressure injector fuel lines, pressure control valve, and 3gen bosch four hole injectors.
Reply With Quote
  #5  
Old April 10th, 2017, 14:14
old_man's Avatar
old_man old_man is offline
NAXJA Member
 
Join Date: May 2003
Location: Loveland, Colorado
Posts: 15,303
Re: 89 Renix XJ warm engine no-start

With good components, you should not have heat soak. So if you find a component that works after you cool it down, replace it.
__________________
Tom Houston - Former Colorado Chapter President & Terminal Adrenaline Junkie
Loveland, Colorado
You're just jealous because the voices don't talk to you.
Reply With Quote
  #6  
Old April 10th, 2017, 16:53
1989AMCXJ 1989AMCXJ is offline
NAXJA Forum User
 
Join Date: Sep 2016
Location: Big Bear Lake
Posts: 31
Re: 89 Renix XJ warm engine no-start

Thanks...
Reply With Quote
  #7  
Old April 11th, 2017, 13:24
cwyman6 cwyman6 is offline
NAXJA Forum User
 
Join Date: Aug 2014
Location: socal
Posts: 59
Re: 89 Renix XJ warm engine no-start

I would point towards the ignition switch not supplying full power in the start position.
Reply With Quote
  #8  
Old April 11th, 2017, 13:34
1989AMCXJ 1989AMCXJ is offline
NAXJA Forum User
 
Join Date: Sep 2016
Location: Big Bear Lake
Posts: 31
Re: 89 Renix XJ warm engine no-start

so how does the ignition switch relate to a warm engine no start?
Reply With Quote
  #9  
Old April 11th, 2017, 15:23
Dubster Dubster is offline
NAXJA Member
 
Join Date: Jul 2011
Location: North San Diego County
Posts: 94
Re: 89 Renix XJ warm engine no-start

I had the exact same symptoms on a newer XJ. Cold, started and ran fine. Warm, stop and go into the store, come back and it either wouldn't start or ran like crap. Acted like it was flooded.

Ended up being a bad temp sensor. It was causing the computer to think the engine was cold even though it was up to operating temperature.

Just a thought. Makes more sense than an ignition switch issue.

dub
Reply With Quote
  #10  
Old April 11th, 2017, 19:22
1989AMCXJ 1989AMCXJ is offline
NAXJA Forum User
 
Join Date: Sep 2016
Location: Big Bear Lake
Posts: 31
Re: 89 Renix XJ warm engine no-start

Dubster: both temp sensors are under 90 days old, and I have a REM + reader that reads out the temps along with the factory gauges, and all seems to be well...I am going bonkers with this!!!
Reply With Quote
  #11  
Old April 12th, 2017, 13:56
cwyman6 cwyman6 is offline
NAXJA Forum User
 
Join Date: Aug 2014
Location: socal
Posts: 59
Re: 89 Renix XJ warm engine no-start

Need to check power at the icm when cranking. The contacts go bad and after it runs for a while the resistance in the switch can pull to much power causing a weak spark. You can bypass it by putting power to the correct wire coming from the ignition.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hard Start when warm, easy start when cold Pinocpao OEM Tech Discussion 4 December 2nd, 2016 17:50
Renix wont start when warm muddypunk OEM Tech Discussion 10 March 8th, 2012 08:04
Renix no start after HO engine install then fire Mike1331 OEM Tech Discussion 11 February 15th, 2010 10:11
Strange renix warm start issue. lawrence OEM Tech Discussion 6 August 24th, 2009 13:07
87 Renix-hard to start when warm Cal-XJ OEM Tech Discussion 10 May 4th, 2007 14:46


All times are GMT -7. The time now is 07:33.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014