NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old November 22nd, 2015, 19:47
Scott26 Scott26 is offline
NAXJA Forum User
 
Join Date: Nov 2015
Location: Columbus Indiana
Posts: 4
New Member - 98 with defrost only

Just got my first XJ 98 with 135K miles. I have been using the search to research why I only have defrost only. I DO have functioning cruise control and have visually inspected the line that runs under the battery box and do not see any cracks etc. Since the cruise works is this an indicator that helps narrow the diagnosis? Any advise would be appreciated.

I hope to get some pictures posted. With the help of a friend and forum member I am replacing many parts to get my almost stock(factory wheels rusted out) XJ ready for several more years of fun.

Thinking of replacing the check valve then maybe running new vacuum lines?
Reply With Quote
  #2  
Old November 23rd, 2015, 06:27
Sidewinder CC's Avatar
Sidewinder CC Sidewinder CC is offline
NAXJA Forum User
 
Join Date: Jul 2010
Location: Canton, Michigan
Posts: 1,022
Re: New Member - 98 with defrost only

Some XJ's have an HVAC check valve, others just have a tee (see pics).

Check for a broken HVAC vacuum tube going in to the firewall. See pics.



Broken tube and fix:



Reply With Quote
  #3  
Old November 23rd, 2015, 09:16
Scott26 Scott26 is offline
NAXJA Forum User
 
Join Date: Nov 2015
Location: Columbus Indiana
Posts: 4
Re: New Member - 98 with defrost only

Thank you for the pictures. Mine has the T at the firewall and the line appears good going through the firewall. The only check valve I see is back at the elbow that connects to the intake, but I am assuming if the cruise works I am not loosing vacuum there?
Reply With Quote
  #4  
Old November 23rd, 2015, 09:59
87manche's Avatar
87manche 87manche is offline
NAXJA Member
 
Join Date: Oct 2005
Location: Ohio
Posts: 15,376
Re: New Member - 98 with defrost only

there's a vacuum harness behind the HVAC control unit.

if someone was rough pulling it out they may be broken.
__________________
RIP Ugly Truck
Reply With Quote
  #5  
Old November 24th, 2015, 05:51
Sidewinder CC's Avatar
Sidewinder CC Sidewinder CC is offline
NAXJA Forum User
 
Join Date: Jul 2010
Location: Canton, Michigan
Posts: 1,022
Re: New Member - 98 with defrost only

OP,

Do you feel any airflow from any other vents when they are selected - even a tiny bit?

Here's a chart that shows the vacuum routing for the various mode selections. Note that when Defrost is selected all vacuum is removed from the actuator. If Defrost is not selected and the Defrost door is driven open (spring loaded actuator) the actuator may be bad, the Defrost door bell crank may be broken and the door remained open when it broke, or the vacuum control tube to the actuator is broken. Note also there is a MIX setting where the floor door is open and the Defrost door is driven part way. If you select MIX (selection #6) and you feel air coming out of the floor vents, as well as the defrost vents, then the actuator is working (partially anyway).



Here's a pic showing the Defrost actuator and the bell crank. The Yellow tube is full Defrost and the Blue tube is Mix (mid position).



You can see the Defrost door actuator bell crank by removing the trim panel and knee blocker from under the steering column and looking up past connector C201. Select Defrost and Mix with the mode selector and watch the movement of the actuator and bell crank. See pic.


.
Reply With Quote
  #6  
Old November 24th, 2015, 10:56
Scott26 Scott26 is offline
NAXJA Forum User
 
Join Date: Nov 2015
Location: Columbus Indiana
Posts: 4
Re: New Member - 98 with defrost only

Thank you very much for the detailed information. There is not air coming out of any of the vents except defrost but I will check them all again to be certain.

I appreciate this very much and will likely dig into this weekend and see what I can find out.

Regards
Scott
Reply With Quote
  #7  
Old November 24th, 2015, 11:00
87manche's Avatar
87manche 87manche is offline
NAXJA Member
 
Join Date: Oct 2005
Location: Ohio
Posts: 15,376
Re: New Member - 98 with defrost only

actuators can be easily tested with a mityvac.
__________________
RIP Ugly Truck
Reply With Quote
  #8  
Old December 1st, 2015, 07:38
Sidewinder CC's Avatar
Sidewinder CC Sidewinder CC is offline
NAXJA Forum User
 
Join Date: Jul 2010
Location: Canton, Michigan
Posts: 1,022
Re: New Member - 98 with defrost only

Scott26,

Any progress?
Reply With Quote
  #9  
Old December 6th, 2015, 14:46
Scott26 Scott26 is offline
NAXJA Forum User
 
Join Date: Nov 2015
Location: Columbus Indiana
Posts: 4
Re: New Member - 98 with defrost only

Today after checking the HVAC unit everything looked good and I went over the vacuum lines and found a small break in the line that I have overlooked previously. Repaired that section of the line and everything worked great. THANKS TO EVERYONE FOR THE ADVISE AND PICTURES.

New radiator, thermostat, water pump, and hoses are next job. Water pump is making little noise and there is a very small radiator leak. Brakes, shocks, rear springs, motor and transmission mount are done.
Reply With Quote
  #10  
Old December 12th, 2016, 06:14
rockosocko rockosocko is offline
NAXJA Forum User
 
Join Date: Oct 2015
Location: NW Mississippi 'yall
Posts: 32
Re: New Member - 98 with defrost only

Sidewinder:
THIS IS GREAT! Just what I need to work on son's 01.
After engine swap there's no HEAT but blower works fine. I mean, mixture door actuator
or ____ isn't working like It used to. (01 cherokee 4x4/auto)

BUT, how 'easy' is it to get to while dash is IN?
I'm kinda busted up @ 54 and it's hard to get under there, and then see with my 'readers' on.

Did you ever think to make a STICKY about this?
In my searching, it looks like there are quite a few vids on Youtube about flapper door 'fixes' and such.

Thank you for offering this to everybody.
Errol
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
No Defrost supersuby483 OEM Tech Discussion 1 November 6th, 2011 05:44
Sweet smell, defrost doesn't defrost and A/C blows hot... gw204 OEM Tech Discussion 4 July 22nd, 2009 18:52
No defrost DieselAirman OEM Tech Discussion 6 November 18th, 2007 15:37
defrost SUA SPONTE OEM Tech Discussion 3 February 25th, 2007 23:52
Defrost bass2323 OEM Tech Discussion 4 December 11th, 2005 17:53


All times are GMT -7. The time now is 17:35.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014