NAXJA Forums -::- North American XJ Association  

Go Back   NAXJA Forums -::- North American XJ Association > NAXJA Unibody Jeep Technical Forums > Jeep Cherokee XJ (1984 - 2001) > OEM Tech Discussion
HOME Member FAQ Sponsor Info Rules Bylaws E-Mail

OEM Tech Discussion Forum for OEM (Original Equipment) or stock XJs and MJs.

Reply
 
Thread Tools Display Modes
  #1  
Old October 23rd, 2007, 07:51
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
P1391, What the ?

Trouble code P1391 - Loss of CMK or CKP ??

Does anybody know what this is?

The truck will run fine until you rev engine up to 2000rpm the engine will drop to 200rpm and giving it throttle wont do anything.
Reply With Quote
  #2  
Old October 23rd, 2007, 10:19
MapleDitch MapleDitch is offline
NAXJA Forum User
 
Join Date: Jun 2007
Location: Mission, BC
Posts: 138
Re: P1391, What the ?

CKP is Chrysler's acronym for CPS or Crank Position Sensor.
Reply With Quote
  #3  
Old October 23rd, 2007, 15:49
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

Thank you, thats what I was thinking but wasnt sure.
The XJ runs good sometimes, the loses all power till i turn off & restart.
Reply With Quote
  #4  
Old October 23rd, 2007, 16:05
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: P1391, What the ?

Sorry about the way these look, but I couldn't copy and paste them so I took screen captures.





Reply With Quote
  #5  
Old October 23rd, 2007, 17:44
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

This info is great, thank you very much.
I just went out & purchased 2nd CPS($106) to ind out thats not the problem. W/this info i can do more testing and less spending.
thank you
Reply With Quote
  #6  
Old October 24th, 2007, 08:51
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: P1391, What the ?

No problem. Post up how things turn out.
Reply With Quote
  #7  
Old October 24th, 2007, 11:24
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

OK, CMP(coil pick up) came up bad, I replaced and now the truck wont start, kicks over sometimes but wont start.
Reply With Quote
  #8  
Old October 24th, 2007, 14:33
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: P1391, What the ?

This is copied from my 1999 F.S.M. I don't know if this will help or not (hope so).
"ENGINE START-UP MODE
This is an Open Loop mode. The following actions occur when the starter motor is engaged. The powertrain control module (PCM) receives inputs from:
² Battery voltage
² Engine coolant temperature sensor
² Crankshaft position sensor
² Intake manifold air temperature sensor
² Manifold absolute pressure (MAP) sensor
² Throttle position sensor (TPS)
² Camshaft position sensor signal
The PCM monitors the crankshaft position sensor. If the PCM does not receive a crankshaft position sensor signal within 3 seconds of cranking the
engine, it will shut down the fuel injection system. The fuel pump is activated by the PCM through the fuel pump relay. Voltage is applied to the fuel injectors with the ASD relay via the PCM. The PCM will then control the injection sequence and injector pulse width by turning the ground circuit to each individual injector on and off. The PCM determines the proper ignition timing according to input received from the crankshaft position
sensor."
Reply With Quote
  #9  
Old October 25th, 2007, 13:23
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

Thanks for info,
The fuel pump is still running, it seems to be pumping fuel like its running, strong smell of gas. Wont start. I couldnt locate another coil pickup(CPS), i think my new one is bad.
Reply With Quote
  #10  
Old October 26th, 2007, 08:41
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

Thanks Timber,
I brought XJ to Jeep, I gave them all I did on paper. Hopefully they find it.
Reply With Quote
  #11  
Old October 26th, 2007, 10:11
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: P1391, What the ?

Good luck.
Reply With Quote
  #12  
Old October 28th, 2007, 07:44
ahm's Avatar
ahm ahm is offline
NAXJA Forum User
 
Join Date: May 2006
Location: Long Island NY
Posts: 60
Re: P1391, What the ?

I Need it.
Well Jeep looked at for 2 hrs and have no idea what it could be. They told me they can cont. to look at but it will get very expensive($98hr). I picked it up and i'm going to check wiring, Jeep said the sensors(Cam & Crank) are good and the timing was good.
Start there first.
Reply With Quote
  #13  
Old November 9th, 2007, 06:12
Frank Z's Avatar
Frank Z Frank Z is offline
NAXJA Member
 
Join Date: Dec 2004
Location: Colorado Springs
Posts: 7,850
Re: P1391, What the ?

Any luck finding the problem? I've getting the same code and have also replaced the Crank Position Sensor.
Reply With Quote
  #14  
Old November 9th, 2007, 19:33
Ricker's Avatar
Ricker Ricker is offline
NAXJA Member
 
Join Date: May 2004
Location: Germansville, Pa.
Posts: 136
Re: P1391, What the ?

Similar problem here. Both sensors are ok. Loss of signal above 2K. Has something to do with the two signals being out of sync. I only get a CEL, no shutdown.
I will post when I discover more.
Rick......
Reply With Quote
  #15  
Old November 10th, 2007, 07:38
Timber's Avatar
Timber Timber is offline
NAXJA Forum User
 
Join Date: Sep 2004
Location: Slohio
Posts: 1,779
Re: P1391, What the ?

In thinking more about this, and please note that I'm just beginning to learn about engines and transmissions, is it possible that a cracked flexplate on an auto. or a bad flywheel on a manual could cause the CKP to send a bad signal?
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -7. The time now is 10:24.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2017, vBulletin Solutions, Inc.
NAXJA and NAXJA logo's Copyright NAXJA. All content/images Copyright NAXJA 1999-2014