PDA

View Full Version : Coolant Question


alexgalexg
November 19th, 2017, 21:13
Okay so my head blew due to the people I had make it do a questionable job. But this question is more related to when I put it back together. Right before the head started letting coolant into the engine I did a water pump. After filling the rad with coolant I stuck a funnel on the filler for the rad while the Jeep was parked on an incline and let it run so I could bleed out the bubbles. I noticed this time that it would suck in a ton of coolant and then spit it back out soon after. Once I finally got it to bleed the air out I did maybe half an hour of driving with perfect temp and good heat in the cab. The next day I found my reservoir was filled to max and opening the coolant cap led to coolant shooting out even though the car sat overnight. Are you not supposed to bleed these on an incline?

RCP Phx
November 20th, 2017, 05:05
What year?

alexgalexg
November 20th, 2017, 06:55
1998 with 4.0

RCP Phx
November 20th, 2017, 10:39
It sounds like you might be getting combustion gases in there. Best to check it with a sniffer! The late years don't really require burping and shouldn't be backfilling the reservoir (possible bad cap also).
What did you do to solve the original problem? New head? Did the block need surfaced?

alexgalexg
November 20th, 2017, 20:33
Put in a new head. Block was good. My best guess is that the head wasnt made well. Not sure how else I have a bad head. The head issues would explain why the coolant put up such a fight. I just put up a video on taking the recent head off the truck if you want to see it and put in your 2 cents
https://youtu.be/zTAmSDXdFek