View Full Version : Brown junk in heater core

October 22nd, 2017, 08:51
I am considering purchasing a 2002 XJ and rejoining your ranks. The only known problem is the heater core keeps clogging up. The current owner was able to clear it and it worked for a couple years but the heat was starting to get weak again last year. My first thought was a head gasket but their is no sign of contamination of the oil or coolant in the radiator. Any thoughts of what might be the cause? Should I gamble and hope it is just a coolant flush, for a clean unmolested, truly driven by a little old lady, XJ?

October 22nd, 2017, 09:11
I would take the gamble if the price is right. Flush it, then run it with some vinegar, then flush it a few more times. Pull the hoses off the heater core and run the garden hoses through it both directions.

You can add a coolant filter on the inlet side of the heater core, but sometimes they're more hassle than help.

October 22nd, 2017, 09:19
We are at $2500 and other than the heat and an ABS controller the jeep is clean. I personally donít like ABS so Iím not too worried about that. It is well under 100k on the truck.


October 22nd, 2017, 10:14
I am considering purchasing a 2002 XJ

There's no such animal !!!

October 22nd, 2017, 13:58
2001 Xj. I was off buy a year

October 22nd, 2017, 19:30
My heater core had the same brown junk in it -- I have no idea on it's previous life -- came to me with 225,000 on the clock

For the heater core I used an Harbor freight 12 volt pump -- a bucket and some coolant system cleaner -- took off the heater hoses from the engine and hooked up the pump dumping one hose into the bucket -- let the pump circulate,from the bucket, just through the heater core -- then switched hoses and did it again -- I ran for about 2 hours switching directions of flow about every 15 minutes and changing my water in the bucket a few times

It ran very clean by the time I was done and the heat is plentiful

October 23rd, 2017, 01:37
Thanks for the info. I was just worried it was an indicator of deeper problems but it seems to be common for these things.

October 24th, 2017, 22:29
Was the coolant ever switched to the Dex cool stuff I think it's a red or orange color that is suppose to be a replacement for the old Greene stuff the P.O. flushed mine and filled with that stuff and I found all kinds of brown looking turds in the coolant reservoir and radiator. When the two mix they create a sludge that looks like someone crapped in the radiator not to mention the Dex cool eats gaskets due to the acid that's in it. If show you a picture of what came out of mine but I'm new to the forum and havnt figured that out yet

November 4th, 2017, 13:31
Mine looked like this before replacing every single component in the cooling system and a complete engine rebuild.https://uploads.tapatalk-cdn.com/20171104/6a8339945802e22fc65893b915ffbfdb.jpghttps://uploads.tapatalk-cdn.com/20171104/0e4a59df7941bb33b94f69cc2f7680a0.jpg

Sent from my SM-G892A using Tapatalk

November 5th, 2017, 18:51
That looks like the work of dex cool

November 5th, 2017, 19:36
That is copper my friend.
Someone sprayed the head gasket prior to installation.
or at least it looks like it lol